Radio fuse - Jeep Commander Forums: Jeep Commander Forum
General Commander Discussion General Discussion involving the Jeep Commander goes here. If it does not fit into a more specific category below, post it here.

 
LinkBack Thread Tools Display Modes
post #1 of 8 (permalink) Old 02-22-2011, 12:12 PM Thread Starter
Junior Member
Points: 17, Level: 1 Points: 17, Level: 1 Points: 17, Level: 1
Level up: 33% Level up: 33% Level up: 33%
Activity: 0% Activity: 0% Activity: 0%
 
tamholmes73's Avatar
 
Join Date: Feb 2011
Posts: 5
Radio fuse

My radio suddenly stopped working...no lights no clock..nothing. I went home and looked at the manual. My boyfriend decided he knew the fuse. Under the hood he removed the #28 fuse and this didnt fix the problem. Instead my check engine light came on. Can someone tell me where the fuse to the radio is and how to get my check engine light off. Please help... I guess I should add that it is a 2008 Jeep Commander...oops...very important detail.

Last edited by tamholmes73; 02-22-2011 at 12:18 PM.
tamholmes73 is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old 02-22-2011, 12:32 PM
Senior Member
Points: 34,360, Level: 100 Points: 34,360, Level: 100 Points: 34,360, Level: 100
Level up: 0% Level up: 0% Level up: 0%
Activity: 0% Activity: 0% Activity: 0%
 
cico7's Avatar
 
Join Date: Sep 2007
Location: mid ohio
Posts: 5,612
Garage
Send a message via MSN to cico7 Send a message via Skype™ to cico7
Left side, under the dash. Fuse 14.
3rd row down, 4th from left.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Benjamin Davis Pirtle
1990-2015
cico7 is offline  
post #3 of 8 (permalink) Old 02-22-2011, 02:02 PM Thread Starter
Junior Member
Points: 17, Level: 1 Points: 17, Level: 1 Points: 17, Level: 1
Level up: 33% Level up: 33% Level up: 33%
Activity: 0% Activity: 0% Activity: 0%
 
tamholmes73's Avatar
 
Join Date: Feb 2011
Posts: 5
Thank you i will try that and let everyone know.
tamholmes73 is offline  
 
post #4 of 8 (permalink) Old 02-23-2011, 02:09 PM Thread Starter
Junior Member
Points: 17, Level: 1 Points: 17, Level: 1 Points: 17, Level: 1
Level up: 33% Level up: 33% Level up: 33%
Activity: 0% Activity: 0% Activity: 0%
 
tamholmes73's Avatar
 
Join Date: Feb 2011
Posts: 5
any other suggestions
tamholmes73 is offline  
post #5 of 8 (permalink) Old 02-23-2011, 03:07 PM
Senior Member
Points: 34,360, Level: 100 Points: 34,360, Level: 100 Points: 34,360, Level: 100
Level up: 0% Level up: 0% Level up: 0%
Activity: 0% Activity: 0% Activity: 0%
 
cico7's Avatar
 
Join Date: Sep 2007
Location: mid ohio
Posts: 5,612
Garage
Send a message via MSN to cico7 Send a message via Skype™ to cico7
was the fuse blown? Did you find it?


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Benjamin Davis Pirtle
1990-2015
cico7 is offline  
post #6 of 8 (permalink) Old 02-23-2011, 03:16 PM Thread Starter
Junior Member
Points: 17, Level: 1 Points: 17, Level: 1 Points: 17, Level: 1
Level up: 33% Level up: 33% Level up: 33%
Activity: 0% Activity: 0% Activity: 0%
 
tamholmes73's Avatar
 
Join Date: Feb 2011
Posts: 5
i couldnt find it
tamholmes73 is offline  
post #7 of 8 (permalink) Old 02-23-2011, 03:19 PM
Banned
Points: 6,103, Level: 50 Points: 6,103, Level: 50 Points: 6,103, Level: 50
Level up: 77% Level up: 77% Level up: 77%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Jan 2008
Location: Ft. Wayne, Indiana
Posts: 1,406
I have an 06, and I am looking at my book as I write this. The #28 fuse under the hood is 20a yellow, labeled "IOD #2 (Audio). There are two fuse boxes under the hood. This fuse is in the one closest to the front of the Jeep. The #14 that cico said is actually a 20a yellow, labeled "Cigar Ltr", at least in my book. We have found errors in these books before. Cico has an 07, I believe. The only other fuse that I can find pertaining to the radio is the one for the amp: #1, 30a pink, labeled "Audio Amp". It is under the dash, to the left of the steering wheel. I do not know why the radio would not work without the amp - it would seem to me you would get a display with no sound, but I have been wrong before. The amp sits on the drivers side by the third row. It has been noted on the forum that water can get in there and short it out.
dhh3 is offline  
post #8 of 8 (permalink) Old 02-23-2011, 03:37 PM Thread Starter
Junior Member
Points: 17, Level: 1 Points: 17, Level: 1 Points: 17, Level: 1
Level up: 33% Level up: 33% Level up: 33%
Activity: 0% Activity: 0% Activity: 0%
 
tamholmes73's Avatar
 
Join Date: Feb 2011
Posts: 5
see in my manual it says IOD off draw so would that still be the correct one.
tamholmes73 is offline  
Sponsored Links
Advertisement
 
Reply

  Jeep Commander Forums: Jeep Commander Forum > Jeep Commander Discussion > General Commander Discussion

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jeep Commander Forums: Jeep Commander Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome