Sunroof Flush? - Jeep Commander Forums: Jeep Commander Forum
General Commander Discussion General Discussion involving the Jeep Commander goes here. If it does not fit into a more specific category below, post it here.

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 03-13-2011, 11:02 AM Thread Starter
Junior Member
Points: 177, Level: 3 Points: 177, Level: 3 Points: 177, Level: 3
Level up: 54% Level up: 54% Level up: 54%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Jan 2011
Posts: 8
Sunroof Flush?

My sunroof is not flush on the front, probably about 1/4 inch low, but it is in the back. Is this normal, my Commander is a 2006. It functions ok, and does not leak or have wind noise.
jamesr is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 03-13-2011, 11:07 AM
Banned
Points: 1,104, Level: 18 Points: 1,104, Level: 18 Points: 1,104, Level: 18
Level up: 4% Level up: 4% Level up: 4%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Mar 2011
Posts: 389
Quote:
Originally Posted by jamesr View Post
My sunroof is not flush on the front, probably about 1/4 inch low, but it is in the back. Is this normal, my Commander is a 2006. It functions ok, and does not leak or have wind noise.
I'd apply the old saying if it ain't broke don't fix it to this...If it don't leak, don't fix it.
CommandSystemsGo! is offline  
post #3 of 5 (permalink) Old 03-13-2011, 11:08 AM
Banned
Points: 6,103, Level: 50 Points: 6,103, Level: 50 Points: 6,103, Level: 50
Level up: 77% Level up: 77% Level up: 77%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Jan 2008
Location: Ft. Wayne, Indiana
Posts: 1,406
When closed, it should be flush with the roof, front to back. Something is not allowing it to raise to the fully closed position, or something in the mechanism is worn. You are lucky it is not leaking.
dhh3 is offline  
 
post #4 of 5 (permalink) Old 03-13-2011, 09:32 PM
Senior Member
Points: 5,186, Level: 46 Points: 5,186, Level: 46 Points: 5,186, Level: 46
Level up: 18% Level up: 18% Level up: 18%
Activity: 0% Activity: 0% Activity: 0%
 
xjtrailrider's Avatar
 
Join Date: Nov 2009
Location: Roanoke VA
Posts: 451
My 09 is flush. I agree with the others, if it aint broke-don't fix it!
xjtrailrider is offline  
post #5 of 5 (permalink) Old 03-13-2011, 11:18 PM
Member
Points: 1,291, Level: 19 Points: 1,291, Level: 19 Points: 1,291, Level: 19
Level up: 91% Level up: 91% Level up: 91%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: May 2010
Posts: 40
i have an 06' as well and it does the same thing but does not leak...
06commander6994 is offline  
Sponsored Links
Advertisement
 
Reply

  Jeep Commander Forums: Jeep Commander Forum > Jeep Commander Discussion > General Commander Discussion

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jeep Commander Forums: Jeep Commander Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome