Service 4WD warning light. - Jeep Commander Forums: Jeep Commander Forum
General Commander Discussion General Discussion involving the Jeep Commander goes here. If it does not fit into a more specific category below, post it here.

 
LinkBack Thread Tools Display Modes
post #1 of 8 (permalink) Old 07-21-2011, 07:53 AM Thread Starter
Junior Member
Points: 5,492, Level: 47 Points: 5,492, Level: 47 Points: 5,492, Level: 47
Level up: 72% Level up: 72% Level up: 72%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Apr 2007
Posts: 18
Service 4WD warning light.

The message 'Service 4WD' has come up on my dash along with the traction control icon and light near the lower center of the cluster.

The manual does not explain this. I have 29,600 miles on it. This happened when it just turned 29,000 miles, and has not happened again until today.

What does this mean? Is it a maintenance warning light or does it indicate that there is something wrong?

Frank.
Frank is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old 07-26-2011, 07:11 AM Thread Starter
Junior Member
Points: 5,492, Level: 47 Points: 5,492, Level: 47 Points: 5,492, Level: 47
Level up: 72% Level up: 72% Level up: 72%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Apr 2007
Posts: 18
....Bump....

Hope somebody can help me with this. I notice no difference at all in operation. Just those messages and lights comming on. Turn Jeep off and they don't come back upon restart. But they will show up randomly.
This just started happening recently. It had a reprogramming when new for the service 4wd message. Stayed off all of these years until last month.

Jeep techs please advise.....
Frank is offline  
post #3 of 8 (permalink) Old 11-06-2011, 08:22 PM
Senior Member
Points: 13,860, Level: 76 Points: 13,860, Level: 76 Points: 13,860, Level: 76
Level up: 53% Level up: 53% Level up: 53%
Activity: 0% Activity: 0% Activity: 0%
 
rubicontrail.net's Avatar
 
Join Date: Oct 2005
Location: Chandler, AZ
Posts: 2,473
Quote:
Originally Posted by Frank View Post
....Bump....

Hope somebody can help me with this. I notice no difference at all in operation. Just those messages and lights comming on. Turn Jeep off and they don't come back upon restart. But they will show up randomly.
This just started happening recently. It had a reprogramming when new for the service 4wd message. Stayed off all of these years until last month.

Jeep techs please advise.....
I have this same issue. It comes and goes and I haven't figured out the cause. The dealer looked at a year ago, flashed the computer, but it comes back every few months.

2007 Jeep Commander Limited, 1998 Jeep Wrangler Sahara, 1955 Willys Jeep Pickup (Restoration Project), 2011 Subaru Outback 2.5i Limited:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
rubicontrail.net is offline  
 
post #4 of 8 (permalink) Old 11-07-2011, 11:30 AM
Senior Member
Points: 8,689, Level: 62 Points: 8,689, Level: 62 Points: 8,689, Level: 62
Level up: 80% Level up: 80% Level up: 80%
Activity: 0% Activity: 0% Activity: 0%
 
Gulf550's Avatar
 
Join Date: Nov 2009
Location: Georgia
Own a Commander?: Yes
Model year: 2006
Trim Package: Limited
Power-Train: 4.7L V-8
4WD
If 4WD - system: QD-II
Current Mileage: 127,000
Posts: 288
Have any off you done the key dance to get the fault codes? Or if you cannot get that to work just goto autozone and they will scan it for free.

2006 Jeep Commander Limited 4.7L QD II.....[I]4in Super lift Supension lift, Defender Roof Rack, 285 70R17 ProComp Xtreme Mud Terrain II tires, JK wheels, Rear grab handles, polished throttle body, RCV performance CV Axles, 4X Guard belly guard, front guard, jeepinbyals upper control arms, borla cat back exhaust and LED off road bar 40" and dully D2's.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Gulf550 is offline  
post #5 of 8 (permalink) Old 11-08-2011, 09:26 AM
Junior Member
Points: 4,252, Level: 41 Points: 4,252, Level: 41 Points: 4,252, Level: 41
Level up: 51% Level up: 51% Level up: 51%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Dec 2006
Location: Madison, MS
Posts: 19
Mine ended up being a shorted wire in the harness going into the front diff that controlled the electronic part of the diff locker. I could reset the code but a few days later it would come back on.

I ended up replacing the electronic diff fork and the harness


1975 Triumph TR6 (Red)
2013 Ford Explorer XLT(Sterling)
2013 Jeep Wrangler Unlimited Rubicon (Billet Metallic)
kthrash is offline  
post #6 of 8 (permalink) Old 11-08-2011, 10:05 AM
Senior Member
Points: 13,860, Level: 76 Points: 13,860, Level: 76 Points: 13,860, Level: 76
Level up: 53% Level up: 53% Level up: 53%
Activity: 0% Activity: 0% Activity: 0%
 
rubicontrail.net's Avatar
 
Join Date: Oct 2005
Location: Chandler, AZ
Posts: 2,473
Mine doesn't throw a code. I have done the "key dance" as well as used my Innova DTC scanner. Both indicate no codes present.

As soon as you switch the key off and back on, the lights and the EVIC message disappear.

This is the same behavior that is outlined in the TSB for 2006 vehicles. Mine is not a 2006 but a very early 2007 (ordered on the day that order banks for 2007s opened).

The dealership supposedly reflashed the FDCM, but it still intermittently happens. It usually happens in freeway driving or surface streets in dry conditions. I can not detect if it has actually deactivated the 4WD.

I am curious if it could possibly caused by the fact that I am running a slightly bigger than stock tire (245/70R17 vs the stock 245/65R17). If I knew that was a cause I would pick up the AEV XK EGR module. However, I don't want to drop nearly $300 on something that MIGHT fix the problem.

2007 Jeep Commander Limited, 1998 Jeep Wrangler Sahara, 1955 Willys Jeep Pickup (Restoration Project), 2011 Subaru Outback 2.5i Limited:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
rubicontrail.net is offline  
post #7 of 8 (permalink) Old 11-08-2011, 11:11 AM
Senior Member
Points: 8,689, Level: 62 Points: 8,689, Level: 62 Points: 8,689, Level: 62
Level up: 80% Level up: 80% Level up: 80%
Activity: 0% Activity: 0% Activity: 0%
 
Gulf550's Avatar
 
Join Date: Nov 2009
Location: Georgia
Own a Commander?: Yes
Model year: 2006
Trim Package: Limited
Power-Train: 4.7L V-8
4WD
If 4WD - system: QD-II
Current Mileage: 127,000
Posts: 288
I don't think it's because of your tires, a lot of members are running larger tires and don't have that problem. This might be an item that you have to go back to the dealer with. Maybe someone else might chime in.

2006 Jeep Commander Limited 4.7L QD II.....[I]4in Super lift Supension lift, Defender Roof Rack, 285 70R17 ProComp Xtreme Mud Terrain II tires, JK wheels, Rear grab handles, polished throttle body, RCV performance CV Axles, 4X Guard belly guard, front guard, jeepinbyals upper control arms, borla cat back exhaust and LED off road bar 40" and dully D2's.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Gulf550 is offline  
post #8 of 8 (permalink) Old 11-15-2011, 05:35 PM
Senior Member
Points: 5,718, Level: 48 Points: 5,718, Level: 48 Points: 5,718, Level: 48
Level up: 84% Level up: 84% Level up: 84%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Aug 2008
Location: Near Detroit Michigan
Posts: 125
Brake Light Switch?

My '08 had similar warning lights, intermittent. While warning lights were on the cruise control would not work.

Turned out the brake light switch had a problem, causing the computer to think the brakes were being applied under acceleration, which in turn caused the warning lights to come on. Since the brake switch also turns the cruise control off, when it stuck the cruise couldn't be turned on.

I imagine a few people following me had some unkind words when the brake lights came on at oddball times.

Dealer covered under warranty.

HTH

Jim
FmrVette is offline  
Sponsored Links
Advertisement
 
Reply

  Jeep Commander Forums: Jeep Commander Forum > Jeep Commander Discussion > General Commander Discussion

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jeep Commander Forums: Jeep Commander Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome