Jeep is Running Sluggish - Jeep Commander Forums: Jeep Commander Forum
General Commander Discussion General Discussion involving the Jeep Commander goes here. If it does not fit into a more specific category below, post it here.

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 07-22-2011, 09:18 PM Thread Starter
Junior Member
Points: 8, Level: 1 Points: 8, Level: 1 Points: 8, Level: 1
Level up: 15% Level up: 15% Level up: 15%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Jul 2011
Posts: 2
Jeep is Running Sluggish

Hey folks, new member here. I have a 2008, 3.7L V6 Jeep Commander that is experiencing a weird problem. When I press the gas pedal all the way down to the floor, the speedometer shows that I am only moving about 30Mph, however, it feels as if I am moving half that speed. Obviously, I have a problem but I am wondering if anyone here has experienced the same issue? I don't even know where to begin with searching for the problem (using the search function), because the problem description is too long. Please help out a noob. Thanks.
Junkman2008 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 07-23-2011, 03:51 AM
Junior Member
Points: 48, Level: 1 Points: 48, Level: 1 Points: 48, Level: 1
Level up: 96% Level up: 96% Level up: 96%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Jul 2011
Location: Camarillo, CA
Posts: 9
Send a message via MSN to crazyforjeeps Send a message via Skype™ to crazyforjeeps
Have you tried to reset your ECM? Disconnect your battery for a few minutes and see that that work?
crazyforjeeps is offline  
post #3 of 3 (permalink) Old 07-23-2011, 05:26 AM Thread Starter
Junior Member
Points: 8, Level: 1 Points: 8, Level: 1 Points: 8, Level: 1
Level up: 15% Level up: 15% Level up: 15%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Jul 2011
Posts: 2
No, I haven't tried that. I don't even know what the ECM is. I had some work done on the brakes that fixed the problem for a few days but now the problem is back. I assume that ECM stands for Electronic Control Module? Is this a common failure point?
Junkman2008 is offline  
Sponsored Links
Advertisement
 
Reply

  Jeep Commander Forums: Jeep Commander Forum > Jeep Commander Discussion > General Commander Discussion

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jeep Commander Forums: Jeep Commander Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome