MDS Light Not Turning on - Jeep Commander Forums: Jeep Commander Forum
General Commander Discussion General Discussion involving the Jeep Commander goes here. If it does not fit into a more specific category below, post it here.

 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 08-26-2011, 10:02 PM Thread Starter
Member
Points: 6,560, Level: 53 Points: 6,560, Level: 53 Points: 6,560, Level: 53
Level up: 5% Level up: 5% Level up: 5%
Activity: 0% Activity: 0% Activity: 0%
 
gambit023's Avatar
 
Join Date: Aug 2011
Location: Maryland
Own a Commander?: Yes
Model year: 2006
Trim Package: Overland
Power-Train: 5.7L V-8 Hemi
4WD
If 4WD - system: QD-II
Current Mileage: 114000
Posts: 47
MDS / ECO Indicator Light 2009 Commander Hemi

I just picked up a 2009 Commander Overland which comes standard with the 5.7 HEMI. However, I've noticed that the ECO or MDS does not come on in the instrument cluster.

I remember driving a 2009 Limited HEMI and it did come on at highway speed and coasting.

I read on a Ram forum that the computer needs to be flashed with the latest update to have this feature.

Is this true?


Thanks,
New Commander Owner

Last edited by gambit023; 08-27-2011 at 10:46 AM. Reason: edit
gambit023 is offline  
Sponsored Links
Advertisement
 
Reply

  Jeep Commander Forums: Jeep Commander Forum > Jeep Commander Discussion > General Commander Discussion

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jeep Commander Forums: Jeep Commander Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome