Rack and Pinion Steering Gear fails - Jeep Commander Forums: Jeep Commander Forum
General Commander Discussion General Discussion involving the Jeep Commander goes here. If it does not fit into a more specific category below, post it here.

 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old 04-20-2012, 12:13 PM Thread Starter
Senior Member
Points: 134,048, Level: 100 Points: 134,048, Level: 100 Points: 134,048, Level: 100
Level up: 0% Level up: 0% Level up: 0%
Activity: 0% Activity: 0% Activity: 0%
 
Yeggster's Avatar
 
Join Date: Dec 2008
Location: Orillia, Ontario, Canada
Own a Commander?: No
Model year: 2006
Trim Package: Sport
2WD
If 4WD - system: QT-I
Posts: 1,352
Rack and Pinion Steering Gear fails

The Steering Gear or rack and pinion is failing in my 2006 Commander

It starte with the steering pump making that whining noise, and then it got really had to steer at idle.

I found a used one for only $100 so that's good ... I'll report how much my local garage charges for labour.

My plan is to keep the old one and have it rebuilt for a spare incase the used one fails.

Anyone had experience with replacing with used? ... The Commander it's off of has 176000 miles on it.

OH and what about driving it in this condition? if it does not get fixed by end of next week I have a three day trip I'm planning ... is it OK to keep driving it with the failing rack and pinion?

2006 Limited, Chrome and Black, tan leather interior, DVD, Hemi, custom front hitch tow hooks and towbar clips, Remote mounted washable Pure Power oil filter, Futomo Valve.
Yeggster is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 04-20-2012, 06:50 PM
Senior Member
Points: 11,816, Level: 71 Points: 11,816, Level: 71 Points: 11,816, Level: 71
Level up: 42% Level up: 42% Level up: 42%
Activity: 0% Activity: 0% Activity: 0%
 
robby's Avatar
 
Join Date: Jun 2008
Location: Desplaines IL.
Posts: 3,262
Other than your forearms looking like they belong on Popeye, you won't harm anything by continued operation.

However, I don't understand how you have determined the rack is the failure, my friend.
I'm thinking the pump died and you are indicating it was whining, a sign of internal fluid bypassing.

On another note, it is good to hear from you......hope life is coming back together for you and your family.

Rob


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
|
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
|
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
robby is offline  
post #3 of 7 (permalink) Old 04-20-2012, 10:20 PM
Senior Member
Points: 11,873, Level: 71 Points: 11,873, Level: 71 Points: 11,873, Level: 71
Level up: 56% Level up: 56% Level up: 56%
Activity: 0% Activity: 0% Activity: 0%
 
bob123's Avatar
 
Join Date: Jul 2006
Location: Nashville, TN
Posts: 707
Yeggster: Have you ever changed the power steering fluid? If not, do you think this could have caused the pump and/or rack to fail? How many miles do you have on your 2006?

2006 Black 65th Anniversary Edition
3.7L V6

Last edited by bob123; 04-20-2012 at 10:24 PM.
bob123 is offline  
 
post #4 of 7 (permalink) Old 04-21-2012, 07:49 AM Thread Starter
Senior Member
Points: 134,048, Level: 100 Points: 134,048, Level: 100 Points: 134,048, Level: 100
Level up: 0% Level up: 0% Level up: 0%
Activity: 0% Activity: 0% Activity: 0%
 
Yeggster's Avatar
 
Join Date: Dec 2008
Location: Orillia, Ontario, Canada
Own a Commander?: No
Model year: 2006
Trim Package: Sport
2WD
If 4WD - system: QT-I
Posts: 1,352
Quote:
Originally Posted by robby View Post
Other than your forearms looking like they belong on Popeye, you won't harm anything by continued operation.

However, I don't understand how you have determined the rack is the failure, my friend.
I'm thinking the pump died and you are indicating it was whining, a sign of internal fluid bypassing.

On another note, it is good to hear from you......hope life is coming back together for you and your family.

Rob
Thankyou!

Frankly I'm not 100% sure how they know it's the steering gear that has failed ... But a pressure test has shown its not the pump and there is no leaks ... I'm trusting my local mechanic and he had always been good to me ... I will report back how it goes!

2006 Limited, Chrome and Black, tan leather interior, DVD, Hemi, custom front hitch tow hooks and towbar clips, Remote mounted washable Pure Power oil filter, Futomo Valve.
Yeggster is offline  
post #5 of 7 (permalink) Old 04-21-2012, 07:59 AM Thread Starter
Senior Member
Points: 134,048, Level: 100 Points: 134,048, Level: 100 Points: 134,048, Level: 100
Level up: 0% Level up: 0% Level up: 0%
Activity: 0% Activity: 0% Activity: 0%
 
Yeggster's Avatar
 
Join Date: Dec 2008
Location: Orillia, Ontario, Canada
Own a Commander?: No
Model year: 2006
Trim Package: Sport
2WD
If 4WD - system: QT-I
Posts: 1,352
Quote:
Originally Posted by bob123 View Post
Yeggster: Have you ever changed the power steering fluid? If not, do you think this could have caused the pump and/or rack to fail? How many miles do you have on your 2006?
I only have about 40,000 miles and have not changed the P\S oil just added a little once ... I don't think the oil or fluid is a factor ... I assume the rack and pinion steering gear failed due to a combination of it being to "light duty" in original construction and my rough driving habits

2006 Limited, Chrome and Black, tan leather interior, DVD, Hemi, custom front hitch tow hooks and towbar clips, Remote mounted washable Pure Power oil filter, Futomo Valve.
Yeggster is offline  
post #6 of 7 (permalink) Old 04-21-2012, 08:06 AM
Junior Member
Points: 24, Level: 1 Points: 24, Level: 1 Points: 24, Level: 1
Level up: 47% Level up: 47% Level up: 47%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Apr 2012
Location: Grand Junction Co
Posts: 1
Just FYI my 2006 limited hemi with a 2" spacer lift just had the entire rack and pinion replaced at the dealer for the tune of $1800 and change just before i bought it and it only has 54000 miles, this could be a weak link.
Granahan378 is offline  
post #7 of 7 (permalink) Old 04-21-2012, 08:24 AM Thread Starter
Senior Member
Points: 134,048, Level: 100 Points: 134,048, Level: 100 Points: 134,048, Level: 100
Level up: 0% Level up: 0% Level up: 0%
Activity: 0% Activity: 0% Activity: 0%
 
Yeggster's Avatar
 
Join Date: Dec 2008
Location: Orillia, Ontario, Canada
Own a Commander?: No
Model year: 2006
Trim Package: Sport
2WD
If 4WD - system: QT-I
Posts: 1,352
Quote:
Originally Posted by Granahan378 View Post
Just FYI my 2006 limited hemi with a 2" spacer lift just had the entire rack and pinion replaced at the dealer for the tune of $1800 and change just before i bought it and it only has 54000 miles, this could be a weak link.
Yes i agree ... I'm driving on my way now to pick up a used steering gear ... my plan is after its changed ... is to save the original and send it away to be rebuilt so I have a spare one.

2006 Limited, Chrome and Black, tan leather interior, DVD, Hemi, custom front hitch tow hooks and towbar clips, Remote mounted washable Pure Power oil filter, Futomo Valve.
Yeggster is offline  
Sponsored Links
Advertisement
 
Reply

  Jeep Commander Forums: Jeep Commander Forum > Jeep Commander Discussion > General Commander Discussion

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jeep Commander Forums: Jeep Commander Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome