Excessive hydroplaning? - Jeep Commander Forums: Jeep Commander Forum
General Commander Discussion General Discussion involving the Jeep Commander goes here. If it does not fit into a more specific category below, post it here.

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 18 (permalink) Old 09-17-2012, 10:13 PM Thread Starter
Senior Member
Points: 6,137, Level: 50 Points: 6,137, Level: 50 Points: 6,137, Level: 50
Level up: 94% Level up: 94% Level up: 94%
Activity: 0% Activity: 0% Activity: 0%
 
BrendenV's Avatar
 
Join Date: Feb 2011
Location: Fredericksburg VA
Posts: 301
Excessive hydroplaning?

So it might just be me but I'm wondering why when I drive in the slightest drizzle of rain with my 4.7 xk that it seems so squirrely? I'm on nitto terra grappler all terrains and yea they're getting a little worn but should a 5,200 pound vehicle with AWD QT-ll be all over the road? Is anyone else having this problem? Recently I rode in my brothers 5.0 explorer Eddie Bauer and that thing didn't even move when going over puddles at high speeds. It's gotten to the point where I'm having to seriously slow down or grip the steering wheel very hard to keep it straight in the rain. Seems odd, maybe it's just me?


Sent from my Autoguide iPhone app
BrendenV is offline  
Sponsored Links
Advertisement
 
post #2 of 18 (permalink) Old 09-17-2012, 10:19 PM
Super Moderator
Points: 59,473, Level: 100 Points: 59,473, Level: 100 Points: 59,473, Level: 100
Level up: 0% Level up: 0% Level up: 0%
Activity: 77% Activity: 77% Activity: 77%
 
jeep5253's Avatar
 
Join Date: Jun 2006
Own a Commander?: Yes
Model year: 2006
Trim Package: Limited
Power-Train: 5.7L V-8 Hemi
4WD
If 4WD - system: QD-II
Posts: 14,897
Might be a problem with your traction control.

2006 Steel Blue 5.7L HEMI Limited 4x4 Build Date: June 9, 2006 Hour 14
Interior: Dark Slate/Light Graystone with Saddle Brown Leather Seats
Quadra-Drive II, NAV, DVD, Trailer Tow Group IV, Off-Road Group II, Remote Start, UConnect, Rear Backup Camera, Chrome Wheels,
Magnaflow cat-back exhaust, Daytime Running Lights enabled, 2" Rough Country Lift with 265/70R17 Goodyear Wrangler AT/S
jeep5253 is offline  
post #3 of 18 (permalink) Old 09-18-2012, 10:32 AM Thread Starter
Senior Member
Points: 6,137, Level: 50 Points: 6,137, Level: 50 Points: 6,137, Level: 50
Level up: 94% Level up: 94% Level up: 94%
Activity: 0% Activity: 0% Activity: 0%
 
BrendenV's Avatar
 
Join Date: Feb 2011
Location: Fredericksburg VA
Posts: 301
That what I'm hoping isn't the problem! Should this be a dealer issue or is there a way to attempt to get it right?


Sent from my Autoguide iPhone app
BrendenV is offline  
 
post #4 of 18 (permalink) Old 09-18-2012, 10:39 AM
Senior Member
Points: 14,892, Level: 79 Points: 14,892, Level: 79 Points: 14,892, Level: 79
Level up: 9% Level up: 9% Level up: 9%
Activity: 0% Activity: 0% Activity: 0%
 
GPintheMitten's Avatar
 
Join Date: Nov 2008
Location: Flushing, Michigan
Posts: 2,406
I assume you've checked air pressures, but if not, check that. In addition, when you say tires are a little worn, I wonder how much exactly. What is your tread depth? That makes a big difference in shedding water on the road. My guess is that it's time for new tires, or slow down in the rain. Once the friction is gone, ABS, 4WD doesn't do a thing.

2007 XK Limited, 5.7L Hemi, QDII, Rusty's 2" lift, Spidertrax 1.5 inch wheel spacers, GetLost4x4's front hitch mount for portable winch.GY Duratracs 265/70R17s , Rola Roof Rack, diy built spare tire mount for the roof rack.
GPintheMitten is offline  
post #5 of 18 (permalink) Old 09-18-2012, 12:37 PM Thread Starter
Senior Member
Points: 6,137, Level: 50 Points: 6,137, Level: 50 Points: 6,137, Level: 50
Level up: 94% Level up: 94% Level up: 94%
Activity: 0% Activity: 0% Activity: 0%
 
BrendenV's Avatar
 
Join Date: Feb 2011
Location: Fredericksburg VA
Posts: 301
Haven't checked tire pressure I've been trusting my TPMS system. This has been going on for some time even when the tires were much newer and had more tread.

This may be another issue but I've been noticing even on dry pavement if I hit the slightest bump I'm all over the road. It seems more top heavy and unstable around turns which makes me think maybe shocks and struts going bad? There is excessive noise from the front suspension when hitting bumps like metal/metal clunking. I have the 2" RC lift and I posted this is issue before but I couldn't figure it out.


Sent from my Autoguide iPhone app
BrendenV is offline  
post #6 of 18 (permalink) Old 09-18-2012, 01:51 PM
Member
Points: 1,205, Level: 19 Points: 1,205, Level: 19 Points: 1,205, Level: 19
Level up: 5% Level up: 5% Level up: 5%
Activity: 0% Activity: 0% Activity: 0%
 
JpCommanderXK's Avatar
 
Join Date: Mar 2012
Location: Rochester, NY
Posts: 88
As gpinthemiten said, once traction has been lost you can have the best system in the world and its not going to help much.. I would start with your tires as they are the first thing to cause loss of traction. As far as the suspension noise what type of mileage do you have, how much wheeling do you do and have you considered going to the OME HD lift? I have BFGs KOs with maybe 50% tread with not much problems. I highly doubt your suspension is causing hydroplaning issues but I may be wrong, Id start with new tires especially if the are worn, if you are looking for new A/Ts Ive read/heard great things about the Silent Armors and General AT2s..

2006 Jeep Green/Saddle Brown Leather HEMI QDII OME HD w/Fox Emulsion 2.0 Rear Shocks SpiderTraxx 1.5" 265/70R17 Goodyear MTRs w/Kevlar Ture Duals w/Imco 50 k&n 63 CAI Full Mopar Skids Tow Package
Tow Hooks SteelArmadillo Belly Skid Diablo 91 Tuned
JpCommanderXK is offline  
post #7 of 18 (permalink) Old 09-18-2012, 02:28 PM Thread Starter
Senior Member
Points: 6,137, Level: 50 Points: 6,137, Level: 50 Points: 6,137, Level: 50
Level up: 94% Level up: 94% Level up: 94%
Activity: 0% Activity: 0% Activity: 0%
 
BrendenV's Avatar
 
Join Date: Feb 2011
Location: Fredericksburg VA
Posts: 301
I just hit 80,000 miles the lift has been on for about 15,000 the noise has always been there. I don't wheel often I've gone up a trail probably 3 times. I'll look into the new tires my budget is limited at this point. I haven't looked into a different lift either. I've contacted rough country about my spindle hitting the springs on sharp turns and they wouldn't respond even after I sent pics.


Sent from my Autoguide iPhone app
BrendenV is offline  
post #8 of 18 (permalink) Old 09-19-2012, 08:59 AM
Senior Member
Points: 14,892, Level: 79 Points: 14,892, Level: 79 Points: 14,892, Level: 79
Level up: 9% Level up: 9% Level up: 9%
Activity: 0% Activity: 0% Activity: 0%
 
GPintheMitten's Avatar
 
Join Date: Nov 2008
Location: Flushing, Michigan
Posts: 2,406
Did you get a front end alignment after the lift?

2007 XK Limited, 5.7L Hemi, QDII, Rusty's 2" lift, Spidertrax 1.5 inch wheel spacers, GetLost4x4's front hitch mount for portable winch.GY Duratracs 265/70R17s , Rola Roof Rack, diy built spare tire mount for the roof rack.
GPintheMitten is offline  
post #9 of 18 (permalink) Old 09-19-2012, 12:04 PM Thread Starter
Senior Member
Points: 6,137, Level: 50 Points: 6,137, Level: 50 Points: 6,137, Level: 50
Level up: 94% Level up: 94% Level up: 94%
Activity: 0% Activity: 0% Activity: 0%
 
BrendenV's Avatar
 
Join Date: Feb 2011
Location: Fredericksburg VA
Posts: 301
I did not get an alignment


Sent from my Autoguide iPhone app
BrendenV is offline  
post #10 of 18 (permalink) Old 09-19-2012, 03:50 PM
Member
Points: 1,205, Level: 19 Points: 1,205, Level: 19 Points: 1,205, Level: 19
Level up: 5% Level up: 5% Level up: 5%
Activity: 0% Activity: 0% Activity: 0%
 
JpCommanderXK's Avatar
 
Join Date: Mar 2012
Location: Rochester, NY
Posts: 88
I would get an alignment and possibly look into new tires. General ATs are a great tire and 4 @$580 tirerack is not a bad deal. Also look into wrangler take offs even slightly used are going cheap. I havent had any issues so far and my BFGs are less than 50%, I would have to assume your tires are done for..

2006 Jeep Green/Saddle Brown Leather HEMI QDII OME HD w/Fox Emulsion 2.0 Rear Shocks SpiderTraxx 1.5" 265/70R17 Goodyear MTRs w/Kevlar Ture Duals w/Imco 50 k&n 63 CAI Full Mopar Skids Tow Package
Tow Hooks SteelArmadillo Belly Skid Diablo 91 Tuned
JpCommanderXK is offline  
Sponsored Links
Advertisement
 
Reply

  Jeep Commander Forums: Jeep Commander Forum > Jeep Commander Discussion > General Commander Discussion

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jeep Commander Forums: Jeep Commander Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome