Click click!! car won't start - Jeep Commander Forums: Jeep Commander Forum
General Commander Discussion General Discussion involving the Jeep Commander goes here. If it does not fit into a more specific category below, post it here.

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 15 (permalink) Old 03-15-2014, 05:59 PM Thread Starter
Junior Member
Points: 30, Level: 1 Points: 30, Level: 1 Points: 30, Level: 1
Level up: 60% Level up: 60% Level up: 60%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Mar 2014
Posts: 4
Click click!! car won't start

Background-a new battery was put in in December, an ignition switch was also put in in December, the starter was put in in less than a year.

I am hearing a clicking sound as I attempt to start my car. I take it to AutoZone and they test everything and everything, including the alternator comes back A-ok. I get a jump and the car runs until I turn it off. I'm getting a jump to go throughout the day to make it home.

What is draining my battery?
Attached Thumbnails
Click image for larger version

Name:	086.jpg
Views:	128
Size:	444.7 KB
ID:	10010  
StuckinFayetteville is offline  
Sponsored Links
Advertisement
 
post #2 of 15 (permalink) Old 03-16-2014, 12:38 PM
Senior Member
Points: 4,098, Level: 40 Points: 4,098, Level: 40 Points: 4,098, Level: 40
Level up: 74% Level up: 74% Level up: 74%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Jun 2012
Location: Vancouver Island, BC, Canada
Posts: 173
So you had your battery tested and it's dead?

06 Hemi
Eric S is offline  
post #3 of 15 (permalink) Old 03-16-2014, 05:55 PM
Senior Member
Points: 27,950, Level: 98 Points: 27,950, Level: 98 Points: 27,950, Level: 98
Level up: 60% Level up: 60% Level up: 60%
Activity: 0% Activity: 0% Activity: 0%
 
07JeepXK's Avatar
 
Join Date: Sep 2007
Location: Orchard Park, NY
Posts: 6,311
Click click is a dead battery. Sounds like your alternator isn't charging the batter or you have something draining the battery.




2007 4.7 Liter XK | Front OME MD Springs w/Superlift Preload Spacer | Rear 4" Superlift Springs | Bilstein 5125 Rear Shocks | JBA UCA's | Rusty's Rear Adjustable Track Bar | Black Rock 997 Wheels | Fred Goeske 1/4 Inch Wheel Spacers | 305/70R17 Goodyear Wrangler MT/R w/Kevlar | Airflow Snorkel | Flowmaster 40 Series Muffler | Superchips Flashpaq | Mopar Skids | 4xGuard Belly Guard | American Rebel Rear Diff Cover | Rear Powertrax No-Slip | Front E-Locker | Rear Heat/AC Delete
07JeepXK is offline  
 
post #4 of 15 (permalink) Old 03-16-2014, 06:13 PM
Senior Member
Points: 4,098, Level: 40 Points: 4,098, Level: 40 Points: 4,098, Level: 40
Level up: 74% Level up: 74% Level up: 74%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Jun 2012
Location: Vancouver Island, BC, Canada
Posts: 173
If you have been jumping it and driving around your alternator is working fine. Most likely your battery is fried but it could be a poor connection to the terminals (give them a good cleaning. Have the battery load tested. It is definitely not fine at the very least it needs to be put on a charger. If it was working okay it should have charged up while driving and if you turn it off the battery should have no problem starting again. If you have something draining the battery with the Jeep off it might not start after a few hours not immediately.

06 Hemi
Eric S is offline  
post #5 of 15 (permalink) Old 03-16-2014, 10:09 PM Thread Starter
Junior Member
Points: 30, Level: 1 Points: 30, Level: 1 Points: 30, Level: 1
Level up: 60% Level up: 60% Level up: 60%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Mar 2014
Posts: 4
reply

My battery isn't dead...everything test fine and fully charged.
StuckinFayetteville is offline  
post #6 of 15 (permalink) Old 03-16-2014, 10:11 PM Thread Starter
Junior Member
Points: 30, Level: 1 Points: 30, Level: 1 Points: 30, Level: 1
Level up: 60% Level up: 60% Level up: 60%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Mar 2014
Posts: 4
reply

It seems as if it isn't charging while I'm driving because it cuts off and won't restart immediately after I cut the car off unless I've had it charging all night.
StuckinFayetteville is offline  
post #7 of 15 (permalink) Old 03-16-2014, 11:06 PM
Super Moderator
Points: 59,418, Level: 100 Points: 59,418, Level: 100 Points: 59,418, Level: 100
Level up: 0% Level up: 0% Level up: 0%
Activity: 36% Activity: 36% Activity: 36%
 
jeep5253's Avatar
 
Join Date: Jun 2006
Own a Commander?: Yes
Model year: 2006
Trim Package: Limited
Power-Train: 5.7L V-8 Hemi
4WD
If 4WD - system: QD-II
Posts: 14,885
Quote:
Originally Posted by StuckinFayetteville View Post
It seems as if it isn't charging while I'm driving because it cuts off and won't restart immediately after I cut the car off unless I've had it charging all night.
As quite a few members here have found out, a battery can test 'good' but still be bad. Are you in Fayetteville, NC ?

2006 Steel Blue 5.7L HEMI Limited 4x4 Build Date: June 9, 2006 Hour 14
Interior: Dark Slate/Light Graystone with Saddle Brown Leather Seats
Quadra-Drive II, NAV, DVD, Trailer Tow Group IV, Off-Road Group II, Remote Start, UConnect, Rear Backup Camera, Chrome Wheels,
Magnaflow cat-back exhaust, Daytime Running Lights enabled, 2" Rough Country Lift with 265/70R17 Goodyear Wrangler AT/S
jeep5253 is offline  
post #8 of 15 (permalink) Old 03-16-2014, 11:06 PM
Member
Points: 435, Level: 8 Points: 435, Level: 8 Points: 435, Level: 8
Level up: 70% Level up: 70% Level up: 70%
Activity: 0% Activity: 0% Activity: 0%
 
bkilby's Avatar
 
Join Date: Feb 2014
Location: Burbank Ca
Posts: 66
Clean the terminals. They might look ok but could have a film of corrosion that you can't see. That's all it takes.
bkilby is offline  
post #9 of 15 (permalink) Old 03-16-2014, 11:08 PM
Member
Points: 435, Level: 8 Points: 435, Level: 8 Points: 435, Level: 8
Level up: 70% Level up: 70% Level up: 70%
Activity: 0% Activity: 0% Activity: 0%
 
bkilby's Avatar
 
Join Date: Feb 2014
Location: Burbank Ca
Posts: 66
Also, did they test the starter itself? Could have a bad solenoid in it. Next time it clicks clicks, turn on the headlights and watch how much they dim when you try to start it. If they dim a lot, check the battery and connections. If they dim a little, check the starter.
bkilby is offline  
post #10 of 15 (permalink) Old 03-17-2014, 04:55 AM
Senior Member
Points: 27,950, Level: 98 Points: 27,950, Level: 98 Points: 27,950, Level: 98
Level up: 60% Level up: 60% Level up: 60%
Activity: 0% Activity: 0% Activity: 0%
 
07JeepXK's Avatar
 
Join Date: Sep 2007
Location: Orchard Park, NY
Posts: 6,311
If it was the starter it wouldn't start when it's jumped off another vehicle.




2007 4.7 Liter XK | Front OME MD Springs w/Superlift Preload Spacer | Rear 4" Superlift Springs | Bilstein 5125 Rear Shocks | JBA UCA's | Rusty's Rear Adjustable Track Bar | Black Rock 997 Wheels | Fred Goeske 1/4 Inch Wheel Spacers | 305/70R17 Goodyear Wrangler MT/R w/Kevlar | Airflow Snorkel | Flowmaster 40 Series Muffler | Superchips Flashpaq | Mopar Skids | 4xGuard Belly Guard | American Rebel Rear Diff Cover | Rear Powertrax No-Slip | Front E-Locker | Rear Heat/AC Delete
07JeepXK is offline  
Sponsored Links
Advertisement
 
Reply

  Jeep Commander Forums: Jeep Commander Forum > Jeep Commander Discussion > General Commander Discussion

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jeep Commander Forums: Jeep Commander Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome