Starter Hangs Up - Jeep Commander Forums: Jeep Commander Forum
General Commander Discussion General Discussion involving the Jeep Commander goes here. If it does not fit into a more specific category below, post it here.

 
LinkBack Thread Tools Display Modes
post #1 of 8 (permalink) Old 06-03-2014, 07:17 PM Thread Starter
Member
Points: 1,918, Level: 26 Points: 1,918, Level: 26 Points: 1,918, Level: 26
Level up: 18% Level up: 18% Level up: 18%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Apr 2014
Posts: 87
Starter Hangs Up

In the month or two i've had my commander, this has only happened twice. But i'm wondering if it is normal or I need to have something looked at. When i try to start the jeep, it doesn't crank as soon as i turn the key like it normally does, so i let go of the key. But even though i let go of the key, the starter continues to try to crank and eventually does. Maybe 2 seconds after i've let off the key. Does this happen to anyone else?
music_man185 is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old 06-04-2014, 12:25 PM
Junior Member
Points: 1,596, Level: 22 Points: 1,596, Level: 22 Points: 1,596, Level: 22
Level up: 96% Level up: 96% Level up: 96%
Activity: 0% Activity: 0% Activity: 0%
 
WBJEEP's Avatar
 
Join Date: May 2014
Location: Wrightsville Beach, NC
Posts: 14
What year is your Commander? Could have a worn out starter. Have you checked all of your connections between the battery and the starter? Any corrosion? That would be first step I would take.

Heaven goes by favor. If it went by merit, you would stay out and your dog would go in. - Mark Twain
WBJEEP is offline  
post #3 of 8 (permalink) Old 06-05-2014, 05:53 AM
Senior Member
Points: 7,833, Level: 59 Points: 7,833, Level: 59 Points: 7,833, Level: 59
Level up: 42% Level up: 42% Level up: 42%
Activity: 0% Activity: 0% Activity: 0%
 
rhobll's Avatar
 
Join Date: Feb 2011
Location: pittsburgh pa
Own a Commander?: Yes
Model year: 2006
Trim Package: Sport
Power-Train: 3.7L V-6
4WD
If 4WD - system: QT-I
Current Mileage: 125K
Posts: 546
my guess would be the connection at the starter motor, corrosion


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

2006 3.7l Silver black and crome Sport W QT1
K&N cai. Aridium 1X plugs. 1.5" Spider Trax...
Tinted windows gone. Got ticketed for 137.50!! Full Synthetic motor oil and many more mods...
rhobll is offline  
 
post #4 of 8 (permalink) Old 06-05-2014, 11:49 AM
Senior Member
Points: 4,098, Level: 40 Points: 4,098, Level: 40 Points: 4,098, Level: 40
Level up: 74% Level up: 74% Level up: 74%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Jun 2012
Location: Vancouver Island, BC, Canada
Posts: 173
It is not normal. Sounds like your your starter needs to be replaced. Seems like it is engaging but the gear is jamming up.

06 Hemi
Eric S is offline  
post #5 of 8 (permalink) Old 06-05-2014, 02:01 PM
Senior Member
Points: 27,950, Level: 98 Points: 27,950, Level: 98 Points: 27,950, Level: 98
Level up: 60% Level up: 60% Level up: 60%
Activity: 0% Activity: 0% Activity: 0%
 
07JeepXK's Avatar
 
Join Date: Sep 2007
Location: Orchard Park, NY
Posts: 6,311
Quote:
Originally Posted by music_man185 View Post
In the month or two i've had my commander, this has only happened twice. But i'm wondering if it is normal or I need to have something looked at. When i try to start the jeep, it doesn't crank as soon as i turn the key like it normally does, so i let go of the key. But even though i let go of the key, the starter continues to try to crank and eventually does. Maybe 2 seconds after i've let off the key. Does this happen to anyone else?
I've had this same problem. It doesnt happen often at all and I don't believe it's done it in the past year or so. It's something to do with the ignition, not the starter believe it or not




2007 4.7 Liter XK | Front OME MD Springs w/Superlift Preload Spacer | Rear 4" Superlift Springs | Bilstein 5125 Rear Shocks | JBA UCA's | Rusty's Rear Adjustable Track Bar | Black Rock 997 Wheels | Fred Goeske 1/4 Inch Wheel Spacers | 305/70R17 Goodyear Wrangler MT/R w/Kevlar | Airflow Snorkel | Flowmaster 40 Series Muffler | Superchips Flashpaq | Mopar Skids | 4xGuard Belly Guard | American Rebel Rear Diff Cover | Rear Powertrax No-Slip | Front E-Locker | Rear Heat/AC Delete
07JeepXK is offline  
post #6 of 8 (permalink) Old 06-05-2014, 08:35 PM Thread Starter
Member
Points: 1,918, Level: 26 Points: 1,918, Level: 26 Points: 1,918, Level: 26
Level up: 18% Level up: 18% Level up: 18%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Apr 2014
Posts: 87
It is an 07
music_man185 is offline  
post #7 of 8 (permalink) Old 06-06-2014, 04:48 AM
Senior Member
Points: 27,950, Level: 98 Points: 27,950, Level: 98 Points: 27,950, Level: 98
Level up: 60% Level up: 60% Level up: 60%
Activity: 0% Activity: 0% Activity: 0%
 
07JeepXK's Avatar
 
Join Date: Sep 2007
Location: Orchard Park, NY
Posts: 6,311
I have an 07 4.7 liter




2007 4.7 Liter XK | Front OME MD Springs w/Superlift Preload Spacer | Rear 4" Superlift Springs | Bilstein 5125 Rear Shocks | JBA UCA's | Rusty's Rear Adjustable Track Bar | Black Rock 997 Wheels | Fred Goeske 1/4 Inch Wheel Spacers | 305/70R17 Goodyear Wrangler MT/R w/Kevlar | Airflow Snorkel | Flowmaster 40 Series Muffler | Superchips Flashpaq | Mopar Skids | 4xGuard Belly Guard | American Rebel Rear Diff Cover | Rear Powertrax No-Slip | Front E-Locker | Rear Heat/AC Delete
07JeepXK is offline  
post #8 of 8 (permalink) Old 06-06-2014, 08:11 AM
Senior Member
Points: 4,070, Level: 40 Points: 4,070, Level: 40 Points: 4,070, Level: 40
Level up: 60% Level up: 60% Level up: 60%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Jan 2013
Location: Rockland County, NY
Own a Commander?: Yes
Model year: 2006
Trim Package: Limited
Power-Train: 5.7L V-8 Hemi
4WD
If 4WD - system: QD-II
Current Mileage: 110000
Posts: 210
I know my fathers 08, with the 3.7 will crank for you, until the engine actually starts. If you just bump the start position in the ignition, it will continue to crank until the engine starts, for 4-5 seconds i believe. Most new cars do this as well. In my 06 5.7 i need to hold the key until it starts, like older vehicles. Im thinking your 07 might have the smart start, like the newer vehicles. The no crank issue might be the typical commander faulty starter, Many horror stories on here about that. Mine ended up needing the starter harness from the batter, as well as a new starter.

06 Commander Limited HEMI. k&n drop in with air raid M.I.T . Aeroturbine 3030xl on stock pipe . Superchips tuned 93. Bilstein 5100 front @1.5 and 5100 on rear + ARB HD coils F/R
06hemixk is offline  
Sponsored Links
Advertisement
 
Reply

  Jeep Commander Forums: Jeep Commander Forum > Jeep Commander Discussion > General Commander Discussion

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jeep Commander Forums: Jeep Commander Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome