Ignition Switch Change -- My Experience - Jeep Commander Forums: Jeep Commander Forum
General Commander Discussion General Discussion involving the Jeep Commander goes here. If it does not fit into a more specific category below, post it here.

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 06-05-2014, 10:07 AM Thread Starter
Junior Member
Points: 1,954, Level: 26 Points: 1,954, Level: 26 Points: 1,954, Level: 26
Level up: 54% Level up: 54% Level up: 54%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Oct 2011
Posts: 13
Ignition Switch Change -- My Experience

Bought my used 06 Limited with a Hemi about 2 years ago. My electrical issues started about 6 months ago.

1. Dash Cluster and Headlights Blinking on and off ~ I read about this on this forum. It was very intermittent. When it got really bad, the BAS and ESP lights would come on and stay on until the Jeep was restarted. Although it "seemed" to be sometimes triggered by bumps -- such as a speed bump in the road -- that was too inconsistent. I thought about outside temp, raining or not, humidity -- nothing was consistent. Also -- try as hard I could -- I could not "create" the problem. Reached underneath the dash -- jiggled the wires and the keys and could not create the problem.

Most (but not all) on this forum suggested an ignition switch change. Because the forums were not unanimous, I was hesitant. Apparently a wire running along the radiator cross-beam can cause this problem also. People at the parts counter said there was no way it could be the ignition. Afterall -- the engine never even stuttered. At one point awhile back, they talked me out of it and recommended a shop specializing in electrical problems. I never called the shop. More, I am generally opposed to "throwing parts" at problems.

2. Rain Sensing Wipers -- For all practical purposes, these became useless. When they engaged, they would wipe a couple of times. Soon, however, they would wipe and come up on the windshield higher than usual -- about 2 or 3 inches higher. Once there, they would not wipe again until I changed the setting. Went into the EVIC settings and disabled them so that my wipers worked like traditional wiper delays and that worked fine. Still -- I liked and wanted the rain-sensing wipers. On this forum -- I have read about changing the wiper motors and the relay. People have had success with both approaches. Was not looking forward to throwing parts at this either.

After a particularly embarrassing trip home at night (blinking headlights and all) and high level of frustration, bought an ignition switch and changed it the next day. Instructions are also somewhere on this forum.

That has been about 3 weeks ago --- so far --- BOTH problems are fixed. Although the ignition switch fix for the blinking cluster is found elsewhere on this forum, this is the only time -- as far as I could tell by searching -- that it has been reported that the ignition switch fixed the rain sensing wipers.

I just wanted to relay the story to help others and say thank you for the forums. They really helped me a great deal.

javajeep is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 06-05-2014, 12:03 PM
Super Moderator
Points: 59,482, Level: 100 Points: 59,482, Level: 100 Points: 59,482, Level: 100
Level up: 0% Level up: 0% Level up: 0%
Activity: 79% Activity: 79% Activity: 79%
 
jeep5253's Avatar
 
Join Date: Jun 2006
Own a Commander?: Yes
Model year: 2006
Trim Package: Limited
Power-Train: 5.7L V-8 Hemi
4WD
If 4WD - system: QD-II
Posts: 14,899
Just goes to show you that the long time members here know what they are talking about, doesn't it ?

2006 Steel Blue 5.7L HEMI Limited 4x4 Build Date: June 9, 2006 Hour 14
Interior: Dark Slate/Light Graystone with Saddle Brown Leather Seats
Quadra-Drive II, NAV, DVD, Trailer Tow Group IV, Off-Road Group II, Remote Start, UConnect, Rear Backup Camera, Chrome Wheels,
Magnaflow cat-back exhaust, Daytime Running Lights enabled, 2" Rough Country Lift with 265/70R17 Goodyear Wrangler AT/S
jeep5253 is offline  
Sponsored Links
Advertisement
 
Reply

  Jeep Commander Forums: Jeep Commander Forum > Jeep Commander Discussion > General Commander Discussion

Tags
ignition switch , instrument panel , rain-sensing wipers

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jeep Commander Forums: Jeep Commander Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome