2007 commander irratic shifting on hyway - Jeep Commander Forums: Jeep Commander Forum
General Commander Discussion General Discussion involving the Jeep Commander goes here. If it does not fit into a more specific category below, post it here.

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 07-28-2014, 03:21 PM Thread Starter
Junior Member
Points: 12, Level: 1 Points: 12, Level: 1 Points: 12, Level: 1
Level up: 23% Level up: 23% Level up: 23%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Jul 2014
Posts: 3
2007 commander irratic shifting on hyway

My 07 commander 4.7 shifts irraticaly on hyway going about 65 70 mph. It downshifts then upshift and repeats irratically. The fluid is full, clean and doesnt smell burnt. What will caise this...shift solenoid or controller or valve or something maybe. I am a certified diesel tech and can do the work myself if i knew wtf to change. No cel or any other light on dash ever display.
snayke62 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 07-28-2014, 04:29 PM Thread Starter
Junior Member
Points: 12, Level: 1 Points: 12, Level: 1 Points: 12, Level: 1
Level up: 23% Level up: 23% Level up: 23%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Jul 2014
Posts: 3
Also it does it in cruise or manual. Dont matter. Its not compensating for a hill cause it does it on flat highway. Never stalls. Shifts okay in town....sometimes seems to shift too soon in town but ill manually drop it a gear if i have too. Its only on the interstate and she hits 3k rpm then 2......then 3 again then 2.....then maybe hang in between a second the downshift and then upsift. Pisses me off.
snayke62 is offline  
post #3 of 3 (permalink) Old 07-29-2014, 08:58 AM
Senior Member
Points: 15,906, Level: 81 Points: 15,906, Level: 81 Points: 15,906, Level: 81
Level up: 12% Level up: 12% Level up: 12%
Activity: 0% Activity: 0% Activity: 0%
 
Mongo's Avatar
 
Join Date: Oct 2010
Location: Lusby, MD
Posts: 3,037
Someone just posted with the same problem,

https://www.jeepcommander.com/forums/...ad.php?t=33930

I offered a little speculation, but NOT really any insightful help, definitely go with someone that seems to have a more informed opinion of the possible cause.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Mongo is offline  
Sponsored Links
Advertisement
 
Reply

  Jeep Commander Forums: Jeep Commander Forum > Jeep Commander Discussion > General Commander Discussion

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jeep Commander Forums: Jeep Commander Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome