Erratic shifting while cruising on highway - Jeep Commander Forums: Jeep Commander Forum
General Commander Discussion General Discussion involving the Jeep Commander goes here. If it does not fit into a more specific category below, post it here.

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 07-29-2014, 01:29 AM Thread Starter
Member
Points: 7,052, Level: 55 Points: 7,052, Level: 55 Points: 7,052, Level: 55
Level up: 51% Level up: 51% Level up: 51%
Activity: 4% Activity: 4% Activity: 4%
 
Join Date: Sep 2010
Location: Ontario Canada
Posts: 30
Erratic shifting while cruising on highway

My 2007 5.7 Hemi Limited Quadratrac II (70000 mi) tends to shift up and down at 65 mph on a level road with a slight thump on upshift. It does this continually, even in cruise. The rpm variance is about 300 rpm (2000 -2300). Frequency is about once every 30 seconds.

If I drop it out of "D" to "5" it does not do it. Can't recall if it did this before as it is quite subtle.

Seems to me it might be the O/D or lockup kicking in and out. Was thinking about getting a re-flash with all the latest firmware updates.
Am I asking for trouble with a reflash ? Worried about wearing out clutch packs
wallyo is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 07-29-2014, 08:42 AM
Senior Member
Points: 15,906, Level: 81 Points: 15,906, Level: 81 Points: 15,906, Level: 81
Level up: 12% Level up: 12% Level up: 12%
Activity: 0% Activity: 0% Activity: 0%
 
Mongo's Avatar
 
Join Date: Oct 2010
Location: Lusby, MD
Posts: 3,037
Sorry, can't help you with firmware versions, but typically if the firmware worked fine before and a problem has come up, new firmware is NOT going to fix the new problem, that might be from wear or a malfunction. But, yes, I could be wrong, perhaps there was a common problem that firmware changes did address, and a little wear was enough to induce the problem that newer firmware would fix.


Fresh Fluid and Filter never hurts. If its been a while and you're tough on your trans its always possible degraded fluid, changed viscosity and greater pressure drops across filters is contributing to extra shifting.

I "thought" there was a TSB on the 545RE for filters installed at the factory cracking, don't remember what the symptoms of the crack filter were, but just more reason to do an oil and filter change if you haven't done one. I think the 545RE has two filters, the typical pick-up filter and pressure filter that looks like a small engine oil filter. Its the small engine oil like filter that cracks, and I think it is inside the trans, NOT on the outside, but accessible by dropping the pan. There are youtube videos about changing that filter.

I'd be more concerned with the trans overheating, the biggest problem with the OD automatics is the tall OD gear, you get into conditions where the trans keeps shifting in and out of the OD gear, and the constant shifting overheats the trans, and then the cascades of effects from that which shortens the life the trans greatly.

That is why there is a towing mode for OD trans.

For the Brick Like Aerodynamics of the Commander, I wouldn't be surprised if 65mph the aerodynamic load is enough that its at the edge of downshifting out of OD.

Do you have cruise control on when you get the shifting/tc unlock?

Have you changed the tires or at least checked they are at proper pressure?


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Last edited by Mongo; 07-29-2014 at 08:56 AM.
Mongo is offline  
post #3 of 3 (permalink) Old 07-29-2014, 07:34 PM
Junior Member
Points: 12, Level: 1 Points: 12, Level: 1 Points: 12, Level: 1
Level up: 23% Level up: 23% Level up: 23%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Jul 2014
Posts: 3
My 07 4.7 does this exact same thing. I have a hard time beleiving a trans change will fix it. But its worthba shot i guess. It acys to me like the trans cant decide what gear to be in when its in od. I have found that if you are more aggressivly driving it doesnt do it as much. Its when ur feathering it and trying to keep a steady road speed. As far as the wind resistance and tires....ive bumped it up to 80 mph before while it eas doing it to get it out of the "shift point" and then it just did it more violently.
snayke62 is offline  
Sponsored Links
Advertisement
 
Reply

  Jeep Commander Forums: Jeep Commander Forum > Jeep Commander Discussion > General Commander Discussion

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jeep Commander Forums: Jeep Commander Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome