Air Conditioning Hi/Lo on a HEMI - Jeep Commander Forums: Jeep Commander Forum
General Commander Discussion General Discussion involving the Jeep Commander goes here. If it does not fit into a more specific category below, post it here.

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 09-24-2014, 11:02 AM Thread Starter
Junior Member
Points: 1,157, Level: 18 Points: 1,157, Level: 18 Points: 1,157, Level: 18
Level up: 57% Level up: 57% Level up: 57%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Sep 2014
Posts: 4
Air Conditioning Hi/Lo on a HEMI

I have an 06' Commander limited with a HEMI, only 54K miles. My A/C is having an issue with the HI. System has been evac'd and refilled, checked for leaks etc. We determined that the HI function of the fan is not working. Issue number one: The fan is hydraulic, not electric. It is extremely difficult to find and costs $862.00!!! We have talked about putting an additional electric fan on the radiator, but the radiator has two additional radiators bolted in front of it, one for the transmission and I forget the other. So the electric fan would have to go on the outside of the three and probably wouldn't do much not being directly on the main radiator. Has anyone else had this problem, what was your solution, did it work well? Thanks!!!!
Attached Thumbnails
Click image for larger version

Name:	20140112_175842p.jpg
Views:	63
Size:	48.2 KB
ID:	11754  
courtematt is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 09-24-2014, 12:18 PM
Senior Member
Points: 15,906, Level: 81 Points: 15,906, Level: 81 Points: 15,906, Level: 81
Level up: 12% Level up: 12% Level up: 12%
Activity: 0% Activity: 0% Activity: 0%
 
Mongo's Avatar
 
Join Date: Oct 2010
Location: Lusby, MD
Posts: 3,037
Quote:
Originally Posted by courtematt View Post
I have an 06' Commander limited with a HEMI, only 54K miles. My A/C is having an issue with the HI. System has been evac'd and refilled, checked for leaks etc. We determined that the HI function of the fan is not working. Issue number one: The fan is hydraulic, not electric. It is extremely difficult to find and costs $862.00!!! We have talked about putting an additional electric fan on the radiator, but the radiator has two additional radiators bolted in front of it, one for the transmission and I forget the other. So the electric fan would have to go on the outside of the three and probably wouldn't do much not being directly on the main radiator. Has anyone else had this problem, what was your solution, did it work well? Thanks!!!!
The blower fan, in the interior of the Commander, that you adjust at the AC/Heat controls is electric.

The fan to cool the radiators is hydrualic.

Your post is just a little confusing talking about different systems being on "Hi".

So I'm assuming you mean you've determined that the AC condenser is NOT getting enough airflow to properly cool/condense the refrigerant when the AC is on its highest setting, thus that is the root of poor AC performance?

If the hydrualic fan works but won't go into the hi mode, have you checked its NOT a control problem, like the valve that actuates it? Or have you determined the hydrualic motor is degraded and can NOT turn any faster then it does?

Have you called around to junk yards? Have tried freshed fluid in the PS system?

Starting from the engine moving forward, there is the engine radiator bolted to the back of the bulkhead, then there is a combination AC Condenser and Tranmission Oil Cooler bolted to the front of the bulkhead and then there is a Power Steering Fluid Cooler that plastic bayonet affixed to the Condenser/Trans Cooler.

One Option that comes to mind, is to move the PS Fluid Cooler higher up and and put the electric fan blowinging onto the condenser. The lower portion of the Condenser/Trans Cooler is the Condenser portion, the lower 3/4 of the cooler is the condenser. You may have to get new PS line that is longer than the existing lines to relocate the PS cooler.

Finally, have you looked into aftermarket fans that could be mounted in replacement of the hydrualic fan? Chrysler choose a hydrualic fan because they didn't have an electric fan powerful enough to fit in the tight location, perhaps a there are more powerful aftermarket fans that are compact enough to fit. You could wire it up to be triggered (relay) by the electric valve actuating the hydrualic fan.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Last edited by Mongo; 09-24-2014 at 12:20 PM.
Mongo is offline  
post #3 of 4 (permalink) Old 09-25-2014, 10:46 AM Thread Starter
Junior Member
Points: 1,157, Level: 18 Points: 1,157, Level: 18 Points: 1,157, Level: 18
Level up: 57% Level up: 57% Level up: 57%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Sep 2014
Posts: 4
Sorry if it was confusing...I had to re-write the post because I lost it, and forgot couple of things. To answer your question, the switch does go into HI mode, but (the fan) is just not strong enough to blow as cold as it should. The A/C works great at sustained speeds over 40 MPH because the fan does not have to work as hard. The short, low speed trips are the issue. I did speak with my mech about putting an aftermarket fan on to help with, but not replace the hydraulic fan and we will probably go that route. Didn't think about relocating the PS cooler, thanks for that tip, will need to buy/fab a longer line as well.
courtematt is offline  
 
post #4 of 4 (permalink) Old 09-25-2014, 12:29 PM
Senior Member
Points: 15,906, Level: 81 Points: 15,906, Level: 81 Points: 15,906, Level: 81
Level up: 12% Level up: 12% Level up: 12%
Activity: 0% Activity: 0% Activity: 0%
 
Mongo's Avatar
 
Join Date: Oct 2010
Location: Lusby, MD
Posts: 3,037
If nothing else is suffering from lack of cooling air flow, the engine, trans, PS, then I guess putting a pusher fan on the front of the condenser would fix your AC problem.

The PS cooler has rubber hoses that are clamped to the cooler, so replacing the lines with longer should be a problem. The clamps look like crimps, just have to cut them off and replace them normal hose clamps. Look for the type of line for the liquid it will carry rated for the pressures of the system, i.e. heater hose or fuel injection hose would NOT last if you use it for power steering, different forms of oil can detiorate hose, so you want PS hose of the right diameter.

The problem is, the hydrualic fan is NOT going to get better, it is just going to get worse. So your delima is, do you add a fan, then just a few months or a year down the road have to replace the hydrualic fan anyway, or do you bite the bullet now and replace the fan.

I did an internet search a few weeks back, there was a dealer that sells parts online selling one for a little over $500, or maybe it was $600.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Mongo is offline  
Sponsored Links
Advertisement
 
Reply

  Jeep Commander Forums: Jeep Commander Forum > Jeep Commander Discussion > General Commander Discussion

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jeep Commander Forums: Jeep Commander Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome