Light show heaven - Jeep Commander Forums: Jeep Commander Forum
General Commander Discussion General Discussion involving the Jeep Commander goes here. If it does not fit into a more specific category below, post it here.

 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 01-16-2008, 08:58 AM Thread Starter
Senior Member
Points: 11,274, Level: 70 Points: 11,274, Level: 70 Points: 11,274, Level: 70
Level up: 6% Level up: 6% Level up: 6%
Activity: 0% Activity: 0% Activity: 0%
 
XKJeep06's Avatar
 
Join Date: Nov 2007
Location: Houston, TX
Posts: 452
Light show heaven

Okay, so I decided to head out to work earlier than usual to beat the morning rush. I'm on the cellphone via Bluetooth. I'm more than halfway to work, when suddenly my airbag light pops on ... no biggie. Light flickers off a few seconds later; I decide to turn on the radio... looks on, but no audio. FUNKY! A few miles later down the freeway, the airbag light reappears, as well as my traction control, park assist warning, and brake lights; at the same time, the speedo/tachometer are jumping from 0 to up. Still the vehicle is cruising with no hesitation. Once I exited, the check engine light stays on.

I decided to take it to the 5-star Jeep dealership right around the corner. I noticed also my windshield wipers would not stop operating when I turned it off manually as I pulled into their bay.

Anyone experience such odd behaviors???? Your thoughts?

Today, it's in for:
1.) Check Engine Light is on.
2.) Radio has no audio (again).
3.) Clunking noise coming from the roof/left rear passenger door.
XKJeep06 is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 01-17-2008, 10:37 AM
Senior Member
Points: 6,355, Level: 52 Points: 6,355, Level: 52 Points: 6,355, Level: 52
Level up: 3% Level up: 3% Level up: 3%
Activity: 0% Activity: 0% Activity: 0%
 
Hemi-Overland's Avatar
 
Join Date: Aug 2007
Location: GA
Posts: 258
wow...ugh, man that sux. Nothing like that here.

let us know the out come
Hemi-Overland is offline  
post #3 of 6 (permalink) Old 01-17-2008, 11:14 AM
Senior Member
Points: 8,145, Level: 60 Points: 8,145, Level: 60 Points: 8,145, Level: 60
Level up: 98% Level up: 98% Level up: 98%
Activity: 0% Activity: 0% Activity: 0%
 
webjones's Avatar
 
Join Date: Nov 2006
Location: Alpharetta, Georgia
Posts: 688
Most of those symptoms happened once on my previous Jeep (a WJ) - when the battery was going bad.
webjones is offline  
 
post #4 of 6 (permalink) Old 01-17-2008, 01:02 PM Thread Starter
Senior Member
Points: 11,274, Level: 70 Points: 11,274, Level: 70 Points: 11,274, Level: 70
Level up: 6% Level up: 6% Level up: 6%
Activity: 0% Activity: 0% Activity: 0%
 
XKJeep06's Avatar
 
Join Date: Nov 2007
Location: Houston, TX
Posts: 452
Follow up

Oh man, DC is really disappointing my ownership of my XK. So yesterday afternoon, I get a call from the SA. Coming from a five-star stealership, I would hope they would give me some good news. That wasn't the case here...

So the SA tells me that due to numerous work done previously from my dealership (where I bought it from, down the road), they wouldn't do any follow-up service on my vehicle. Can you believe that? So basically it was hands off, and let your previous dealership handle the problem. Their excuse was that my previous services haven't RESOLVED the problems correctly (the problem of these short circuits are due to some water leak), thus, DC would not be obligated to fund the warranty work @ the 5-star shop. I really had no time to argue with them. So I picked it up and took it back that afternoon to my dealership.

I'll try to fill everyone in on what I find out what has been done to resolve the issues.
XKJeep06 is offline  
post #5 of 6 (permalink) Old 01-17-2008, 01:29 PM
Senior Member
Points: 13,804, Level: 76 Points: 13,804, Level: 76 Points: 13,804, Level: 76
Level up: 39% Level up: 39% Level up: 39%
Activity: 0% Activity: 0% Activity: 0%
 
PolarBZ's Avatar
 
Join Date: Apr 2007
Location: Lakewood, Washington
Posts: 2,265
I once had something like that happen. Then it went away and hasnt been back... almost forgot about it.

RIP - Silver '06 Limited; 5.7 Hemi; 2" TerraFlex Lift; 255/70R17 Bridgestone Dueler REVOS, Horizontal Inclinometer, Signal Frog Antenna Ball, Surco Safari 50"x50" Roof Rack, GetLost4x4 bumper, Bulldog 9k Winch, GetLost4x4 Rock Rails - (should have added a snorkel)
PolarBZ is offline  
post #6 of 6 (permalink) Old 01-17-2008, 01:34 PM
Points: 15,918, Level: 81 Points: 15,918, Level: 81 Points: 15,918, Level: 81
Level up: 14% Level up: 14% Level up: 14%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Nov 2007
Posts: 3,374
my airbag light has been on for awhile.

its going in tomorrow for airbag light, rear window problems, and my outside temperature reading is always off by 20*.
Get Lost 4X4 is offline  
Sponsored Links
Advertisement
 
Reply

  Jeep Commander Forums: Jeep Commander Forum > Jeep Commander Discussion > General Commander Discussion

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jeep Commander Forums: Jeep Commander Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome