Help! Suggestions? - Jeep Commander Forums: Jeep Commander Forum
General Commander Discussion General Discussion involving the Jeep Commander goes here. If it does not fit into a more specific category below, post it here.

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 11 (permalink) Old 04-29-2015, 08:20 PM Thread Starter
Senior Member
Points: 9,702, Level: 66 Points: 9,702, Level: 66 Points: 9,702, Level: 66
Level up: 13% Level up: 13% Level up: 13%
Activity: 0% Activity: 0% Activity: 0%
 
Danny's Avatar
 
Join Date: Feb 2009
Location: Louisiana
Posts: 602
Help! Suggestions?

So i drive to a friends house today and 10 min after I park I go back
outside to find a spot right under my radiator about the size of a dinner plate.
I look underneath and front left LCA is covered in oil, took skid plate off (also covered in oil), and found traces running down sway bar and various other places. The oil is light brown like fresh motor oil. I checked my dip stick and it's fine. (Dip stick oil is 3k in and darker) Checked differential and its dry. I have no clue where it's coming from. I poked around with a flashlight and still no joy. Anyone have any suggestions? I don't want to start it much less drive.
Thank you.
Danny is offline  
Sponsored Links
Advertisement
 
post #2 of 11 (permalink) Old 04-29-2015, 08:38 PM
Senior Member
Points: 7,991, Level: 60 Points: 7,991, Level: 60 Points: 7,991, Level: 60
Level up: 21% Level up: 21% Level up: 21%
Activity: 0% Activity: 0% Activity: 0%
 
luckyse7ens's Avatar
 
Join Date: Apr 2014
Location: CA
Own a Commander?: Yes
Model year: 2010
Trim Package: Sport
Power-Train: 3.7L V-6
2WD
If 4WD - system: QT-I
Current Mileage: 140000
Posts: 1,585
What does it smell like?
luckyse7ens is offline  
post #3 of 11 (permalink) Old 04-29-2015, 08:44 PM Thread Starter
Senior Member
Points: 9,702, Level: 66 Points: 9,702, Level: 66 Points: 9,702, Level: 66
Level up: 13% Level up: 13% Level up: 13%
Activity: 0% Activity: 0% Activity: 0%
 
Danny's Avatar
 
Join Date: Feb 2009
Location: Louisiana
Posts: 602
Quote:
Originally Posted by luckyse7ens View Post
What does it smell like?
It's not really strong like gear oil, and like I said as far as I can see my front diff is clean. It sorta smells like motor oil. Thing is my dipstick oil looks darker and it's not low in the least (according to dipstick)
Danny is offline  
 
post #4 of 11 (permalink) Old 04-29-2015, 08:50 PM Thread Starter
Senior Member
Points: 9,702, Level: 66 Points: 9,702, Level: 66 Points: 9,702, Level: 66
Level up: 13% Level up: 13% Level up: 13%
Activity: 0% Activity: 0% Activity: 0%
 
Danny's Avatar
 
Join Date: Feb 2009
Location: Louisiana
Posts: 602
Could that be a strut? Imma have to go poke around again, but I didn't notice the strut leaking. Drivers LCA was really soaked, tho
Danny is offline  
post #5 of 11 (permalink) Old 04-29-2015, 10:44 PM Thread Starter
Senior Member
Points: 9,702, Level: 66 Points: 9,702, Level: 66 Points: 9,702, Level: 66
Level up: 13% Level up: 13% Level up: 13%
Activity: 0% Activity: 0% Activity: 0%
 
Danny's Avatar
 
Join Date: Feb 2009
Location: Louisiana
Posts: 602
Ok my driveway is clean as a whistle. I went to Goodyear just before going to my friends house to get a nail removed from my passenger side rear tire. I then immediately went to my friends place and that's where I found the mess within 10 min of being parked. Could they have busted something with the lift? If so....what?
Danny is offline  
post #6 of 11 (permalink) Old 04-29-2015, 11:23 PM
Senior Member
Points: 4,564, Level: 43 Points: 4,564, Level: 43 Points: 4,564, Level: 43
Level up: 7% Level up: 7% Level up: 7%
Activity: 17% Activity: 17% Activity: 17%
 
Join Date: Mar 2015
Location: Monterey California
Own a Commander?: Yes
Model year: 2006
Trim Package: Limited
Power-Train: 5.7L V-8 Hemi
4WD
If 4WD - system: QD-II
Current Mileage: 124000
Posts: 201
Power steering fluid or possible leak from transmission cooler lines.
bdalameda is offline  
post #7 of 11 (permalink) Old 05-01-2015, 08:32 PM Thread Starter
Senior Member
Points: 9,702, Level: 66 Points: 9,702, Level: 66 Points: 9,702, Level: 66
Level up: 13% Level up: 13% Level up: 13%
Activity: 0% Activity: 0% Activity: 0%
 
Danny's Avatar
 
Join Date: Feb 2009
Location: Louisiana
Posts: 602
Thanks for all your replies, everyone. Turns out it was the radiator that busted. Got a new one locally for $115 plus put a new thermostat in while we were in there. Had a mechanic buddy of mine do most of the work. Well, he actually did all of it... I handed him stuff, lol.
That went smoothly enough until I,in my infinite wisdom,decided to rinse the motor down afterwards. Careful as I was, and lots of profanity later, I ended up with a new TPS. Tried compressed air and left it overnight, battery cables undone.....but no dice on the not being able to get above 2grand on the RPM's/50 mph and having the ESP, BAS, CEL, and trac control lights going off until I replaced the TPS
Danny is offline  
post #8 of 11 (permalink) Old 05-01-2015, 08:35 PM
Senior Member
Points: 7,991, Level: 60 Points: 7,991, Level: 60 Points: 7,991, Level: 60
Level up: 21% Level up: 21% Level up: 21%
Activity: 0% Activity: 0% Activity: 0%
 
luckyse7ens's Avatar
 
Join Date: Apr 2014
Location: CA
Own a Commander?: Yes
Model year: 2010
Trim Package: Sport
Power-Train: 3.7L V-6
2WD
If 4WD - system: QT-I
Current Mileage: 140000
Posts: 1,585
Quote:
Originally Posted by Danny View Post
Thanks for all your replies, everyone. Turns out it was the radiator that busted. Got a new one locally for $115 plus put a new thermostat in while we were in there. Had a mechanic buddy of mine do most of the work. Well, he actually did all of it... I handed him stuff, lol.
That went smoothly enough until I,in my infinite wisdom,decided to rinse the motor down afterwards. Careful as I was, and lots of profanity later, I ended up with a new TPS. Tried compressed air and left it overnight, battery cables undone.....but no dice on the not being able to get above 2grand on the RPM's/50 mph and having the ESP, BAS, CEL, and trac control lights going off until I replaced the TPS
Very happy you figured it out. Im surprised you didn't smell the typical antifreeze sweet/sour smell. It was probably time for a flush anyways if it was the color you say it is.
luckyse7ens is offline  
post #9 of 11 (permalink) Old 05-02-2015, 12:16 AM
Senior Member
Points: 15,906, Level: 81 Points: 15,906, Level: 81 Points: 15,906, Level: 81
Level up: 12% Level up: 12% Level up: 12%
Activity: 0% Activity: 0% Activity: 0%
 
Mongo's Avatar
 
Join Date: Oct 2010
Location: Lusby, MD
Posts: 3,037
The coolant in your '06 should have been changed in 2011, if it hasn't ever been changed, then likely the brown color of the anti-freeze that leaked out is from rust and corrosion in the cooling system.
Mongo is offline  
post #10 of 11 (permalink) Old 05-02-2015, 05:46 AM Thread Starter
Senior Member
Points: 9,702, Level: 66 Points: 9,702, Level: 66 Points: 9,702, Level: 66
Level up: 13% Level up: 13% Level up: 13%
Activity: 0% Activity: 0% Activity: 0%
 
Danny's Avatar
 
Join Date: Feb 2009
Location: Louisiana
Posts: 602
Thanks guys. I actually had it flushed sometime in 2012, but nonetheless I don't have as keen of an eye as some of the more mechanically inclined folk around here. I should have caught that right away.
Danny is offline  
Sponsored Links
Advertisement
 
Reply

  Jeep Commander Forums: Jeep Commander Forum > Jeep Commander Discussion > General Commander Discussion

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jeep Commander Forums: Jeep Commander Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome