4WD Service Required, 08 Overland, Quadra-Drive - Jeep Commander Forums: Jeep Commander Forum
General Commander Discussion General Discussion involving the Jeep Commander goes here. If it does not fit into a more specific category below, post it here.

 
LinkBack Thread Tools Display Modes
post #1 of 8 (permalink) Old 06-15-2015, 09:33 PM Thread Starter
Senior Member
Points: 5,042, Level: 45 Points: 5,042, Level: 45 Points: 5,042, Level: 45
Level up: 46% Level up: 46% Level up: 46%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Mar 2014
Location: NorthAmerica
Own a Commander?: Yes
Model year: 2008
Trim Package: Overland
Power-Train: 5.7L V-8 Hemi
4WD
If 4WD - system: QD-II
Current Mileage: 150000
Posts: 224
4WD Service Required, 08 Overland, Quadra-Drive

Looking to purchase an 08' Overland, Quadra-Drive. Will not shift into 4WD or 4 Wheel Neutral. The display shows "4WD service required" 126K miles, 5.7L Hemi.

Has anyone seen this before? Thanks.
vjsimone is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old 06-15-2015, 10:52 PM
Junior Member
Points: 471, Level: 9 Points: 471, Level: 9 Points: 471, Level: 9
Level up: 43% Level up: 43% Level up: 43%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Mar 2015
Posts: 22
Very common issue due to the software Jeep used in the last reflash. I have read jeep now have another reflash that fixes the problem. I just do the fuse pull trick. Others will be in with more info soon.

Basically I would still buy the car with this fault. Mine was the same when I bought it.
Ausromeo is offline  
post #3 of 8 (permalink) Old 06-16-2015, 12:50 AM Thread Starter
Senior Member
Points: 5,042, Level: 45 Points: 5,042, Level: 45 Points: 5,042, Level: 45
Level up: 46% Level up: 46% Level up: 46%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Mar 2014
Location: NorthAmerica
Own a Commander?: Yes
Model year: 2008
Trim Package: Overland
Power-Train: 5.7L V-8 Hemi
4WD
If 4WD - system: QD-II
Current Mileage: 150000
Posts: 224
Ok, thanks. After more reading, found the fuse trick. Also found the new recall, update to the N23; http://www.chrysler.com/universal/we...ce/pdf/P73.pdf
vjsimone is offline  
 
post #4 of 8 (permalink) Old 06-16-2015, 08:59 AM
Senior Member
Points: 13,779, Level: 76 Points: 13,779, Level: 76 Points: 13,779, Level: 76
Level up: 33% Level up: 33% Level up: 33%
Activity: 0% Activity: 0% Activity: 0%
 
LuvMyCommander's Avatar
 
Join Date: Apr 2010
Location: Chicago, IL
Posts: 954
If you're purchasing the Commander at a dealer ask if they can apply the latest update, it should address that issue. The fuse trick is only temporary from what I've seen. I have the latest flash and it fixed that issue and has been working ever since, been going almost a year with no issues.
LuvMyCommander is offline  
post #5 of 8 (permalink) Old 06-16-2015, 01:19 PM
Senior Member
Points: 16,359, Level: 82 Points: 16,359, Level: 82 Points: 16,359, Level: 82
Level up: 2% Level up: 2% Level up: 2%
Activity: 4% Activity: 4% Activity: 4%
 
Join Date: May 2006
Location: Orlando, FL
Own a Commander?: Yes
Model year: 2006
Trim Package: Limited
Power-Train: 4.7L V-8
4WD
If 4WD - system: QD-II
Current Mileage: 165,000
Posts: 1,477
I didn't realize that the new recall has been around for almost a year, If there is that much history, we should have a good idea if it works.
Creek is offline  
post #6 of 8 (permalink) Old 06-16-2015, 01:24 PM
Senior Member
Points: 13,779, Level: 76 Points: 13,779, Level: 76 Points: 13,779, Level: 76
Level up: 33% Level up: 33% Level up: 33%
Activity: 0% Activity: 0% Activity: 0%
 
LuvMyCommander's Avatar
 
Join Date: Apr 2010
Location: Chicago, IL
Posts: 954
Yes, it was available I believe in June of last year but it wasn't performed as a recall, it was a TSB at that point. Not many dealers knew about it at that time but I printed out the TSB and they were able to reflash the FDCM and it fixed the "4WD Service Required" issue.
LuvMyCommander is offline  
post #7 of 8 (permalink) Old 06-16-2015, 01:52 PM
Senior Member
Points: 16,293, Level: 81 Points: 16,293, Level: 81 Points: 16,293, Level: 81
Level up: 89% Level up: 89% Level up: 89%
Activity: 0% Activity: 0% Activity: 0%
 
lekmedm's Avatar
 
Join Date: Mar 2008
Location: Annandale, NJ
Own a Commander?: Yes
Model year: 2007
Trim Package: Overland
Power-Train: 5.7L V-8 Hemi
4WD
If 4WD - system: QD-II
Current Mileage: 232,700
Posts: 953
Garage
Everybody gets all worked up over the N23 recall. There are other possible reasons for getting that service message.

So the first question is, from whom are you purchasing the Jeep? If it's a dealer, let him look in to it as a condition for your purchase. If you are buying from a private seller, take the VIN down to a dealer and check if the recall was done. The N23 recall was a fiasco, so make sure that the July 2014 flash was applied.

The other thing to look at are other sources for the message. Scan for codes. I had the service message WAY before the N23 recall. I had a C1417 code that meant I had a circuit issue in the front diff.
lekmedm is offline  
post #8 of 8 (permalink) Old 06-24-2015, 12:58 AM Thread Starter
Senior Member
Points: 5,042, Level: 45 Points: 5,042, Level: 45 Points: 5,042, Level: 45
Level up: 46% Level up: 46% Level up: 46%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Mar 2014
Location: NorthAmerica
Own a Commander?: Yes
Model year: 2008
Trim Package: Overland
Power-Train: 5.7L V-8 Hemi
4WD
If 4WD - system: QD-II
Current Mileage: 150000
Posts: 224
P73, 2008, XK, Overland, 5.7L, 126K mi

So, I ended up taking this jeep to the dealer for a $150 pre purchase inspection, which included the list of my suspects. Any way, they applied the P73 flash and all was fixed, never tried the fuse trick, but I was able to test the 4WD before purchase, a few times, which I didn't buy for other reasons. But bought another 08, 95kmi and traded in my 09 sport, 90Kmi.
vjsimone is offline  
Sponsored Links
Advertisement
 
Reply

  Jeep Commander Forums: Jeep Commander Forum > Jeep Commander Discussion > General Commander Discussion

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jeep Commander Forums: Jeep Commander Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome