Dual Climate controls, passenger side is noticeably warmer. - Jeep Commander Forums: Jeep Commander Forum
General Commander Discussion General Discussion involving the Jeep Commander goes here. If it does not fit into a more specific category below, post it here.

 2Likes
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 19 (permalink) Old 06-09-2016, 08:41 AM Thread Starter
Member
Points: 1,374, Level: 20 Points: 1,374, Level: 20 Points: 1,374, Level: 20
Level up: 74% Level up: 74% Level up: 74%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Mar 2016
Posts: 76
Dual Climate controls, passenger side is noticeably warmer.

I've done a search and noticed some people complained about this issue, but I never saw a resolution. Does anyone know exactly what this is? I'm assuming blend door malfunction, but since no one confirmed that, I wanted to ask.

I just had the system serviced, so I know that the R134A is at the correct levels.

Last edited by PickleSlice; 06-09-2016 at 09:31 AM.
PickleSlice is offline  
Sponsored Links
Advertisement
 
post #2 of 19 (permalink) Old 06-09-2016, 01:28 PM
Member
Points: 2,173, Level: 28 Points: 2,173, Level: 28 Points: 2,173, Level: 28
Level up: 16% Level up: 16% Level up: 16%
Activity: 0% Activity: 0% Activity: 0%
 
wingdog's Avatar
 
Join Date: Jun 2014
Location: Henderson, nv
Posts: 65
If one side is colder than the other it most likely is a bad blend door for the warmer side. Not sure how big a pain it is to replace one as mine function properly.
wingdog is offline  
post #3 of 19 (permalink) Old 06-09-2016, 01:58 PM
Senior Member
Points: 15,906, Level: 81 Points: 15,906, Level: 81 Points: 15,906, Level: 81
Level up: 12% Level up: 12% Level up: 12%
Activity: 0% Activity: 0% Activity: 0%
 
Mongo's Avatar
 
Join Date: Oct 2010
Location: Lusby, MD
Posts: 3,037
The passenger side air blend door breaking in the dual climate control system or a leak in the evaporator for both systems will cause the passenger side to blow warmer air than the driver side.


If its caused by the evaporator leak, then recharging the system should return cold air to the passenger side. Unless the leak in the evaporator is bad, which they always progress to be worse and worse. If that was true, then your AC pressure would be down already on your just serviced system.


If the pressure are fine, then you're problem is likely a bad air blend door and usually the root of that is its actuating motor or the plastic link between the door and actuating motor.


BTW, the AC condensation drain for the evaporator is over the transmission, you can't see from under the car. So you can't tell if dye or oil are leaking out of the AC evaporator.
Mongo is offline  
 
post #4 of 19 (permalink) Old 06-21-2016, 11:54 PM
Banned
Points: 1,575, Level: 22 Points: 1,575, Level: 22 Points: 1,575, Level: 22
Level up: 75% Level up: 75% Level up: 75%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: May 2016
Posts: 105
thanks. It appears for those of us without dual ac it's a low charge/ bad evaporator core.
Did a search this is a very common complaint for Commanders.
Conundrum2006 is offline  
post #5 of 19 (permalink) Old 06-22-2016, 08:38 AM Thread Starter
Member
Points: 1,374, Level: 20 Points: 1,374, Level: 20 Points: 1,374, Level: 20
Level up: 74% Level up: 74% Level up: 74%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Mar 2016
Posts: 76
I'm actually going to try and tackle this this weekend. The evap core is not expensive, it's just time consuming to replace.
PickleSlice is offline  
post #6 of 19 (permalink) Old 06-23-2016, 05:32 PM
Member
Points: 3,243, Level: 35 Points: 3,243, Level: 35 Points: 3,243, Level: 35
Level up: 29% Level up: 29% Level up: 29%
Activity: 0% Activity: 0% Activity: 0%
 
BillyThrasher's Avatar
 
Join Date: Mar 2015
Posts: 79
I have this same problem,but my commander isn't equipped with dual climate control. Any ideas?


Sent from AutoGuide.com Free App
BillyThrasher is offline  
post #7 of 19 (permalink) Old 06-25-2016, 10:48 PM
Senior Member
Points: 5,042, Level: 45 Points: 5,042, Level: 45 Points: 5,042, Level: 45
Level up: 46% Level up: 46% Level up: 46%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Mar 2014
Location: NorthAmerica
Own a Commander?: Yes
Model year: 2008
Trim Package: Overland
Power-Train: 5.7L V-8 Hemi
4WD
If 4WD - system: QD-II
Current Mileage: 150000
Posts: 224
Quote:
Originally Posted by PickleSlice View Post
I'm actually going to try and tackle this this weekend. The evap core is not expensive, it's just time consuming to replace.
So, you determined you have a leak in which evaporator?

08, Commander, Overland, 5.7L HEMI, QD-II, Stock.
vjsimone is offline  
post #8 of 19 (permalink) Old 06-28-2016, 12:35 PM
Banned
Points: 1,575, Level: 22 Points: 1,575, Level: 22 Points: 1,575, Level: 22
Level up: 75% Level up: 75% Level up: 75%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: May 2016
Posts: 105
I have look at the problem again, my temperature discrepancy passenger side to drivers it is there through the ranges; ac, vent cool, and heating.

Again I'm not dual climate control. Not sure what's going on.


Sent from my iPhone using Tapatalk
Conundrum2006 is offline  
post #9 of 19 (permalink) Old 06-29-2016, 03:37 AM
Senior Member
Points: 5,042, Level: 45 Points: 5,042, Level: 45 Points: 5,042, Level: 45
Level up: 46% Level up: 46% Level up: 46%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Mar 2014
Location: NorthAmerica
Own a Commander?: Yes
Model year: 2008
Trim Package: Overland
Power-Train: 5.7L V-8 Hemi
4WD
If 4WD - system: QD-II
Current Mileage: 150000
Posts: 224
A/C issue

Quote:
Originally Posted by Conundrum2006 View Post
I have look at the problem again, my temperature discrepancy passenger side to drivers it is there through the ranges; ac, vent cool, and heating.

Again I'm not dual climate control. Not sure what's going on.


Sent from my iPhone using Tapatalk
Low freon can cause this. What is the difference in temp? Check the temp in the very back on high fan, what is it?

You can get a small A/C thermometer from the autoparts store.

08, Commander, Overland, 5.7L HEMI, QD-II, Stock.

Last edited by vjsimone; 06-29-2016 at 03:39 AM. Reason: Adding Question..
vjsimone is offline  
post #10 of 19 (permalink) Old 07-31-2016, 01:20 PM
Banned
Points: 1,575, Level: 22 Points: 1,575, Level: 22 Points: 1,575, Level: 22
Level up: 75% Level up: 75% Level up: 75%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: May 2016
Posts: 105
Quote:
Originally Posted by vjsimone View Post
Low freon can cause this. What is the difference in temp? Check the temp in the very back on high fan, what is it?

You can get a small A/C thermometer from the autoparts store.
Yup, my evaporator has got to be leaking.
had two problems first was the low side on my gauges was reading too high causing me to under charge it. Now a month after it was recharged to the correct level its slowly starting to get warm on the passenger side.

Second problem is the ac fan is just weak, previous owner replaced it with a after market motor. I've got a factory motor on the way.

For replacement evaporator cores what brands are recommended?


Found this video on dash removal. I'll be looking it up in the FSM later.

https://www.youtube.com/watch?v=gj3P1YEYE6Y
Conundrum2006 is offline  
Sponsored Links
Advertisement
 
Reply

  Jeep Commander Forums: Jeep Commander Forum > Jeep Commander Discussion > General Commander Discussion

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jeep Commander Forums: Jeep Commander Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome