2008 Commander Hemi Stall - Jeep Commander Forums: Jeep Commander Forum
General Commander Discussion General Discussion involving the Jeep Commander goes here. If it does not fit into a more specific category below, post it here.

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 06-09-2016, 07:59 PM Thread Starter
Junior Member
Points: 12, Level: 1 Points: 12, Level: 1 Points: 12, Level: 1
Level up: 23% Level up: 23% Level up: 23%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Jun 2016
Posts: 2
2008 Commander Hemi Stall

I know this subject has been talked about at length, but here goes......

I've got an '08 Commander, 5.7L and it has been a jewel! Until recently, I haven't had to turn a wrench on it except to change the oil and replace the battery. (Had some sunroof leaking issues, but solved those) It started running a little rough so I decided to give her a tune up. Changed the coil boots and spark plugs (OEM Champion Copper Plugs P/N RE14mcc4 .... gray / charcoal tips). Ever since then I have acquired the dreaded Hemi stall everyone talks about. It stalls at idle or very low speed. From there I decided to change the EGR, cleaned TB, PCV valve, cleaned IAT, and checked for vacuum leaks, checked tranny fluid, and still have the stalling issue. It seems to be stalling more frequently now. It has 183,000 miles on it and has run flawlessly for as long as I have had it. I'm thinking I should go back to when it began to stall and that's with the plugs. Suggestions? Any help would be appreciated!
brojdoster is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 06-11-2016, 09:52 AM Thread Starter
Junior Member
Points: 12, Level: 1 Points: 12, Level: 1 Points: 12, Level: 1
Level up: 23% Level up: 23% Level up: 23%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Jun 2016
Posts: 2
Follow up.....

Bought another round of OEM Champion Copper Plus P/N RE14mcc4 w/gray, charcoal tips. Replaced them all yesterday morning. NO MORE STALLING!! It ran like a dream yesterday while I was in town. Let it idle for almost an hour in the driveway.....NO STALLS! My suggestion if your HEMI is suffering from stalling issues, first thing iOS to try the spark plugs. Make sure you use the OEM Champion plugs. Hope this can help someone!
Attached Thumbnails
Click image for larger version

Name:	611GJ0UFbNL._SL1500_.jpg
Views:	65
Size:	84.7 KB
ID:	19865  
brojdoster is offline  
post #3 of 3 (permalink) Old 06-18-2016, 11:05 PM
Senior Member
Points: 5,042, Level: 45 Points: 5,042, Level: 45 Points: 5,042, Level: 45
Level up: 46% Level up: 46% Level up: 46%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Mar 2014
Location: NorthAmerica
Own a Commander?: Yes
Model year: 2008
Trim Package: Overland
Power-Train: 5.7L V-8 Hemi
4WD
If 4WD - system: QD-II
Current Mileage: 150000
Posts: 224
Yes b'y, an old issue.....

So maybe you had one bad plug in you first new batch? Are you willing to measure the resistance on your first set of plugs?

Could have had a bad connection to one of the plugs the first time you changed them, only to get cleared up from the second change.

"I'm thinking I should go back to when it began to stall and that's with the plugs." Bingo.....

08, Commander, Overland, 5.7L HEMI, QD-II, Stock.
vjsimone is offline  
Sponsored Links
Advertisement
 
Reply

  Jeep Commander Forums: Jeep Commander Forum > Jeep Commander Discussion > General Commander Discussion

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jeep Commander Forums: Jeep Commander Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome