Replacing motor due to water damage - Jeep Commander Forums: Jeep Commander Forum
General Commander Discussion General Discussion involving the Jeep Commander goes here. If it does not fit into a more specific category below, post it here.

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 66 (permalink) Old 09-14-2008, 09:42 PM Thread Starter
Points: 1,471, Level: 21 Points: 1,471, Level: 21 Points: 1,471, Level: 21
Level up: 72% Level up: 72% Level up: 72%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Jan 2008
Posts: 163
Replacing motor due to water damage

Long store short was helping friends from their house that was flooding here in northwest indiana and went through water that I thought was 1 foot but was wrong and it was to my factory wheel height on my 07 commander with the standard chrome wheels and it was dead in the water. Wont start so go some people to help push out to dry land and it wont start. It says the 4x4 system is disengaged. As anyone seen this and what the heck can I do. It has power but wont turn over at all just clicks. Please help if possible its next to the brigde we got stopped in. Again its on the side where dry land is but dont want to leave it there all night. Is there a fuse I can pull or what. I dont think if I got it to a jeep dealer they would fix it under warranty. Or what could I say. Was driving it and got flooded. Help me out guys cause Im already close to losing it.

JRod
HEMI Commander. is offline  
Sponsored Links
Advertisement
 
post #2 of 66 (permalink) Old 09-14-2008, 09:50 PM
Senior Member
Points: 63,765, Level: 100 Points: 63,765, Level: 100 Points: 63,765, Level: 100
Level up: 0% Level up: 0% Level up: 0%
Activity: 0% Activity: 0% Activity: 0%
 
a49erFan's Avatar
 
Join Date: Jan 2007
Location: Sunny Arizona
Posts: 12,582
Send a message via Yahoo to a49erFan
Check your dip stick to see if it looks normal or foamy, if normal then you most likely did not suck water. May be just wet electronics and starter and you need to let it dry out.



a49erFan is offline  
post #3 of 66 (permalink) Old 09-14-2008, 09:54 PM Thread Starter
Points: 1,471, Level: 21 Points: 1,471, Level: 21 Points: 1,471, Level: 21
Level up: 72% Level up: 72% Level up: 72%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Jan 2008
Posts: 163
no water in oil at all. the engine bay dry as a plum. I think the starter is out or water got on the connections. It wont turn over just clicks thats all. All inside electronics works. Radio, navi, lights etc.
HEMI Commander. is offline  
 
post #4 of 66 (permalink) Old 09-14-2008, 09:59 PM
Senior Member
Points: 15,238, Level: 79 Points: 15,238, Level: 79 Points: 15,238, Level: 79
Level up: 78% Level up: 78% Level up: 78%
Activity: 0% Activity: 0% Activity: 0%
 
adamag25's Avatar
 
Join Date: Jul 2008
Location: Northwest Central Jersey
Posts: 2,629
Try tapping the starter with anything you can find (hammer, screwdriver, ect.) it may need a pretty good hit if it is stuck.

Bright Silver 4.7L 2.25 RR/OME lift, Kumho KL71 265/70/17, Flashpaq, Lights, rack, intake, Super44, mopar skids, 4x belly guard, rear fog lights, MM9500 winch, GetLost4x4 winch mount

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

HILLBILLY DELUXE
adamag25 is offline  
post #5 of 66 (permalink) Old 09-14-2008, 10:01 PM
Senior Member
Points: 15,238, Level: 79 Points: 15,238, Level: 79 Points: 15,238, Level: 79
Level up: 78% Level up: 78% Level up: 78%
Activity: 0% Activity: 0% Activity: 0%
 
adamag25's Avatar
 
Join Date: Jul 2008
Location: Northwest Central Jersey
Posts: 2,629
Did it stall out in the water? If so it may be hydro-locked then you are in for a little bit of work to get going.

Bright Silver 4.7L 2.25 RR/OME lift, Kumho KL71 265/70/17, Flashpaq, Lights, rack, intake, Super44, mopar skids, 4x belly guard, rear fog lights, MM9500 winch, GetLost4x4 winch mount

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

HILLBILLY DELUXE
adamag25 is offline  
post #6 of 66 (permalink) Old 09-14-2008, 10:03 PM Thread Starter
Points: 1,471, Level: 21 Points: 1,471, Level: 21 Points: 1,471, Level: 21
Level up: 72% Level up: 72% Level up: 72%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Jan 2008
Posts: 163
it did stall in the water
HEMI Commander. is offline  
post #7 of 66 (permalink) Old 09-14-2008, 10:05 PM
Senior Member
Points: 15,238, Level: 79 Points: 15,238, Level: 79 Points: 15,238, Level: 79
Level up: 78% Level up: 78% Level up: 78%
Activity: 0% Activity: 0% Activity: 0%
 
adamag25's Avatar
 
Join Date: Jul 2008
Location: Northwest Central Jersey
Posts: 2,629
You may need to pull the plugs but check your air filter first. Make sure your air filter is dry. If it is wet then you will need to pull the spark plugs.

Bright Silver 4.7L 2.25 RR/OME lift, Kumho KL71 265/70/17, Flashpaq, Lights, rack, intake, Super44, mopar skids, 4x belly guard, rear fog lights, MM9500 winch, GetLost4x4 winch mount

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

HILLBILLY DELUXE
adamag25 is offline  
post #8 of 66 (permalink) Old 09-14-2008, 10:10 PM Thread Starter
Points: 1,471, Level: 21 Points: 1,471, Level: 21 Points: 1,471, Level: 21
Level up: 72% Level up: 72% Level up: 72%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Jan 2008
Posts: 163
air filter is dry and no water got in the engine bay
HEMI Commander. is offline  
post #9 of 66 (permalink) Old 09-14-2008, 10:12 PM
Senior Member
Points: 15,238, Level: 79 Points: 15,238, Level: 79 Points: 15,238, Level: 79
Level up: 78% Level up: 78% Level up: 78%
Activity: 0% Activity: 0% Activity: 0%
 
adamag25's Avatar
 
Join Date: Jul 2008
Location: Northwest Central Jersey
Posts: 2,629
If tapping the starter does not work you may need to let it dry. How long has it been since it was in the water?

Bright Silver 4.7L 2.25 RR/OME lift, Kumho KL71 265/70/17, Flashpaq, Lights, rack, intake, Super44, mopar skids, 4x belly guard, rear fog lights, MM9500 winch, GetLost4x4 winch mount

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

HILLBILLY DELUXE
adamag25 is offline  
post #10 of 66 (permalink) Old 09-14-2008, 10:16 PM
Senior Member
Points: 15,238, Level: 79 Points: 15,238, Level: 79 Points: 15,238, Level: 79
Level up: 78% Level up: 78% Level up: 78%
Activity: 0% Activity: 0% Activity: 0%
 
adamag25's Avatar
 
Join Date: Jul 2008
Location: Northwest Central Jersey
Posts: 2,629
this may help https://www.jeepcommander.com/forums/...hlight=starter

Bright Silver 4.7L 2.25 RR/OME lift, Kumho KL71 265/70/17, Flashpaq, Lights, rack, intake, Super44, mopar skids, 4x belly guard, rear fog lights, MM9500 winch, GetLost4x4 winch mount

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

HILLBILLY DELUXE
adamag25 is offline  
Sponsored Links
Advertisement
 
Reply

  Jeep Commander Forums: Jeep Commander Forum > Jeep Commander Discussion > General Commander Discussion

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jeep Commander Forums: Jeep Commander Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome