Traction control activating - Jeep Commander Forums: Jeep Commander Forum
General Commander Discussion General Discussion involving the Jeep Commander goes here. If it does not fit into a more specific category below, post it here.

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 11-30-2016, 01:58 AM Thread Starter
Junior Member
 
Npd126's Avatar
 
Join Date: Nov 2016
Posts: 1
Traction control activating

I have a 06 commander limited with 4.7 awd. I just recently had the timing chains repaired at the stealership. While driving home my traction control activated at 40 mph and would not allow me to accelerate past 40. Lost all power. I turned the traction control off and it drove fine. Also I have had some humming coming from the front end that has gradually progressed. Maybe a coincidence but is it possible I've lost a hub bearing and a speed sensor.

Also I have no abs or traction control trouble codes.

Also I had the ignition recall and both 4wd reflashes done at the same visit.

Furthermore I Def don't think it's related except maybe a couple wire in the same loom but my oil light has been intermittently coming on but going off after restart. No motor knocking and oil level is fine. And since you have to drop the oil pan for the timing chain repair it has fresh dealer oil. The oil system was also flushed. I figure worse case senario I have shaving in the oil pump screen and electrical issues with the trac control. Best case bad wheel speed sensor and bad oil pressure sending unit.

Any comments or help?
Npd126 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 11-30-2016, 03:02 PM
Senior Member
Points: 4,070, Level: 40 Points: 4,070, Level: 40 Points: 4,070, Level: 40
Level up: 60% Level up: 60% Level up: 60%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Jan 2013
Location: Rockland County, NY
Own a Commander?: Yes
Model year: 2006
Trim Package: Limited
Power-Train: 5.7L V-8 Hemi
4WD
If 4WD - system: QD-II
Current Mileage: 110000
Posts: 210
when is the last time you had a front diff fluid change?
06hemixk is offline  
Sponsored Links
Advertisement
 
Reply

  Jeep Commander Forums: Jeep Commander Forum > Jeep Commander Discussion > General Commander Discussion

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jeep Commander Forums: Jeep Commander Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome