water leaking in... - Jeep Commander Forums: Jeep Commander Forum
General Commander Discussion General Discussion involving the Jeep Commander goes here. If it does not fit into a more specific category below, post it here.

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 11-20-2017, 02:58 PM Thread Starter
Banned
Points: 3,376, Level: 36 Points: 3,376, Level: 36 Points: 3,376, Level: 36
Level up: 18% Level up: 18% Level up: 18%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Oct 2017
Location: Acworth GA
Own a Commander?: Yes
Model year: 2008
Trim Package: Limited
Power-Train: 5.7L V-8 Hemi
4WD
If 4WD - system: QD-II
Current Mileage: 144k
Posts: 159
water leaking in...

So I took my jeep to the carwash today and just so happened to be looking around while I was inside and noticed water pretty much pouring out of the upper rear trim piece by the tailgate. got out of the wash go to check it out the weather stripping seams fine I did notice the big black boot and connector were lose. pushed it in tight and am hoping that will solve the problem. Then when I'm driving home I notice water dripping out of the OS grab handle (A pillar) on the passenger side. Again weather stripping in the area looks fine. Noticed there was now a wet spot on the roof right at the corner of the visor as well.

So do you guys think water could run the length of the roof in the headboard or do I have two separate issues here?

I know there are problems with the sun roof drains clogging but haven't read up on it. I will research when I get home tonight, but wanted to throw this out in case someone knows anything.
heffercow is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 11-20-2017, 03:39 PM
Senior Member
Points: 4,070, Level: 40 Points: 4,070, Level: 40 Points: 4,070, Level: 40
Level up: 60% Level up: 60% Level up: 60%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Jan 2013
Location: Rockland County, NY
Own a Commander?: Yes
Model year: 2006
Trim Package: Limited
Power-Train: 5.7L V-8 Hemi
4WD
If 4WD - system: QD-II
Current Mileage: 110000
Posts: 210
Im placing my money on sunroof drain issue. Both front corners of the sunroof I believe have train tubes that run the front pillar behind the grab bar. Maybe try putting compressed air through them from the top to clear them out?

06 Commander Limited HEMI. k&n drop in with air raid M.I.T . Aeroturbine 3030xl on stock pipe . Superchips tuned 93. Bilstein 5100 front @1.5 and 5100 on rear + ARB HD coils F/R
06hemixk is offline  
post #3 of 3 (permalink) Old 11-20-2017, 03:45 PM
Super Moderator
Points: 23,378, Level: 94 Points: 23,378, Level: 94 Points: 23,378, Level: 94
Level up: 3% Level up: 3% Level up: 3%
Activity: 100% Activity: 100% Activity: 100%
 
Big Blue's Avatar
 
Join Date: Oct 2015
Location: East Coast of Florida
Own a Commander?: Yes
Model year: 2008
Trim Package: Sport
Power-Train: 4.7L V-8
4WD
If 4WD - system: QT-II
Current Mileage: 101,200
Posts: 5,328
Garage
Quote:
Originally Posted by heffercow View Post
So I took my jeep to the carwash today and just so happened to be looking around while I was inside and noticed water pretty much pouring out of the upper rear trim piece by the tailgate. got out of the wash go to check it out the weather stripping seams fine I did notice the big black boot and connector were lose. pushed it in tight and am hoping that will solve the problem. Then when I'm driving home I notice water dripping out of the OS grab handle (A pillar) on the passenger side. Again weather stripping in the area looks fine. Noticed there was now a wet spot on the roof right at the corner of the visor as well.

So do you guys think water could run the length of the roof in the headboard or do I have two separate issues here?

I know there are problems with the sun roof drains clogging but haven't read up on it. I will research when I get home tonight, but wanted to throw this out in case someone knows anything.
I had the same problem with water dripping out of the OS grab handle (A pillar) but on the driver's side and my door seals looked fine also.

I replaced the door seals and had the door re-aligned and that solved the problem.

I'd recommend replacing the rear hatch door seal as well.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Big Blue is online now  
Sponsored Links
Advertisement
 
Reply

  Jeep Commander Forums: Jeep Commander Forum > Jeep Commander Discussion > General Commander Discussion

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jeep Commander Forums: Jeep Commander Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome