Blower motor not working - Jeep Commander Forums: Jeep Commander Forum
General Commander Discussion General Discussion involving the Jeep Commander goes here. If it does not fit into a more specific category below, post it here.

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 16 (permalink) Old 11-22-2017, 06:52 PM Thread Starter
Senior Member
Points: 927, Level: 16 Points: 927, Level: 16 Points: 927, Level: 16
Level up: 27% Level up: 27% Level up: 27%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Jun 2017
Location: Fowler, Ohio
Own a Commander?: Yes
Model year: 2008
Trim Package: Limited
Power-Train: 5.7L V-8 Hemi
4WD
If 4WD - system: QT-II
Current Mileage: 147,000
Posts: 100
Blower motor not working

Seems like this a good time of the year for these things to start acting up. I was reading through a few threads about fan motor trouble and it sounds like I can get to the motor by taking out the glove box is this correct? What I noticed first about 3 weeks ago the heat control on the passenger side didn't have any heat while the driver side was working properly. Then yesterday I turned on the fan and it was making some nasty noise and then it quit working all together so it sounds like the motor might be a little beyond cleaning. I suppose its possible the fan motor might have popped a fuse because of debris and its funny because it wasn't making any noise the day before that's why I think the motor might have puked. So do I need to replace the heater control on the pass side or could it be a resister? Thanks for any help you can give me.

Mark

08 Hemi Commander, QT2 diffs boo!, 2 inch lift, 265/70/17 Michelin donuts, and it even has the silent MYGIG radio option too this things almost loaded.
oleblu72 is offline  
Sponsored Links
Advertisement
 
post #2 of 16 (permalink) Old 11-22-2017, 10:12 PM
Senior Member
Points: 2,907, Level: 33 Points: 2,907, Level: 33 Points: 2,907, Level: 33
Level up: 5% Level up: 5% Level up: 5%
Activity: 0% Activity: 0% Activity: 0%
 
Flex's Avatar
 
Join Date: Aug 2017
Location: Edmonton, Alberta Canada
Own a Commander?: Yes
Model year: 2006
Trim Package: Limited
Power-Train: 5.7L V-8 Hemi
4WD
If 4WD - system: QD-II
Current Mileage: 142,000 km
Posts: 371
The glove box has two tabs up top that need to come down. The door will then swing all the way down. A light rap from behind will dislodge each hook. You will also need to remove the lower trim panel. I believe it was two 7mm bolts that held it in place. You have to jiggle it a bit to get it out. Just go slow so that you don't break it. Once the door and panel are out of the way, you can remove the blower motor.

The blower is held up by three t20 torx bit screws. I had to remove the passenger floor light to get at one of them straight on. Mine didn't have a lot of debris in the fan, but it did have one small stick jammed into the blades. I could here it scraping against the housing once in awhile. If you remove it and find that it is still working, blow all the dust out of the motor with compressed air. You have to unhooked its harness from the resistor to remove it from the vehicle.
Flex is offline  
post #3 of 16 (permalink) Old 11-23-2017, 10:08 AM Thread Starter
Senior Member
Points: 927, Level: 16 Points: 927, Level: 16 Points: 927, Level: 16
Level up: 27% Level up: 27% Level up: 27%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Jun 2017
Location: Fowler, Ohio
Own a Commander?: Yes
Model year: 2008
Trim Package: Limited
Power-Train: 5.7L V-8 Hemi
4WD
If 4WD - system: QT-II
Current Mileage: 147,000
Posts: 100
Thanks Flex appreciate it that's most helpful. Are the DVD service manuals worth buying do you know?

Mark

08 Hemi Commander, QT2 diffs boo!, 2 inch lift, 265/70/17 Michelin donuts, and it even has the silent MYGIG radio option too this things almost loaded.
oleblu72 is offline  
 
post #4 of 16 (permalink) Old 11-23-2017, 05:10 PM
Senior Member
Points: 3,844, Level: 39 Points: 3,844, Level: 39 Points: 3,844, Level: 39
Level up: 30% Level up: 30% Level up: 30%
Activity: 0% Activity: 0% Activity: 0%
 
2010 inferno's Avatar
 
Join Date: Feb 2016
Location: Cement City, Mi.
Own a Commander?: Yes
Model year: 2010
Trim Package: Limited
Power-Train: 5.7L V-8 Hemi
4WD
If 4WD - system: QD-II
Current Mileage: 99,000
Posts: 294
Garage
Arrow Factory Service Manual

There are manuals on Ebay on cd and I bought one and for another 1.00 they would send a cd instead of downloading it, they were based on the 2006 year and stated that.

I USE IT. on a 2010

Swanny
2010 inferno is offline  
post #5 of 16 (permalink) Old 11-25-2017, 05:14 PM Thread Starter
Senior Member
Points: 927, Level: 16 Points: 927, Level: 16 Points: 927, Level: 16
Level up: 27% Level up: 27% Level up: 27%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Jun 2017
Location: Fowler, Ohio
Own a Commander?: Yes
Model year: 2008
Trim Package: Limited
Power-Train: 5.7L V-8 Hemi
4WD
If 4WD - system: QT-II
Current Mileage: 147,000
Posts: 100
Thanks Swanny how are the pictures? Reason I ask I have a service manual for my dozer and its a photo copy, between the bad pictures and trying to decipher crappy Japanese English its pretty much a waste.

Mark

08 Hemi Commander, QT2 diffs boo!, 2 inch lift, 265/70/17 Michelin donuts, and it even has the silent MYGIG radio option too this things almost loaded.
oleblu72 is offline  
post #6 of 16 (permalink) Old 11-26-2017, 04:47 PM
Senior Member
Points: 3,844, Level: 39 Points: 3,844, Level: 39 Points: 3,844, Level: 39
Level up: 30% Level up: 30% Level up: 30%
Activity: 0% Activity: 0% Activity: 0%
 
2010 inferno's Avatar
 
Join Date: Feb 2016
Location: Cement City, Mi.
Own a Commander?: Yes
Model year: 2010
Trim Package: Limited
Power-Train: 5.7L V-8 Hemi
4WD
If 4WD - system: QD-II
Current Mileage: 99,000
Posts: 294
Garage
Thumbs up C.d.

I had them mail me the C D with me and the pic's are good and clear, I really prefer a paper copy but not for the money.


Swanny
2010 inferno is offline  
post #7 of 16 (permalink) Old 11-26-2017, 05:49 PM
Senior Member
Points: 2,907, Level: 33 Points: 2,907, Level: 33 Points: 2,907, Level: 33
Level up: 5% Level up: 5% Level up: 5%
Activity: 0% Activity: 0% Activity: 0%
 
Flex's Avatar
 
Join Date: Aug 2017
Location: Edmonton, Alberta Canada
Own a Commander?: Yes
Model year: 2006
Trim Package: Limited
Power-Train: 5.7L V-8 Hemi
4WD
If 4WD - system: QD-II
Current Mileage: 142,000 km
Posts: 371
I have the CD as well. Well worth the money.
Flex is offline  
post #8 of 16 (permalink) Old 11-26-2017, 11:18 PM Thread Starter
Senior Member
Points: 927, Level: 16 Points: 927, Level: 16 Points: 927, Level: 16
Level up: 27% Level up: 27% Level up: 27%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Jun 2017
Location: Fowler, Ohio
Own a Commander?: Yes
Model year: 2008
Trim Package: Limited
Power-Train: 5.7L V-8 Hemi
4WD
If 4WD - system: QT-II
Current Mileage: 147,000
Posts: 100
Yeah I would prefer a regular shop manual too but if the pictures are not clear it kind of hinders your progress. Thanks guys.

Mark

08 Hemi Commander, QT2 diffs boo!, 2 inch lift, 265/70/17 Michelin donuts, and it even has the silent MYGIG radio option too this things almost loaded.
oleblu72 is offline  
post #9 of 16 (permalink) Old 12-18-2017, 05:09 PM Thread Starter
Senior Member
Points: 927, Level: 16 Points: 927, Level: 16 Points: 927, Level: 16
Level up: 27% Level up: 27% Level up: 27%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Jun 2017
Location: Fowler, Ohio
Own a Commander?: Yes
Model year: 2008
Trim Package: Limited
Power-Train: 5.7L V-8 Hemi
4WD
If 4WD - system: QT-II
Current Mileage: 147,000
Posts: 100
Well I finally pulled my blower motor and found out what was wrong with it. It would seem that my Commander wasn't the only thing I brought back from Michigan when I purchased it I found a decapitated mouse in the blower cage that Riga mortise had set in along time ago he must of been up in the duct and finally slid down.

One thing I noticed above the motor is a door that didn't seem to be attached to anything. I could stick my hand up in there and give it a push and it would just swing back and forth. Is this because the motor wasn't running and there wasn't any vacuum? Also I don't have any heat on the passenger side could this be heater door related or do I have a heater switch that I need to replace? Thanks to anyone that can help.

Mark

08 Hemi Commander, QT2 diffs boo!, 2 inch lift, 265/70/17 Michelin donuts, and it even has the silent MYGIG radio option too this things almost loaded.
oleblu72 is offline  
post #10 of 16 (permalink) Old 12-19-2017, 02:22 AM
Senior Member
Points: 2,907, Level: 33 Points: 2,907, Level: 33 Points: 2,907, Level: 33
Level up: 5% Level up: 5% Level up: 5%
Activity: 0% Activity: 0% Activity: 0%
 
Flex's Avatar
 
Join Date: Aug 2017
Location: Edmonton, Alberta Canada
Own a Commander?: Yes
Model year: 2006
Trim Package: Limited
Power-Train: 5.7L V-8 Hemi
4WD
If 4WD - system: QD-II
Current Mileage: 142,000 km
Posts: 371
Mark,

That is the air recirculation door. It's position determines where the system draws air from. Most likely that the gear's teeth have sheared off as that is the only way it would move free of the modulator. Mine was the same. I can email you the part number or post it here.

Last edited by Flex; 12-19-2017 at 02:24 AM.
Flex is offline  
Sponsored Links
Advertisement
 
Reply

  Jeep Commander Forums: Jeep Commander Forum > Jeep Commander Discussion > General Commander Discussion

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jeep Commander Forums: Jeep Commander Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome