Windows and locks don't work on 2007 Limited - Jeep Commander Forums: Jeep Commander Forum
General Commander Discussion General Discussion involving the Jeep Commander goes here. If it does not fit into a more specific category below, post it here.

 1Likes
  • 1 Post By BluPhant
 
LinkBack Thread Tools Display Modes
post #1 of 8 (permalink) Old 03-26-2018, 10:12 AM Thread Starter
Member
Points: 6,425, Level: 52 Points: 6,425, Level: 52 Points: 6,425, Level: 52
Level up: 38% Level up: 38% Level up: 38%
Activity: 0% Activity: 0% Activity: 0%
 
BluPhant's Avatar
 
Join Date: Sep 2009
Location: Southern Connecticut
Own a Commander?: Yes
Model year: 2007
Trim Package: Limited
Power-Train: 4.7L V-8
4WD
If 4WD - system: QT-I
Posts: 40
Windows and locks don't work on 2007 Limited

Greetings folks!

I have a 2007 Commander Limited that needs some work. I read this thread about the type of issue I'm experiencing. The controls on the drivers door for windows and locks are not working.

This weekend I dug in and pulled the dust boot off and immediately noted a number of wires are broken. In reading through this thread, I was set to order a replacement harness, 56048811AB, so I didn't pursue it further this weekend as I figured I'd just replace the whole mess (for $60 or so) and be done with it. Unfortunately, this is the harness for SPORT models, for my limited it looks like I need 56048813AC, which looks to retail for over $500 (I've found it for $350 online). Thats a pretty big difference, and made me reconsider trying to repair the broken wires.

So, I'm looking to see if anyone has done this previously and if so, do you have any specific recommendations?

I'm toying with the idea of detaching the harness completely and doing the patch on the workbench instead of trying to do it in-place.

-Blu
Attached Thumbnails
Click image for larger version

Name:	20180325_121437-COLLAGE.jpg
Views:	92
Size:	24.0 KB
ID:	30945  


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Leather Seats/Alpine iDA-X001 HU/SC-C1 Sirius Tuner/Wheel Locks/Foglites/nüvi 200W GPS
EVIC from 2ooo GC/EVS II Security (Sentry Key)/Under-Dash Courtesy Lights/Hunter 4x4 steps
Rear Flipper Glass Pad/Trail Rated Badge/Custom tint


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

V8 4.7l Flex Fuel, Remote Start, GPS, Saddle Brown Leather, REC GPS, VES, Sirius, Tow Package

"No one can make you feel inferior without your consent."
Eleanor Roosevelt, 'This Is My Story,' 1937
BluPhant is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old 03-29-2018, 05:03 PM
Banned
Points: 3,376, Level: 36 Points: 3,376, Level: 36 Points: 3,376, Level: 36
Level up: 18% Level up: 18% Level up: 18%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Oct 2017
Location: Acworth GA
Own a Commander?: Yes
Model year: 2008
Trim Package: Limited
Power-Train: 5.7L V-8 Hemi
4WD
If 4WD - system: QD-II
Current Mileage: 144k
Posts: 159
I used to have an xj that had the same issues I tried swapping in some bullet connectors to fix it because I was in the process of making my doors removable. Trying to work on those wire in that door jamb is a huge pain in the a$$. I would agree if you are trying to splice/solder in new wire it would be way easier to pull the whole harness and work on a bench. You may have to fight that boot thing and the rubber grommet that feeds through the door but 30 minutes of messing with that will save a ton of time down the road.

Last edited by Big Blue; 03-29-2018 at 06:22 PM.
heffercow is offline  
post #3 of 8 (permalink) Old 04-02-2018, 05:33 PM
Senior Member
Points: 2,907, Level: 33 Points: 2,907, Level: 33 Points: 2,907, Level: 33
Level up: 5% Level up: 5% Level up: 5%
Activity: 0% Activity: 0% Activity: 0%
 
Flex's Avatar
 
Join Date: Aug 2017
Location: Edmonton, Alberta Canada
Own a Commander?: Yes
Model year: 2006
Trim Package: Limited
Power-Train: 5.7L V-8 Hemi
4WD
If 4WD - system: QD-II
Current Mileage: 142,000 km
Posts: 371
Apparently this is a common issue on many vehicles. They make the wires too short and over time they fracture. I would suggest adding at least an extra inch in there to make sure the wires don't get stretched again resulting in another break down the road. Don't use connectors as they will add bulk and may interfere with closing. Solder sections together and use shrink sleeve to prevent open circuits.
Flex is offline  
 
post #4 of 8 (permalink) Old 07-09-2018, 04:09 PM Thread Starter
Member
Points: 6,425, Level: 52 Points: 6,425, Level: 52 Points: 6,425, Level: 52
Level up: 38% Level up: 38% Level up: 38%
Activity: 0% Activity: 0% Activity: 0%
 
BluPhant's Avatar
 
Join Date: Sep 2009
Location: Southern Connecticut
Own a Commander?: Yes
Model year: 2007
Trim Package: Limited
Power-Train: 4.7L V-8
4WD
If 4WD - system: QT-I
Posts: 40
I ended up just ordering a new harness. All set, solved the problem completely. I thought I'd had similar issue with rear passenger side so ordered that harness as well. But magically it started working properly after the drivers front harness installed.

Couple pics for the interested.

Blu
Attached Thumbnails
Click image for larger version

Name:	IMG_20180709_142703_1531170518466.jpg
Views:	53
Size:	335.5 KB
ID:	32663   Click image for larger version

Name:	IMG_20180709_165750_1531170534830.jpg
Views:	50
Size:	448.9 KB
ID:	32665  
XJ99 likes this.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Leather Seats/Alpine iDA-X001 HU/SC-C1 Sirius Tuner/Wheel Locks/Foglites/nüvi 200W GPS
EVIC from 2ooo GC/EVS II Security (Sentry Key)/Under-Dash Courtesy Lights/Hunter 4x4 steps
Rear Flipper Glass Pad/Trail Rated Badge/Custom tint


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

V8 4.7l Flex Fuel, Remote Start, GPS, Saddle Brown Leather, REC GPS, VES, Sirius, Tow Package

"No one can make you feel inferior without your consent."
Eleanor Roosevelt, 'This Is My Story,' 1937
BluPhant is offline  
post #5 of 8 (permalink) Old 07-11-2018, 12:35 AM
Junior Member
Points: 460, Level: 9 Points: 460, Level: 9 Points: 460, Level: 9
Level up: 20% Level up: 20% Level up: 20%
Activity: 0% Activity: 0% Activity: 0%
 
Mattack's Avatar
 
Join Date: Jan 2018
Location: Virginia
Own a Commander?: Yes
Model year: 2007
Trim Package: Sport
Power-Train: 3.7L V-6
4WD
If 4WD - system: QT-I
Current Mileage: 128000
Posts: 16
I was on Mopar looking for the drivers side replacement as you inspired me to do so. I do have the sport model, 56048811AA is the part # for $60. The DIY in me wants to take out the original and fix. The practical side is telling me to pay the $60. My original has the cracked wires in the boot. Works most of the time, but when it rains I have some issues. Also, the rear drivers door would only roll down and not up. It will be interesting to see if its the harness or the window regulator.
Mattack is offline  
post #6 of 8 (permalink) Old 07-11-2018, 09:55 PM
Banned
Points: 3,376, Level: 36 Points: 3,376, Level: 36 Points: 3,376, Level: 36
Level up: 18% Level up: 18% Level up: 18%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Oct 2017
Location: Acworth GA
Own a Commander?: Yes
Model year: 2008
Trim Package: Limited
Power-Train: 5.7L V-8 Hemi
4WD
If 4WD - system: QD-II
Current Mileage: 144k
Posts: 159
Quote:
Originally Posted by Mattack View Post
I was on Mopar looking for the drivers side replacement as you inspired me to do so. I do have the sport model, 56048811AA is the part # for $60. The DIY in me wants to take out the original and fix. The practical side is telling me to pay the $60. My original has the cracked wires in the boot. Works most of the time, but when it rains I have some issues. Also, the rear drivers door would only roll down and not up. It will be interesting to see if its the harness or the window regulator.
Quote:
Originally Posted by BluPhant View Post
I ended up just ordering a new harness. All set, solved the problem completely. I thought I'd had similar issue with rear passenger side so ordered that harness as well. But magically it started working properly after the drivers front harness installed.

Blu



Pretty sure these jeeps are set up like all the others I have messed with (xj, wj, wk), on those all of the windows and locks run through the main switch in the drivers door. so messed up wires in the front door could actually be messing with the others. @Mattack not sure if the harness is different but I have a complete drivers harness from a 2007 limited if you wanted to try it. Just let me know and we can work something out.
heffercow is offline  
post #7 of 8 (permalink) Old 07-11-2018, 11:42 PM
Junior Member
Points: 460, Level: 9 Points: 460, Level: 9 Points: 460, Level: 9
Level up: 20% Level up: 20% Level up: 20%
Activity: 0% Activity: 0% Activity: 0%
 
Mattack's Avatar
 
Join Date: Jan 2018
Location: Virginia
Own a Commander?: Yes
Model year: 2007
Trim Package: Sport
Power-Train: 3.7L V-6
4WD
If 4WD - system: QT-I
Current Mileage: 128000
Posts: 16
@heffercow , I tried to PM but I found out my post count needs to be 15, I'm working on it. Let me get there and I will pm you to see what we can work out. I do have a new switch, but have not changed it out yet.
Mattack is offline  
post #8 of 8 (permalink) Old 07-13-2018, 04:57 PM Thread Starter
Member
Points: 6,425, Level: 52 Points: 6,425, Level: 52 Points: 6,425, Level: 52
Level up: 38% Level up: 38% Level up: 38%
Activity: 0% Activity: 0% Activity: 0%
 
BluPhant's Avatar
 
Join Date: Sep 2009
Location: Southern Connecticut
Own a Commander?: Yes
Model year: 2007
Trim Package: Limited
Power-Train: 4.7L V-8
4WD
If 4WD - system: QT-I
Posts: 40
Quote:
Originally Posted by Mattack View Post
I was on Mopar looking for the drivers side replacement as you inspired me to do so. I do have the sport model, 56048811AA is the part # for $60. The DIY in me wants to take out the original and fix. The practical side is telling me to pay the $60. My original has the cracked wires in the boot. Works most of the time, but when it rains I have some issues. Also, the rear drivers door would only roll down and not up. It will be interesting to see if its the harness or the window regulator.
Well, I had the same exact thought process with a significantly more expensive part. I opted to get the harness rather than repairing it because I didn't want to have to think about it again. If you opt to repair, you're going to have to pull the whole old harness out to do it right (soldering in 2" of space is less than ideal). You'll have to be very careful with the wire holders as you are pulling it out too, as you'll have to reuse them.

Good luck with it!

Blu


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Leather Seats/Alpine iDA-X001 HU/SC-C1 Sirius Tuner/Wheel Locks/Foglites/nüvi 200W GPS
EVIC from 2ooo GC/EVS II Security (Sentry Key)/Under-Dash Courtesy Lights/Hunter 4x4 steps
Rear Flipper Glass Pad/Trail Rated Badge/Custom tint


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

V8 4.7l Flex Fuel, Remote Start, GPS, Saddle Brown Leather, REC GPS, VES, Sirius, Tow Package

"No one can make you feel inferior without your consent."
Eleanor Roosevelt, 'This Is My Story,' 1937
BluPhant is offline  
Sponsored Links
Advertisement
 
Reply

  Jeep Commander Forums: Jeep Commander Forum > Jeep Commander Discussion > General Commander Discussion

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jeep Commander Forums: Jeep Commander Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome