Original Owners? - Jeep Commander Forums: Jeep Commander Forum
General Commander Discussion General Discussion involving the Jeep Commander goes here. If it does not fit into a more specific category below, post it here.

 2Likes
  • 2 Post By Magnum6
 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old 03-19-2019, 02:55 PM Thread Starter
Senior Member
Points: 37,431, Level: 100 Points: 37,431, Level: 100 Points: 37,431, Level: 100
Level up: 0% Level up: 0% Level up: 0%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Apr 2008
Location: NE Arizona
Own a Commander?: Yes
Model year: 2009
Trim Package: Limited
Power-Train: 5.7L V-8 Hemi
4WD
If 4WD - system: QD-II
Current Mileage: 140,000
Posts: 181
Original Owners?

Hey all!

I am a long time member but haven't posted in awhile. I am the original owner of my '09 Commander. It now has 140k miles on the clock. Here are some issues that have come up:

1) The biggest issue I have had is with the moonroof leaking. The entire mechanism and glass/rubber have been replaced a few times but I still experience leaking. Water will trickle out of the little access port in the handles on the A pillar.

2) A recent issue is the radio has stopped working. My wife's 300 has the same radio with the same issue but the dealer replaced it right away. On the Commander, they are aren't ready to replace it and keep monkeying with the wiring with no solution yet.

3) The drivers seat split at the seam and a crack developed on the left bolster. I need to get into an upholstery shop and see if they can match the brown leather.

Thankfully, I still have the lifetime Maxcare warranty, which covers most of these issues. I am sure the bean counters at Chrysler aren't happy that I continue to take advantage of the warranty!

How many of you are original owners? For all owners, what major issues have you had with you Commander as it ages?
consolidation is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 03-19-2019, 03:27 PM
Super Moderator
Points: 19,430, Level: 88 Points: 19,430, Level: 88 Points: 19,430, Level: 88
Level up: 16% Level up: 16% Level up: 16%
Activity: 100% Activity: 100% Activity: 100%
 
Big Blue's Avatar
 
Join Date: Oct 2015
Location: East Coast of Florida
Own a Commander?: Yes
Model year: 2008
Trim Package: Sport
Power-Train: 4.7L V-8
4WD
If 4WD - system: QT-II
Current Mileage: 101,300
Posts: 4,792
Garage
Quote:
Originally Posted by consolidation View Post
Hey all!

I am a long time member but haven't posted in awhile. I am the original owner of my '09 Commander. It now has 140k miles on the clock. Here are some issues that have come up:

1) The biggest issue I have had is with the moonroof leaking. The entire mechanism and glass/rubber have been replaced a few times but I still experience leaking. Water will trickle out of the little access port in the handles on the A pillar.

2) A recent issue is the radio has stopped working. My wife's 300 has the same radio with the same issue but the dealer replaced it right away. On the Commander, they are aren't ready to replace it and keep monkeying with the wiring with no solution yet.

3) The drivers seat split at the seam and a crack developed on the left bolster. I need to get into an upholstery shop and see if they can match the brown leather.

Thankfully, I still have the lifetime Maxcare warranty, which covers most of these issues. I am sure the bean counters at Chrysler aren't happy that I continue to take advantage of the warranty!

How many of you are original owners? For all owners, what major issues have you had with you Commander as it ages?
@consolidation;

Welcome back; I'm not an original owner, I'm a 2nd owner and have had my XK since August of 2014; The 3rd post in the thread below touches on some of the problems I had in my very first year of ownership;

https://www.jeepcommander.com/forums...oking-buy.html

As far as the stereo goes, I'll tell you now, you will be better served replacing it; I went through 3 MyGIG REC factory stereos in about a 18 month period; Even what the factory calls "new replacements" are only refurbished/reconditioned units and they simply don't hold up, particularly in hot climates;

I finally got smart and went with an aftermarket Pioneer AVH-X490BS CD/DVD RDS AV head unit with Sirius XM Receiver. It turned out to be one of the smarter decisions I've made - and it gave me Bluetooth capability which was nice because my factory unit did not come with U-Connect.

I'd kill for that lifetime warranty that you have, you're very fortunate.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Last edited by Big Blue; 03-26-2019 at 05:50 PM.
Big Blue is offline  
post #3 of 7 (permalink) Old 03-19-2019, 03:49 PM
Member
Points: 628, Level: 12 Points: 628, Level: 12 Points: 628, Level: 12
Level up: 56% Level up: 56% Level up: 56%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Jul 2018
Location: Oldham, England
Own a Commander?: Yes
Model year: 2006
Trim Package: Limited
Power-Train: 3.0L CRD
4WD
If 4WD - system: QD-II
Current Mileage: 120000
Posts: 51
Quote:
Originally Posted by consolidation View Post
Hey all!

I am a long time member but haven't posted in awhile. I am the original owner of my '09 Commander. It now has 140k miles on the clock. Here are some issues that have come up:

1) The biggest issue I have had is with the moonroof leaking. The entire mechanism and glass/rubber have been replaced a few times but I still experience leaking. Water will trickle out of the little access port in the handles on the A pillar.
im the third owner of mine, its done 120,000 miles. previous owners had looked after it well though looking at service book etc, ive had no real problems so far. the moon roof leak seems common, it sounds silly but look at the floor drains - they clog up at floor level and water backs up coming out of the A pillar screw caps - ive just cleaned mine out again after the same problem.

2) A recent issue is the radio has stopped working. My wife's 300 has the same radio with the same issue but the dealer replaced it right away. On the Commander, they are aren't ready to replace it and keep monkeying with the wiring with no solution yet.
Im discussing with Alpine (radio supplier) a new ribbon cable on the basis that the scren works sometimes (and i aint paying a grand for a radio when it still plays everything and teh screen works when its cold)

3) The drivers seat split at the seam and a crack developed on the left bolster. I need to get into an upholstery shop and see if they can match the brown leather.

Thankfully, I still have the lifetime Maxcare warranty, which covers most of these issues. I am sure the bean counters at Chrysler aren't happy that I continue to take advantage of the warranty!

How many of you are original owners? For all owners, what major issues have you had with you Commander as it ages?
good fun to drive though.
CP07 is offline  
 
post #4 of 7 (permalink) Old 03-20-2019, 05:59 AM
Member
Points: 628, Level: 12 Points: 628, Level: 12 Points: 628, Level: 12
Level up: 56% Level up: 56% Level up: 56%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Jul 2018
Location: Oldham, England
Own a Commander?: Yes
Model year: 2006
Trim Package: Limited
Power-Train: 3.0L CRD
4WD
If 4WD - system: QD-II
Current Mileage: 120000
Posts: 51
just amother thought, quite a few owners have had a problem with the air-con failing. the main cause i found was the pipes to the rear get covered in road spray (near the rear of the rear wheel arch), including salt in snowy areas (probably not australia or the warmer parts of the world) which corrodes the pipes and the system loses the refridgerant. some people have capped off the rear pipes, but i but got a kit off fleabay (e-bay) patched the pipe and regassed the system - so far, 2 years later, it's still ok.
CP07 is offline  
post #5 of 7 (permalink) Old 03-24-2019, 09:53 PM
Junior Member
Points: 1,354, Level: 20 Points: 1,354, Level: 20 Points: 1,354, Level: 20
Level up: 54% Level up: 54% Level up: 54%
Activity: 0% Activity: 0% Activity: 0%
 
Magnum6's Avatar
 
Join Date: Jun 2017
Own a Commander?: Yes
Model year: 2006
Trim Package: Limited
Power-Train: 4.7L V-8
4WD
If 4WD - system: QD-II
Current Mileage: 230000
Posts: 14
Garage
I'm an original owner - 2006, bought it new. I'll hit 250k miles on that thing in the next 2 months! If it can happen to the XK, I've seen it!
tankman67 and Big Blue like this.
Magnum6 is offline  
post #6 of 7 (permalink) Old 03-25-2019, 10:16 AM
Member
Points: 537, Level: 10 Points: 537, Level: 10 Points: 537, Level: 10
Level up: 74% Level up: 74% Level up: 74%
Activity: 10% Activity: 10% Activity: 10%
 
Arapahoe's Avatar
 
Join Date: Nov 2018
Location: FL Gulf Coast
Own a Commander?: Yes
Model year: 2006
Trim Package: Limited
Power-Train: 5.7L V-8 Hemi
4WD
If 4WD - system: QD-II
Current Mileage: 131,000
Posts: 47
Another original owner of an 06 w/ 131000 miles currently on the Hemi 4x4.

Problems: The biggest was probably the Diff Bushings which just happened last October. Otherwise, just general stuff like new water pump, starter, radiator hoses, and I had to replace my trans cooling lines once because they were leaking a bit where they fit/connect to the trans cooling assembly (not sure if all models have this... might be just for the towing package Commanders?).

Regarding the A pillar leak, every so often I'll vacuum those holes to eliminate blockage. The top is no problem, the bottom requires a little work to get to. Also, I cut the little rubber drain nipple to allow any objects that would otherwise block the drain a chance to just pass through. Once I've done this, I'll test it with a glass of water to see if they're flowing freely.

Additionally, regarding your radio. There is a company that sells refurbished radio units that basically just plug and play in our Commanders. Not sure which one you have, but if I remember correctly, they offer a few different Jeep models.

Hope this helps.
Arapahoe is offline  
post #7 of 7 (permalink) Old 03-26-2019, 08:40 PM
Junior Member
Points: 699, Level: 13 Points: 699, Level: 13 Points: 699, Level: 13
Level up: 98% Level up: 98% Level up: 98%
Activity: 10% Activity: 10% Activity: 10%
 
Join Date: Jun 2018
Location: Minneapolis, Minnesota
Own a Commander?: Yes
Model year: 2007
Trim Package: Overland
Power-Train: 5.7L V-8 Hemi
4WD
If 4WD - system: QD-II
Current Mileage: 81000
Posts: 15
I'm the second owner of my 2007; the original owner is a good friend of mine, though. He had no problems I'm aware of, and I've only had to replace the water pump at about 75,000. I get a little water dripping down the inside of the windshield directly in front of the passenger seat on rare occasions (never actually seen it happen, only the telltale residue), so I'm not sure what's the source of that problem. I hope you don't suffer the same issue.
doesgo is offline  
Sponsored Links
Advertisement
 
Reply

  Jeep Commander Forums: Jeep Commander Forum > Jeep Commander Discussion > General Commander Discussion

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jeep Commander Forums: Jeep Commander Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Cheap/Good Original Size Tires Zeke Wheels / Tires 7 01-10-2009 10:25 PM
Selling original Wheels off 2006 Commander commando Parts For Sale/Wanted/Trade 3 07-24-2007 07:32 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome