Oil light comes on after restarting hot car - Page 2 - Jeep Commander Forums: Jeep Commander Forum
General Commander Discussion General Discussion involving the Jeep Commander goes here. If it does not fit into a more specific category below, post it here.

 1Likes
Reply
 
LinkBack Thread Tools Display Modes
post #11 of 22 (permalink) Old 07-29-2019, 04:33 PM
Senior Member
Points: 4,295, Level: 41 Points: 4,295, Level: 41 Points: 4,295, Level: 41
Level up: 73% Level up: 73% Level up: 73%
Activity: 89% Activity: 89% Activity: 89%
 
Wombler's Avatar
 
Join Date: Jun 2014
Location: California
Own a Commander?: Yes
Model year: 2006
Trim Package: Limited
Power-Train: 5.7L V-8 Hemi
4WD
If 4WD - system: QD-II
Current Mileage: 113676
Posts: 104
Garage
Quote:
Originally Posted by Big Blue View Post
I knew about the MDS, I didn't know that was the reason why the Hemi's used 5W20. Unfortunately, I don't know as much as I would like to, particularly where the Hemi's are concerned.
Ah...well yes, the MDS system requires 5w20 since it solely relies on oil pressure to activate/deactivate the lifters. Too heavy and it can't properly work with the tiny valves. If you've disabled the system or even removed the solenoids then it doesn't matter what oil you run. I've heard some of the Hemi car guys have run 5w10 and still be okay since it's a lighter oil.

Quote:
Originally Posted by slabadie View Post
OK I ran the scan P0522 oil pressure switch/low voltage.
One of the same codes I got! At least you know your oil system is fine so nothing's going to go bad or get destroyed before you get the sensor changed. Just make sure you get an official Mopar one.

2006 Dark Khaki Limited, Hemi, QD-II w/ all the options.
Inertia Performance Heads, Full SRT 6.1 Valve Train, Custom Crower Cam, Double Roller Timing Set, Trend Performance forged Pushrods, High PSI Oil Pump, ARH Long Tube Headers and Mids, Borla Catback, aFe Stage 2 Intake, AEM X-Series WB UEGO & 100psi Oil Guages, PowerStop Drilled & Slotted Rotors, MDS On Light, Kenwood in-dash Nav, HID Projectors and full LED lighting upgrade

Need to get it on a dyno....
Wombler is offline  
Sponsored Links
Advertisement
 
post #12 of 22 (permalink) Old 07-29-2019, 05:20 PM Thread Starter
Junior Member
Points: 104, Level: 2 Points: 104, Level: 2 Points: 104, Level: 2
Level up: 8% Level up: 8% Level up: 8%
Activity: 0% Activity: 0% Activity: 0%
 
slabadie's Avatar
 
Join Date: Jul 2019
Location: Stroudsburg, PA
Own a Commander?: Yes
Model year: 2007
Trim Package: Sport
Power-Train: 3.7L V-6
4WD
Current Mileage: 89,500
Posts: 9
Thank you everyone for your contribution to this thread
slabadie is offline  
post #13 of 22 (permalink) Old 07-29-2019, 05:47 PM
Super Moderator
Points: 21,500, Level: 92 Points: 21,500, Level: 92 Points: 21,500, Level: 92
Level up: 15% Level up: 15% Level up: 15%
Activity: 100% Activity: 100% Activity: 100%
 
Big Blue's Avatar
 
Join Date: Oct 2015
Location: East Coast of Florida
Own a Commander?: Yes
Model year: 2008
Trim Package: Sport
Power-Train: 4.7L V-8
4WD
If 4WD - system: QT-II
Current Mileage: 102,100
Posts: 5,193
Garage
Quote:
Originally Posted by slabadie View Post
Blue, where do I find the EVIC?
@slabadie;

The EVIC (Electronic Vehicle Information Center) is circled in Red in the pic below; That would be where any DTC's (Diagnostic Trouble Codes) would show up.




To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Last edited by Big Blue; 07-29-2019 at 05:50 PM.
Big Blue is offline  
 
post #14 of 22 (permalink) Old 07-29-2019, 06:23 PM
Senior Member
Points: 2,778, Level: 32 Points: 2,778, Level: 32 Points: 2,778, Level: 32
Level up: 19% Level up: 19% Level up: 19%
Activity: 15% Activity: 15% Activity: 15%
 
Join Date: Oct 2017
Location: Evanston, IL
Own a Commander?: Yes
Model year: 2010
Trim Package: Sport
Power-Train: 3.7L V-6
4WD
If 4WD - system: QT-I
Current Mileage: 100k
Posts: 297
I'll add that the sensor is located above the oil filter of the 3.7 and has one wire going to the plug.
Legofan is offline  
post #15 of 22 (permalink) Old 07-30-2019, 10:28 AM
Senior Member
Points: 3,083, Level: 34 Points: 3,083, Level: 34 Points: 3,083, Level: 34
Level up: 22% Level up: 22% Level up: 22%
Activity: 36% Activity: 36% Activity: 36%
 
drm4633's Avatar
 
Join Date: Oct 2017
Location: Middle TN
Own a Commander?: Yes
Model year: 2007
Trim Package: Limited
Power-Train: 5.7L V-8 Hemi
4WD
If 4WD - system: QD-II
Current Mileage: 130k
Posts: 303
i never received a message on the evic about low oil pressure? did anyone else?
drm4633 is offline  
post #16 of 22 (permalink) Old 07-30-2019, 04:02 PM
Senior Member
Points: 2,150, Level: 27 Points: 2,150, Level: 27 Points: 2,150, Level: 27
Level up: 50% Level up: 50% Level up: 50%
Activity: 84% Activity: 84% Activity: 84%
 
Stircrayzy's Avatar
 
Join Date: Mar 2017
Location: East Detroit
Own a Commander?: Yes
Model year: 2006
Trim Package: Limited
Power-Train: 5.7L V-8 Hemi
4WD
If 4WD - system: QD-II
Current Mileage: 123000
Posts: 110
Quote:
Originally Posted by slabadie View Post
anyone concerned that it could be the oil pump?
Yes,
Or worn bearings...?
I always assume worst case scenario until proven otherwise.
Stircrayzy is offline  
post #17 of 22 (permalink) Old 07-30-2019, 04:05 PM
Super Moderator
Points: 21,500, Level: 92 Points: 21,500, Level: 92 Points: 21,500, Level: 92
Level up: 15% Level up: 15% Level up: 15%
Activity: 100% Activity: 100% Activity: 100%
 
Big Blue's Avatar
 
Join Date: Oct 2015
Location: East Coast of Florida
Own a Commander?: Yes
Model year: 2008
Trim Package: Sport
Power-Train: 4.7L V-8
4WD
If 4WD - system: QT-II
Current Mileage: 102,100
Posts: 5,193
Garage
Quote:
Originally Posted by drm4633 View Post
i never received a message on the evic about low oil pressure? did anyone else?
I could be wrong here because I've never received a low oil pressure warning - but I think it may just a be "dummy light".

I only mentioned the EVIC to the OP so he could check for any DTC's that may have been generated - and he did say he found "P0522 oil pressure switch/low voltage."


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Last edited by Big Blue; 07-30-2019 at 05:41 PM.
Big Blue is offline  
post #18 of 22 (permalink) Old 07-31-2019, 11:31 AM
Senior Member
Points: 3,083, Level: 34 Points: 3,083, Level: 34 Points: 3,083, Level: 34
Level up: 22% Level up: 22% Level up: 22%
Activity: 36% Activity: 36% Activity: 36%
 
drm4633's Avatar
 
Join Date: Oct 2017
Location: Middle TN
Own a Commander?: Yes
Model year: 2007
Trim Package: Limited
Power-Train: 5.7L V-8 Hemi
4WD
If 4WD - system: QD-II
Current Mileage: 130k
Posts: 303
Quote:
Originally Posted by Big Blue View Post
I could be wrong here because I've never received a low oil pressure warning - but I think it may just a be "dummy light".

I only mentioned the EVIC to the OP so he could check for any DTC's that may have been generated - and he did say he found "P0522 oil pressure switch/low voltage."

ah...dummy light yes but no messages unless you trigger the dtc code via key switch, right?
drm4633 is offline  
post #19 of 22 (permalink) Old 07-31-2019, 08:38 PM
Super Moderator
Points: 21,500, Level: 92 Points: 21,500, Level: 92 Points: 21,500, Level: 92
Level up: 15% Level up: 15% Level up: 15%
Activity: 100% Activity: 100% Activity: 100%
 
Big Blue's Avatar
 
Join Date: Oct 2015
Location: East Coast of Florida
Own a Commander?: Yes
Model year: 2008
Trim Package: Sport
Power-Train: 4.7L V-8
4WD
If 4WD - system: QT-II
Current Mileage: 102,100
Posts: 5,193
Garage
Quote:
Originally Posted by drm4633 View Post
ah...dummy light yes but no messages unless you trigger the dtc code via key switch, right?
I believe that's correct - or if you read your DTC's with a scanner like the Superchip's flashpaq or some other OBD-II Scanning device/software.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Big Blue is offline  
post #20 of 22 (permalink) Old 07-31-2019, 08:41 PM
Senior Member
Points: 16,022, Level: 81 Points: 16,022, Level: 81 Points: 16,022, Level: 81
Level up: 35% Level up: 35% Level up: 35%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: May 2006
Location: Orlando, FL
Own a Commander?: Yes
Model year: 2006
Trim Package: Limited
Power-Train: 4.7L V-8
4WD
If 4WD - system: QD-II
Current Mileage: 165,000
Posts: 1,468
Not true, was coming back from dropping wife at airport, got a message and maybe a tone alerting me to an oil pressure problem. Pulled into a parts store. I checked oil level all was well. Turned out to be a bad oil senor.
Creek is offline  
Sponsored Links
Advertisement
 
Reply

  Jeep Commander Forums: Jeep Commander Forum > Jeep Commander Discussion > General Commander Discussion

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jeep Commander Forums: Jeep Commander Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome