3.7 running warm - Jeep Commander Forums: Jeep Commander Forum
General Commander Discussion General Discussion involving the Jeep Commander goes here. If it does not fit into a more specific category below, post it here.

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old Yesterday, 07:28 PM Thread Starter
Member
Points: 3,372, Level: 36 Points: 3,372, Level: 36 Points: 3,372, Level: 36
Level up: 15% Level up: 15% Level up: 15%
Activity: 9% Activity: 9% Activity: 9%
 
Join Date: May 2016
Own a Commander?: Yes
Model year: 2007
Trim Package: Sport
Power-Train: 3.7L V-6
4WD
If 4WD - system: QT-I
Current Mileage: 165,000
Posts: 31
3.7 running warm

Hi,

My 3.7L commander has been sitting most of the summer, I try to start it once a week. Today I drove it down to the car wash and the temp gauge was on the right of the center mark and nearly half way to the next mark. Usually its slightly left of the center mark and I've never seen it go past the center mark. The fan was running hard, no engine light, is this a sign to change the thermostat? Anything else I should check? Radiator fluid level is good.

Thanks
Jason
synapse46 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old Yesterday, 09:05 PM
Super Moderator
Points: 22,950, Level: 93 Points: 22,950, Level: 93 Points: 22,950, Level: 93
Level up: 60% Level up: 60% Level up: 60%
Activity: 100% Activity: 100% Activity: 100%
 
Big Blue's Avatar
 
Join Date: Oct 2015
Location: East Coast of Florida
Own a Commander?: Yes
Model year: 2008
Trim Package: Sport
Power-Train: 4.7L V-8
4WD
If 4WD - system: QT-II
Current Mileage: 101,200
Posts: 5,259
Garage
Quote:
Originally Posted by synapse46 View Post
Hi,

My 3.7L commander has been sitting most of the summer, I try to start it once a week. Today I drove it down to the car wash and the temp gauge was on the right of the center mark and nearly half way to the next mark. Usually its slightly left of the center mark and I've never seen it go past the center mark. The fan was running hard, no engine light, is this a sign to change the thermostat? Anything else I should check? Radiator fluid level is good.

Thanks
Jason
Jason;

Thermostat is a logical place to start; It's cheap enough, I'd replace it and then see where you stand.

If the problem persists after that, I'd start looking at the water pump.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Big Blue is offline  
post #3 of 3 (permalink) Old Yesterday, 09:08 PM Thread Starter
Member
Points: 3,372, Level: 36 Points: 3,372, Level: 36 Points: 3,372, Level: 36
Level up: 15% Level up: 15% Level up: 15%
Activity: 9% Activity: 9% Activity: 9%
 
Join Date: May 2016
Own a Commander?: Yes
Model year: 2007
Trim Package: Sport
Power-Train: 3.7L V-6
4WD
If 4WD - system: QT-I
Current Mileage: 165,000
Posts: 31
Sounds good. Do I need to drain the radiator fluid or will there just be small amount of fluid loss.
synapse46 is offline  
Sponsored Links
Advertisement
 
Reply

  Jeep Commander Forums: Jeep Commander Forum > Jeep Commander Discussion > General Commander Discussion

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jeep Commander Forums: Jeep Commander Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 2 (1 members and 1 guests)
Creek
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome