Bad reviews??? - Jeep Commander Forums: Jeep Commander Forum
General Commander Discussion General Discussion involving the Jeep Commander goes here. If it does not fit into a more specific category below, post it here.

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 12 (permalink) Old 06-15-2009, 09:43 PM Thread Starter
Points: 19, Level: 1 Points: 19, Level: 1 Points: 19, Level: 1
Level up: 37% Level up: 37% Level up: 37%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Jun 2009
Posts: 3
Bad reviews???

Hello, Great forum and a lot of great info!

I was thinking about buying a Commander, kinda getting bored with my 02' 4x4 Expedition...but it gets 15mpg city with the mods I did......

-AF1
-5.4L 67K miles
-02 Expy 4X4
-20% Tint
-Hawk Pads
-Edge Evo 2
-Troyer E-Fans
-285/70/17 BFG MT's
-Mobil 1 Oils thoughout
-Magnaflow S/S SISO #15861
-BBK 1 5/8 Polished Ceramic Headers
-MotoBlue Underdrive pulleys w / Gatorback


Anyway,

I was reading a lot of reviews on the 2006 Commander at Edmunds or one of those review websites and a lot of them noted a lot of problems.....sunroofs leaking, interior flooding, windshields whistling and the windshield frames rusting out, water can dump on your head after a rainstorm and you open the doors....also I read that the underbody rusts really badly.

Is the gas mileage really that bad on the 5.7 liter? I have a 5.4 in my current Ford Expedition and I get 15mpg city 18mpg hiway at 75mph+

Have a lot of you also experienced these problems? If, so were the issues fixed by Jeep? Is a 2007 model year better as they may have fixed some issues?

Thanks in advance

Last edited by Padron; 06-15-2009 at 09:47 PM.
Padron is offline  
Sponsored Links
Advertisement
 
post #2 of 12 (permalink) Old 06-15-2009, 09:46 PM
Senior Member
Points: 63,765, Level: 100 Points: 63,765, Level: 100 Points: 63,765, Level: 100
Level up: 0% Level up: 0% Level up: 0%
Activity: 0% Activity: 0% Activity: 0%
 
a49erFan's Avatar
 
Join Date: Jan 2007
Location: Sunny Arizona
Posts: 12,582
Send a message via Yahoo to a49erFan
Read through the forum, we have had members with issues but I do not think that any of them are not found in any other brand vehicle.



a49erFan is offline  
post #3 of 12 (permalink) Old 06-15-2009, 10:58 PM
Senior Member
Points: 27,950, Level: 98 Points: 27,950, Level: 98 Points: 27,950, Level: 98
Level up: 60% Level up: 60% Level up: 60%
Activity: 0% Activity: 0% Activity: 0%
 
07JeepXK's Avatar
 
Join Date: Sep 2007
Location: Orchard Park, NY
Posts: 6,311
I have never heard of the windshield frames rusting out on the Commanders.




2007 4.7 Liter XK | Front OME MD Springs w/Superlift Preload Spacer | Rear 4" Superlift Springs | Bilstein 5125 Rear Shocks | JBA UCA's | Rusty's Rear Adjustable Track Bar | Black Rock 997 Wheels | Fred Goeske 1/4 Inch Wheel Spacers | 305/70R17 Goodyear Wrangler MT/R w/Kevlar | Airflow Snorkel | Flowmaster 40 Series Muffler | Superchips Flashpaq | Mopar Skids | 4xGuard Belly Guard | American Rebel Rear Diff Cover | Rear Powertrax No-Slip | Front E-Locker | Rear Heat/AC Delete
07JeepXK is offline  
 
post #4 of 12 (permalink) Old 06-16-2009, 05:01 AM
Points: 4,498, Level: 42 Points: 4,498, Level: 42 Points: 4,498, Level: 42
Level up: 74% Level up: 74% Level up: 74%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Jan 2006
Posts: 401
I haven't had any of the problems you mention, and I've not read about anyone having serious (or any) rust problems. No car is completely issue-free for every owner, so don't expect perfection. But I've had my '06 for 3 and a half years and I am still thrilled to own it!
Haags is offline  
post #5 of 12 (permalink) Old 06-16-2009, 06:46 AM
Senior Member
Points: 4,379, Level: 42 Points: 4,379, Level: 42 Points: 4,379, Level: 42
Level up: 15% Level up: 15% Level up: 15%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Sep 2008
Location: West Palm Beach, Florida
Posts: 329
Issues? Well, let's see. On my '07 Commander with about 27,000 miles on it, I've had a leak in the tranny fixed, a windshield moulding replaced, a broken cup holder in the back fold down arm rest replaced and a heated seat part replaced, all on warranty. I love the Commander, it's go anywhere, do anything and most comfortable truck I have ever owned.

The gas mileage isn't terrible with 15.3 MPG in the city and 19.6 MPG on highway going just over 70 MPG flat with cruise control. When I replace the plugs at 30k, I can probably do better. I have the 4.7 V8, 3.73 rear end and has the QuadraTracII 4 wheel drive.

2007 Jeep Commander 4X4, 4.7, Steel Blue
2003 Ford Thunderbird, White, Black Top w/ Port Holes
BADOS is offline  
post #6 of 12 (permalink) Old 06-16-2009, 09:39 AM
Points: 87, Level: 1 Points: 87, Level: 1 Points: 87, Level: 1
Level up: 74% Level up: 74% Level up: 74%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Jun 2009
Posts: 8
I have had mine since new and now have 33K miles on it. Of all the issues you mention I have none. Just routine maintenance and all is well. -Bob
Old Salt is offline  
post #7 of 12 (permalink) Old 06-16-2009, 10:53 AM
Senior Member
Points: 14,892, Level: 79 Points: 14,892, Level: 79 Points: 14,892, Level: 79
Level up: 9% Level up: 9% Level up: 9%
Activity: 0% Activity: 0% Activity: 0%
 
GPintheMitten's Avatar
 
Join Date: Nov 2008
Location: Flushing, Michigan
Posts: 2,406
No problems with my 07 Limited 62,000 miles.

After a hard rain, just don't stand too close to the door when you open it. It can trap water between the body and the door. There is a thread on a solution but it doesn't bother me. Sometimes I get about a cup of water that can get your shoes wet. But it doesn't get inside the car.

Some people have experienced the drain tubes in the sun roof clogging and that can lead to water in the cab but you can resolve that fairly easily if it happens. It hasn't happened to me.

No rust at all on mine.

2007 XK Limited, 5.7L Hemi, QDII, Rusty's 2" lift, Spidertrax 1.5 inch wheel spacers, GetLost4x4's front hitch mount for portable winch.GY Duratracs 265/70R17s , Rola Roof Rack, diy built spare tire mount for the roof rack.
GPintheMitten is offline  
post #8 of 12 (permalink) Old 06-16-2009, 10:59 AM
Moderator
Points: 41,300, Level: 100 Points: 41,300, Level: 100 Points: 41,300, Level: 100
Level up: 0% Level up: 0% Level up: 0%
Activity: 4% Activity: 4% Activity: 4%
 
HueyPilotVN's Avatar
 
Join Date: Mar 2007
Location: Lake Havasu City, Arizona
Own a Commander?: Yes
Model year: 2006
Trim Package: Sport
4WD
If 4WD - system: QD-II
Current Mileage: HueyPilotVN
Posts: 2,248
I have had my 07 for a little over 2 years. I took it to the dealer for the first time about a month ago with problems with the A/C. They replaced the compressor and it then thru a belt and lost the idler pulley. I think they screwed up the belt install. No other problems. Actually, I think we might have contributed to the compressor problem because we left the commander idle for long periods with the A/C on to keep the dogs cool while shopping.

2007 Jeep Green Limited 4.7 Flex Fuel, RR 2.5" 4 inch Superlift coils on rear, 1.5" Spacers, Bridgestone 265/70/17, K&N CAI, Flowmaster, Diamond Plate Locking Trunk, Blue Ox Baseplate w/D-rings, "Get Lost 4X4" Front Bumper, T-Max 9000 winch, "Get Lost rear tire carrier, 30 gal second gas tank.
Second 2007 Jeep Green Limited Leather HEMI QDII VES Uconnect Flowmaster OEM Skids Tow Package

Maybe the two will meet up soon edit: they did , I now have 2,now gave 1 away...and got it back again.
HueyPilotVN is offline  
post #9 of 12 (permalink) Old 06-16-2009, 11:02 AM
Points: 3,094, Level: 34 Points: 3,094, Level: 34 Points: 3,094, Level: 34
Level up: 30% Level up: 30% Level up: 30%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Dec 2005
Posts: 170
Quote:
Originally Posted by Padron View Post
Hello, Great forum and a lot of great info!

I was thinking about buying a Commander, kinda getting bored with my 02' 4x4 Expedition...but it gets 15mpg city with the mods I did......

-AF1
-5.4L 67K miles
-02 Expy 4X4
-20% Tint
-Hawk Pads
-Edge Evo 2
-Troyer E-Fans
-285/70/17 BFG MT's
-Mobil 1 Oils thoughout
-Magnaflow S/S SISO #15861
-BBK 1 5/8 Polished Ceramic Headers
-MotoBlue Underdrive pulleys w / Gatorback


Anyway,

I was reading a lot of reviews on the 2006 Commander at Edmunds or one of those review websites and a lot of them noted a lot of problems.....sunroofs leaking, interior flooding, windshields whistling and the windshield frames rusting out, water can dump on your head after a rainstorm and you open the doors....also I read that the underbody rusts really badly.

Is the gas mileage really that bad on the 5.7 liter? I have a 5.4 in my current Ford Expedition and I get 15mpg city 18mpg hiway at 75mph+

Have a lot of you also experienced these problems? If, so were the issues fixed by Jeep? Is a 2007 model year better as they may have fixed some issues?

Thanks in advance
Probs I've had.
*Whistling window..fixed under Jeep Warranty.

*Passenger side window auto up feature stopped working...fixed under Jeep Warranty.

*Rattling in rear area....fixed for awhile under Jeep Warranty...rattling started again.

*Noisy AC fan...fixed under Jeep Warranty.

*Smartbeams stopped working 2 months after purchase...Jeep service could never find out what the problem was...still not fixed.

*Loose passenger mirror...flops in the wind...happened after factory warranty expired..decided not to spend $100 deductable to have it fixed under extended warranty...still floppin.

*Transfer case motor and switch went out.....fixed under extended warranty.

*Fuel line leak....fixed under extended warranty. (thank goodness car did not catch fire and kill us both)

*Lighting on dash starting to go out...lighting on heat and ac controls going out.

*Auto up feature on driver side window just stopped working a few days ago.

*Side molding starting to seperate from mounts.

*Nav DVD disc mysteriously "went bad"....found a new one on EBAY for cheap...Chrylser wanted $150.00 for a replacement...

We have a 2006 Limited 4x4 with the Hemi, purchased new...64K miles on it now...perfectly maintained, garage kept, never mistreated.
FWIW, you should getthe same gas mileage as you do in your Expedition.

When the thing is working, it works real good. One of, if not the most, capable vehicles, I've ever owned....(in the snow and ice I'm not sure if it can be beaten by any other vehicle short of a Range Rover/Land Rover), Tows great, carries alot of people, good cargo area...theres alot to love, but I have just been let down by the probs, never had this many probs from any vehicle I've bought new...or used for that matter...in the past.

I am trading my Commander in on a new Expedition ASAP...problem is, no dealership in my area has any Expeditions..especially not a limited 4x4 model. The one that did, sold it hours before we went to make the deal It'll be a few more months before the new Expeditions start rolling out again (Ford stopped making them when things went south) Soooooo I am going to have suffer through another few months of Commander ownership.

If you do get a Commander...buy a high end extended warranty. Good luck!

Last edited by Daytomann; 06-16-2009 at 11:28 AM.
Daytomann is offline  
post #10 of 12 (permalink) Old 06-16-2009, 09:08 PM Thread Starter
Points: 19, Level: 1 Points: 19, Level: 1 Points: 19, Level: 1
Level up: 37% Level up: 37% Level up: 37%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Jun 2009
Posts: 3
Thanks fellas,

a lot of great info and I am happy to hear most have not experienced the troubles reported by others.

It does sound like Daytonmann has had more than his share of troubles though.....sorry.

I am still undecided, I did go look at another 06 Commander Limited with the 5.7 Hemi and Navigation / DVD tonight....it had 24,000 miles and was around $25K

I think I can do better, but still need to search around. It drove nicely though....it would definately need some kind of lift and bigger tires though to improve the looks.....the ground clearance is pretty low in it's stock form.

Thanks and please keep any problems to look out for coming.


Question, does just one DVD come with the truck for the navigation? Is it good for the entire USA?

Thanks!

Last edited by Padron; 06-16-2009 at 09:15 PM.
Padron is offline  
Sponsored Links
Advertisement
 
Reply

  Jeep Commander Forums: Jeep Commander Forum > Jeep Commander Discussion > General Commander Discussion

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jeep Commander Forums: Jeep Commander Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome