Please Help! Rocky Road Lift Install! - Jeep Commander Forums: Jeep Commander Forum
Suspension / Lifts This is the place to discuss the suspension, lift systems, and other stuff underneath your Jeep Commander

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 13 (permalink) Old 01-05-2008, 10:49 PM Thread Starter
Senior Member
Points: 5,363, Level: 47 Points: 5,363, Level: 47 Points: 5,363, Level: 47
Level up: 7% Level up: 7% Level up: 7%
Activity: 0% Activity: 0% Activity: 0%
 
BoilerCommander's Avatar
 
Join Date: Jul 2007
Location: Northern Indiana
Posts: 526
Exclamation Please Help! Rocky Road Lift Install!

I am almost done with my install and I am stuck on the rear! It is supposed to be the easiest I know. We removed the shock, disconnect the sway bar. We jacked it up like it said to do but when we went to remove the bolt in the upper control arm we cant. It wont come out all the way and we can't wrench it from the wheel well because the spring is in the way. It concerns me how we will get this bolt back in as well!

PLEASE HELP! There is no give at all to remove the spring!
BoilerCommander is offline  
Sponsored Links
Advertisement
 
post #2 of 13 (permalink) Old 01-05-2008, 11:29 PM Thread Starter
Senior Member
Points: 5,363, Level: 47 Points: 5,363, Level: 47 Points: 5,363, Level: 47
Level up: 7% Level up: 7% Level up: 7%
Activity: 0% Activity: 0% Activity: 0%
 
BoilerCommander's Avatar
 
Join Date: Jul 2007
Location: Northern Indiana
Posts: 526
Wow. So this install could not have been more messed up. The fronts did not give me ANY trouble. The hardest part was holding the rear bolts on the strut tower when we were putting them in. We took pictures of how we modified the strut. We used the spring compressor the hold the spring, loosened the plate, and took the bolts out. Didnt have to grind anything.

Well then there is the "easy as cake rear" ummmm no.

We finally got the bolt to the upper control arm off and then we had to jack the **** out of the thing to even get the spring out. Not much play in the axle. I think it was because RR tells you to put the jack on the opposite axle. The thing was shaky even with 4 jack stands. We step on the wheel drum and get the spring out. even with it compressed there is NO WAY in hell we could get the polyurethane mount and the spring back in there. We pushed on the drum so hard it almost ripped the brake line, and we still had about 1" to go. NO LUCK. So it took us over an hour to put that wheel well back together with no lift pieces. the axle had shifted forward and we couldn't get the upper control in easily.

So I figured I would just take it to a shop. This would be really easy to do on a lift. I shoulda stopped there but figured I would just put the spacers on the rears and call it a night... and of course, the last lug I am tightening on the spacers is cross threaded. So now I cant even take the XK to a shop, I have to first find a lug similar to the one spidertrax sent me.

Why is the rear so difficult? I cant believe everyone said it was easy?!

Last edited by BoilerCommander; 01-06-2008 at 01:15 AM.
BoilerCommander is offline  
post #3 of 13 (permalink) Old 01-06-2008, 08:19 AM
Points: 905, Level: 16 Points: 905, Level: 16 Points: 905, Level: 16
Level up: 5% Level up: 5% Level up: 5%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Oct 2007
Posts: 94
Dude.... i am sorry for all of your trouble. i hate to even say it but all of your problems are solved with a Spring Coil Compressor. you can buy them at any auto store and most even rent them or loan them. with the SCC you dont even need to take the control arm or the rear sway bar loose. you compress the spring with a ratchet until you have the clearance. it really is cake.. i am pretty sure on my post of the RR lift i mentioned using one. Get it all back together and go get one. you will be done in less than an hour i promise.

You might need to strap the axle with a ratchet strap and pull it back into place in order to get every thing connected. You can drive the stud out and replace it fairly easy so dont panic. GOOD LUCK!!! I love a Jeep project!!! they never go quite like you plan.
wkfore is offline  
 
post #4 of 13 (permalink) Old 01-06-2008, 10:21 AM
Senior Member
Points: 6,156, Level: 51 Points: 6,156, Level: 51 Points: 6,156, Level: 51
Level up: 3% Level up: 3% Level up: 3%
Activity: 0% Activity: 0% Activity: 0%
 
JJSEBASTIAN's Avatar
 
Join Date: Apr 2007
Location: Syracuse, NY
Posts: 451
Congrats on getting the front done! I didn't have much of an issue with the rear. I know I unbolted both sides at the same time and was worried about the wire that was connected to my rear differential (I have QDII).
I do remember that I had to try a couple different combinations of putting the top of the spring back in, then the bottom, Spacer in then the spring, space on the spring when putting it in, etc.and vice versa. I don't rember which one it was, but I do remember it made a huge difference! I know it doesn't look like it should make a difference but it does!
JJSEBASTIAN is offline  
post #5 of 13 (permalink) Old 01-06-2008, 01:47 PM Thread Starter
Senior Member
Points: 5,363, Level: 47 Points: 5,363, Level: 47 Points: 5,363, Level: 47
Level up: 7% Level up: 7% Level up: 7%
Activity: 0% Activity: 0% Activity: 0%
 
BoilerCommander's Avatar
 
Join Date: Jul 2007
Location: Northern Indiana
Posts: 526
WK, I did use a spring compressor. The main concern I had while using it was that you could not place them opposite of each other. Using the compressor was the only way I could even get the spring out in the first place. (I think i remembered to pick one up thanks to your post! The compressor also helped make the fronts a piece of cake)

I think what it all comes down to is the position of the Jack. The instructions say to jack up the opposite side axle that you are working on. Well, the entire rear differential is connected to each other so you are having an opposing force holding the spring in place. Theoretically it makes sense, jack up the other axle forcing the opposite one down. Well it made the XK unstable on the jack and no play in moving the axle around. I think the only way to really do it is to jack up the frame and let the axle hang loose.

Where did you guys jack it up from?

Last edited by BoilerCommander; 01-06-2008 at 01:49 PM.
BoilerCommander is offline  
post #6 of 13 (permalink) Old 01-06-2008, 02:58 PM
Points: 905, Level: 16 Points: 905, Level: 16 Points: 905, Level: 16
Level up: 5% Level up: 5% Level up: 5%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Oct 2007
Posts: 94
Quote:
Originally Posted by LuckyAx2
WK, I did use a spring compressor. The main concern I had while using it was that you could not place them opposite of each other. Using the compressor was the only way I could even get the spring out in the first place. (I think i remembered to pick one up thanks to your post! The compressor also helped make the fronts a piece of cake)

I think what it all comes down to is the position of the Jack. The instructions say to jack up the opposite side axle that you are working on. Well, the entire rear differential is connected to each other so you are having an opposing force holding the spring in place. Theoretically it makes sense, jack up the other axle forcing the opposite one down. Well it made the XK unstable on the jack and no play in moving the axle around. I think the only way to really do it is to jack up the frame and let the axle hang loose.

Where did you guys jack it up from?
I dont get it... I installed a RR 2.25 inch lift and the rear only took me 30 min a side. i jacked up the Jeep from the diff and put a jack stand on the opposite side of the one i was working on. Then i supported the side i was working on with one much lower. i took the shock off and i used the SCC to get the spring out. then i put the puck on the spring seat. i took a air ratchet and ran the spring down more while on the bench and put it back in. then i let the pressure off with a hand ratchet. I remember that the SCC would not got at opposite sides of the spring but i just spread them out as much as possible. I dont understand why it was so easy for me and so difficult for you. I wonder if the suspension specs are different between yours and mine. I have a 06 Limited with the 4.7 V8. I just cant figure out why they would not react the same. keep me posted on how it turns out. May you can post some pics... there must be something i am missing.
wkfore is offline  
post #7 of 13 (permalink) Old 01-07-2008, 05:04 PM
Senior Member
Points: 63,765, Level: 100 Points: 63,765, Level: 100 Points: 63,765, Level: 100
Level up: 0% Level up: 0% Level up: 0%
Activity: 0% Activity: 0% Activity: 0%
 
a49erFan's Avatar
 
Join Date: Jan 2007
Location: Sunny Arizona
Posts: 12,579
Send a message via Yahoo to a49erFan
Mine was quick and easy as well.





To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


2006 XK, Steel Armadillo Front Bumper w/Warn Powermate winch, Rear Bumper w/tire carrier & Super Sliders, Rhino Rack Roof Rack and Foxwing Awning, KC Lights on Steel Armadillo Light Bar, 4xGuard Rear Differential Cover, Steel Armadillo Plates.
a49erFan is offline  
post #8 of 13 (permalink) Old 01-07-2008, 05:07 PM
Points: 905, Level: 16 Points: 905, Level: 16 Points: 905, Level: 16
Level up: 5% Level up: 5% Level up: 5%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Oct 2007
Posts: 94
Quote:
Originally Posted by a49erFootballFan
Mine was quick and easy as well.
Yea.. i am still racking my brain on why it didnt go well. i even took a good long look under mine today to try and get an understanding. must be suspension specs... it has to be
wkfore is offline  
post #9 of 13 (permalink) Old 01-07-2008, 05:36 PM Thread Starter
Senior Member
Points: 5,363, Level: 47 Points: 5,363, Level: 47 Points: 5,363, Level: 47
Level up: 7% Level up: 7% Level up: 7%
Activity: 0% Activity: 0% Activity: 0%
 
BoilerCommander's Avatar
 
Join Date: Jul 2007
Location: Northern Indiana
Posts: 526
I think it is something with the jack location. Even with the upper control arm bolt removed it wanted to slide back into the axle attachment. I mean when the car is supported by the passenger side axle, it is pretty scary to push on the drivers side axle. We had jack stands on each side and a jack on the differential just in case. My dad lost sleep last night trying to figure it out too. I mean everything we needed to disconnect, was. I just hope I didnt damage the CV boots pushing down so hard on the wheel drum.

When you say
Quote:
i jacked up the Jeep from the diff and put a jack stand on the opposite side of the one i was working on. Then i supported the side i was working on with one much lower.
where did you put the jack stands?

Rocky Road's instructions said
Quote:
Loosen the lug nuts, jack the passenger’s side up until the tire comes off the ground on the driver’s side. Once the tire is off, unbolts the sway bar, remove the shock, and unbolt the upper control arm from the axle. If you do not unbolt the upper arm, it will sit on top of the fuel tank and hamper your efforts at spring removal. Once these items have been completed, and the driver’s side of the axle is free-hanging, you should be able to pop the spring out by hand.
My problem is that the axle was never free hanging

Last edited by BoilerCommander; 01-07-2008 at 05:40 PM.
BoilerCommander is offline  
post #10 of 13 (permalink) Old 01-07-2008, 10:43 PM
Points: 905, Level: 16 Points: 905, Level: 16 Points: 905, Level: 16
Level up: 5% Level up: 5% Level up: 5%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Oct 2007
Posts: 94
I dont remember specific location but it didnt make a difference. i just compressed the crap out of the spring with the SCC. it wasnt an issue. the spring came out. then i put it on the bench and got more compression out of it with an air ratchet. it all went back together with no issue. sorry you are having all these issues. I wish i could come by your place and help!!!
wkfore is offline  
Sponsored Links
Advertisement
 
Reply

  Jeep Commander Forums: Jeep Commander Forum > Jeep Commander Discussion > Suspension / Lifts

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jeep Commander Forums: Jeep Commander Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome