Many Jeeps, first commander! - Jeep Commander Forums: Jeep Commander Forum
New Member Section Drop in, say Hi and meet the community

 
LinkBack Thread Tools Display Modes
post #1 of 9 (permalink) Old 09-10-2017, 11:26 AM Thread Starter
Junior Member
Points: 102, Level: 2 Points: 102, Level: 2 Points: 102, Level: 2
Level up: 4% Level up: 4% Level up: 4%
Activity: 0% Activity: 0% Activity: 0%
 
JeepRad's Avatar
 
Join Date: Sep 2017
Location: Mesa, AZ
Own a Commander?: Yes
Model year: 2007
Trim Package: Limited
Power-Train: 5.7L V-8 Hemi
4WD
If 4WD - system: QT-II
Current Mileage: 94,500
Posts: 12
Many Jeeps, first commander!

Greetings all! Just purchased an 07 Commander Limited, 5.7L and very excited about it. I'm new to the Commander, but not new to Jeeps, starting with a CJ-7 Renegade in high school, followed by a ZJ, XJ, TJ, JK, and now the XK! I recently upgraded my 08 JKU engine to a 6.0L LS w/ 435hp/430 torque at the rear wheels. Definitely a lot more fun to drive!

Anyway, I picked up the 07 Commander for some mild mods and use as a secondary vehicle. I have a few issues to overcome, but overall it's a nice truck. I intend to do the 2" OME lift with new UCAs, and will be looking for some JK wheels and larger tires.

the XK is equipt with the boston acoustics system, although the head unit barely functions and will need to be replaced. It only does AM/FM, no SiriusXM/CD/Nav. I know there will be a number of differing opinions, but is it worth replacing with the mygig nav unit (for factory appearance) or should I just go aftermarket? (I like having the built in Nav and listen to Sirius XM most of the time).

Next question, regarding the climate control. the blower and selector dials work fine, however, the individual temp knobs are not working correctly. The only way for the AC to blow cold is with the setting on "LOW", if I turn the knob to any temp, warm air comes out (regardless of interior temp). Wondering if it's a switch issue, (interior) thermostat, or something more significant.

Thanks in advance!

Tim (Mesa, AZ)
JeepRad is offline  
Sponsored Links
Advertisement
 
post #2 of 9 (permalink) Old 09-10-2017, 12:43 PM
Super Moderator
Points: 23,998, Level: 94 Points: 23,998, Level: 94 Points: 23,998, Level: 94
Level up: 65% Level up: 65% Level up: 65%
Activity: 100% Activity: 100% Activity: 100%
 
Big Blue's Avatar
 
Join Date: Oct 2015
Location: East Coast of Florida; Proud to have served.
Own a Commander?: Yes
Model year: 2008
Trim Package: Sport
Power-Train: 4.7L V-8
4WD
If 4WD - system: QT-II
Current Mileage: 101,200
Posts: 5,499
Garage
Quote:
Originally Posted by JeepRad View Post
Greetings all! Just purchased an 07 Commander Limited, 5.7L and very excited about it. I'm new to the Commander, but not new to Jeeps, starting with a CJ-7 Renegade in high school, followed by a ZJ, XJ, TJ, JK, and now the XK! I recently upgraded my 08 JKU engine to a 6.0L LS w/ 435hp/430 torque at the rear wheels. Definitely a lot more fun to drive!

Anyway, I picked up the 07 Commander for some mild mods and use as a secondary vehicle. I have a few issues to overcome, but overall it's a nice truck. I intend to do the 2" OME lift with new UCAs, and will be looking for some JK wheels and larger tires.

the XK is equipt with the boston acoustics system, although the head unit barely functions and will need to be replaced. It only does AM/FM, no SiriusXM/CD/Nav. I know there will be a number of differing opinions, but is it worth replacing with the mygig nav unit (for factory appearance) or should I just go aftermarket? (I like having the built in Nav and listen to Sirius XM most of the time).

Next question, regarding the climate control. the blower and selector dials work fine, however, the individual temp knobs are not working correctly. The only way for the AC to blow cold is with the setting on "LOW", if I turn the knob to any temp, warm air comes out (regardless of interior temp). Wondering if it's a switch issue, (interior) thermostat, or something more significant.

Thanks in advance!

Tim (Mesa, AZ)
Welcome to the forum JeepRad;

I'm assuming your XK is a 4x4?

As far as replacing the MyGIG Radio;

I have replaced mine - but you can't get them new anymore - all the units Chrysler has are reconditioned;

In light of that, you may want to consider an after market head unit for more advanced features & better overall reliability;


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Last edited by Big Blue; 09-10-2017 at 05:44 PM.
Big Blue is offline  
post #3 of 9 (permalink) Old 09-10-2017, 02:34 PM Thread Starter
Junior Member
Points: 102, Level: 2 Points: 102, Level: 2 Points: 102, Level: 2
Level up: 4% Level up: 4% Level up: 4%
Activity: 0% Activity: 0% Activity: 0%
 
JeepRad's Avatar
 
Join Date: Sep 2017
Location: Mesa, AZ
Own a Commander?: Yes
Model year: 2007
Trim Package: Limited
Power-Train: 5.7L V-8 Hemi
4WD
If 4WD - system: QT-II
Current Mileage: 94,500
Posts: 12
Yep, 4x4 Commander. I was looking at the reconditioned factory head units, have people had decent luck with them? The BA sound system is fine for my needs. I've installed a number of aftermarket stereos over the years, the best have been Alpine. I have a Kenwood in my JKU, but I don't care for it, it takes forever the initiate and the Bluetooth is sketchy (sometimes it recognizes my iPod, other times it won't).

Any thoughts on the climate control issue? Thanks!
JeepRad is offline  
 
post #4 of 9 (permalink) Old 09-10-2017, 04:56 PM
Senior Member
Points: 32,999, Level: 100 Points: 32,999, Level: 100 Points: 32,999, Level: 100
Level up: 0% Level up: 0% Level up: 0%
Activity: 20% Activity: 20% Activity: 20%
 
rblapham's Avatar
 
Join Date: May 2009
Location: Cleveland TN
Own a Commander?: Yes
Model year: 2006
Trim Package: Limited
Power-Train: 5.7L V-8 Hemi
4WD
If 4WD - system: QD-II
Current Mileage: 103,000
Posts: 623
Garage
Quote:
Originally Posted by JeepRad View Post
Next question, regarding the climate control. the blower and selector dials work fine, however, the individual temp knobs are not working correctly. The only way for the AC to blow cold is with the setting on "LOW", if I turn the knob to any temp, warm air comes out (regardless of interior temp). Wondering if it's a switch issue, (interior) thermostat, or something more significant.

Thanks in advance!

Tim (Mesa, AZ)
On the separate climate controls for temperature, The settings must be set for full automatic, The right knob in "Automatic" and the left knob in "Auto - High or Low". It's screwy but was designed that way. Either knob not in automatic the temperature is unpredictable.
PS it's explained in the owners manual, if you don't have one they are free to download from Jeep/Chrysler.

06 Commander Limited Hemi - QDII,
Past -89 Comanche, 98 Grand Cherokee (2WD), 2000 Cherokee, 05 Grand Cherokee Limited 4.7
Had to replace the brakes - they opened more gas stations in town
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Last edited by rblapham; 09-10-2017 at 05:01 PM.
rblapham is offline  
post #5 of 9 (permalink) Old 09-10-2017, 07:01 PM Thread Starter
Junior Member
Points: 102, Level: 2 Points: 102, Level: 2 Points: 102, Level: 2
Level up: 4% Level up: 4% Level up: 4%
Activity: 0% Activity: 0% Activity: 0%
 
JeepRad's Avatar
 
Join Date: Sep 2017
Location: Mesa, AZ
Own a Commander?: Yes
Model year: 2007
Trim Package: Limited
Power-Train: 5.7L V-8 Hemi
4WD
If 4WD - system: QT-II
Current Mileage: 94,500
Posts: 12
rblapham, Thank you! I didn't have it set in "Automatic" just on "high" (it's around 103F here in Mesa). I will give your suggestion a try...
JeepRad is offline  
post #6 of 9 (permalink) Old 09-11-2017, 04:55 AM
Senior Member
Points: 32,999, Level: 100 Points: 32,999, Level: 100 Points: 32,999, Level: 100
Level up: 0% Level up: 0% Level up: 0%
Activity: 20% Activity: 20% Activity: 20%
 
rblapham's Avatar
 
Join Date: May 2009
Location: Cleveland TN
Own a Commander?: Yes
Model year: 2006
Trim Package: Limited
Power-Train: 5.7L V-8 Hemi
4WD
If 4WD - system: QD-II
Current Mileage: 103,000
Posts: 623
Garage
Another goofy Commander programming is the outside temperature display, See this thread
https://www.jeepcommander.com/forums/...explained.html

06 Commander Limited Hemi - QDII,
Past -89 Comanche, 98 Grand Cherokee (2WD), 2000 Cherokee, 05 Grand Cherokee Limited 4.7
Had to replace the brakes - they opened more gas stations in town
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
rblapham is offline  
post #7 of 9 (permalink) Old 09-11-2017, 06:27 PM Thread Starter
Junior Member
Points: 102, Level: 2 Points: 102, Level: 2 Points: 102, Level: 2
Level up: 4% Level up: 4% Level up: 4%
Activity: 0% Activity: 0% Activity: 0%
 
JeepRad's Avatar
 
Join Date: Sep 2017
Location: Mesa, AZ
Own a Commander?: Yes
Model year: 2007
Trim Package: Limited
Power-Train: 5.7L V-8 Hemi
4WD
If 4WD - system: QT-II
Current Mileage: 94,500
Posts: 12
Yep, I already read the thread on the outside temp sensor. Mine was stuck on 78 degrees the first day I drove it, since then it has been reading more accurately.
JeepRad is offline  
post #8 of 9 (permalink) Old 10-02-2017, 06:57 PM Thread Starter
Junior Member
Points: 102, Level: 2 Points: 102, Level: 2 Points: 102, Level: 2
Level up: 4% Level up: 4% Level up: 4%
Activity: 0% Activity: 0% Activity: 0%
 
JeepRad's Avatar
 
Join Date: Sep 2017
Location: Mesa, AZ
Own a Commander?: Yes
Model year: 2007
Trim Package: Limited
Power-Train: 5.7L V-8 Hemi
4WD
If 4WD - system: QT-II
Current Mileage: 94,500
Posts: 12
Well, the XK needed new shocks/struts/ball joints, so I went with the OME 2" lift with heavy duty springs and additional 3/8" spacers in the front. I also opted for the JBAoffroad upper control arms w/ ball joints. Love it! Here are before/after pics...





The wheels are 2016 Wrangler Sahara 18" on Bridgestone Dueler tires.
JeepRad is offline  
post #9 of 9 (permalink) Old 10-03-2017, 09:19 AM
Super Moderator
Points: 23,998, Level: 94 Points: 23,998, Level: 94 Points: 23,998, Level: 94
Level up: 65% Level up: 65% Level up: 65%
Activity: 100% Activity: 100% Activity: 100%
 
Big Blue's Avatar
 
Join Date: Oct 2015
Location: East Coast of Florida; Proud to have served.
Own a Commander?: Yes
Model year: 2008
Trim Package: Sport
Power-Train: 4.7L V-8
4WD
If 4WD - system: QT-II
Current Mileage: 101,200
Posts: 5,499
Garage
Quote:
Originally Posted by JeepRad View Post
Well, the XK needed new shocks/struts/ball joints, so I went with the OME 2" lift with heavy duty springs and additional 3/8" spacers in the front. I also opted for the JBAoffroad upper control arms w/ ball joints. Love it! Here are before/after pics...

The wheels are 2016 Wrangler Sahara 18" on Bridgestone Dueler tires.
That's nice work JeepRad; your XK is looking sharp.

Thanks for sharing the pics.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Big Blue is offline  
Sponsored Links
Advertisement
 
Reply

  Jeep Commander Forums: Jeep Commander Forum > Jeep Commander Discussion > New Member Section

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jeep Commander Forums: Jeep Commander Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome