New member with a possible cure: (Navigation intermittent blank sceen) - Jeep Commander Forums: Jeep Commander Forum
New Member Section Drop in, say Hi and meet the community

 3Likes
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 13 (permalink) Old 06-29-2018, 04:34 PM Thread Starter
Junior Member
Points: 30, Level: 1 Points: 30, Level: 1 Points: 30, Level: 1
Level up: 60% Level up: 60% Level up: 60%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Jun 2018
Location: Tucson Arizona
Own a Commander?: Yes
Model year: 2006
Trim Package: Limited
Power-Train: 5.7L V-8 Hemi
4WD
If 4WD - system: QT-II
Current Mileage: 126.000
Posts: 7
New member with a possible cure: (Navigation intermittent blank sceen)

Greetings everyone:


I'm a new member & owner of a 2006 Jeep Commander Limited/ 5.7 Hemi. Wanted to share a recent event I had this week.
For a few years my Navigation screen would go blank for awhile and then back to normal and then out again. None of the functions on the steering wheel would work but I still could change the modes when the screen popped in.


Fast forward to this week, My fuel pump went out and was replaced. Started the Jeep after the repairs and yes!! the screen was up & running so I quickly set it to satellite radio. Well it stayed on longer than usual, I tested the buttons on the steering wheel and damn they worked ! What happen ? Why is my navigation system screen and function all of a sudden working again? On a hunch I called the repair shop and simply asked if they fixed it for kicks?


Come to find out that while they were replacing the fuel pump a loose wire was noted, It was reconnected and tighten and that my friends fixed the on again off again Nav/ screen and all of the functions. That trip saved me hundreds on buying another complete system ! I haven't a clue as to which wire, But it's worth an investigation for those with the same issue I was having for years....Keep me posted if that cure works for you?

Last edited by Alsberryk; 06-29-2018 at 04:37 PM.
Alsberryk is offline  
Sponsored Links
Advertisement
 
post #2 of 13 (permalink) Old 06-29-2018, 05:01 PM
Super Moderator
Points: 59,244, Level: 100 Points: 59,244, Level: 100 Points: 59,244, Level: 100
Level up: 0% Level up: 0% Level up: 0%
Activity: 91% Activity: 91% Activity: 91%
 
jeep5253's Avatar
 
Join Date: Jun 2006
Own a Commander?: Yes
Model year: 2006
Trim Package: Limited
Power-Train: 5.7L V-8 Hemi
4WD
If 4WD - system: QD-II
Posts: 14,873
Quote:
Originally Posted by Alsberryk View Post
Greetings everyone:


I'm a new member & owner of a 2006 Jeep Commander Limited/ 5.7 Hemi. Wanted to share a recent event I had this week.
For a few years my Navigation screen would go blank for awhile and then back to normal and then out again. None of the functions on the steering wheel would work but I still could change the modes when the screen popped in.


Fast forward to this week, My fuel pump went out and was replaced. Started the Jeep after the repairs and yes!! the screen was up & running so I quickly set it to satellite radio. Well it stayed on longer than usual, I tested the buttons on the steering wheel and damn they worked ! What happen ? Why is my navigation system screen and function all of a sudden working again? On a hunch I called the repair shop and simply asked if they fixed it for kicks?


Come to find out that while they were replacing the fuel pump a loose wire was noted, It was reconnected and tighten and that my friends fixed the on again off again Nav/ screen and all of the functions. That trip saved me hundreds on buying another complete system ! I haven't a clue as to which wire, But it's worth an investigation for those with the same issue I was having for years....Keep me posted if that cure works for you?
This is pretty much useless without knowing which wire. Couldn't you ask them which one? And please read the sticky threads in the New Member Section and answer your User Profile Questions. Thanks.

2006 Steel Blue 5.7L HEMI Limited 4x4 Build Date: June 9, 2006 Hour 14
Interior: Dark Slate/Light Graystone with Saddle Brown Leather Seats
Quadra-Drive II, NAV, DVD, Trailer Tow Group IV, Off-Road Group II, Remote Start, UConnect, Rear Backup Camera, Chrome Wheels,
Magnaflow cat-back exhaust, Daytime Running Lights enabled, 2" Rough Country Lift with 265/70R17 Goodyear Wrangler AT/S
jeep5253 is offline  
post #3 of 13 (permalink) Old 06-29-2018, 06:37 PM Thread Starter
Junior Member
Points: 30, Level: 1 Points: 30, Level: 1 Points: 30, Level: 1
Level up: 60% Level up: 60% Level up: 60%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Jun 2018
Location: Tucson Arizona
Own a Commander?: Yes
Model year: 2006
Trim Package: Limited
Power-Train: 5.7L V-8 Hemi
4WD
If 4WD - system: QT-II
Current Mileage: 126.000
Posts: 7
Useless? I'm not a mechanic so not knowing the wire isn't a surprise ( I was hoping someone with that kind of knowledge might have an idea or clue as to the what the possibilities are, Obviously you added nothing to this post) It worked so calling the information " Useless" is an over statement. I'll call next week to check on that information and head to the ( NMS) To fill out the profile questions
Alsberryk is offline  
 
post #4 of 13 (permalink) Old 06-29-2018, 06:42 PM
Super Moderator
Points: 59,244, Level: 100 Points: 59,244, Level: 100 Points: 59,244, Level: 100
Level up: 0% Level up: 0% Level up: 0%
Activity: 91% Activity: 91% Activity: 91%
 
jeep5253's Avatar
 
Join Date: Jun 2006
Own a Commander?: Yes
Model year: 2006
Trim Package: Limited
Power-Train: 5.7L V-8 Hemi
4WD
If 4WD - system: QD-II
Posts: 14,873
Quote:
Originally Posted by Alsberryk View Post
Useless? I'm not a mechanic so not knowing the wire isn't a surprise ( I was hoping someone with that kind of knowledge might have an idea or clue as to the what the possibilities are, Obviously you added nothing to this post) It worked so calling the information " Useless" is an over statement. I'll call next week to check on that information and head to the ( NMS) To fill out the profile questions
Yes, it's useless. All you told us was they fixed a loose wire. There are hundreds of wires on a Commander. Without knowing which one it would you would have to check every wire, and that is a daunting task not worth starting.

2006 Steel Blue 5.7L HEMI Limited 4x4 Build Date: June 9, 2006 Hour 14
Interior: Dark Slate/Light Graystone with Saddle Brown Leather Seats
Quadra-Drive II, NAV, DVD, Trailer Tow Group IV, Off-Road Group II, Remote Start, UConnect, Rear Backup Camera, Chrome Wheels,
Magnaflow cat-back exhaust, Daytime Running Lights enabled, 2" Rough Country Lift with 265/70R17 Goodyear Wrangler AT/S

Last edited by jeep5253; 06-30-2018 at 12:37 PM. Reason: spelling
jeep5253 is offline  
post #5 of 13 (permalink) Old 06-29-2018, 06:56 PM Thread Starter
Junior Member
Points: 30, Level: 1 Points: 30, Level: 1 Points: 30, Level: 1
Level up: 60% Level up: 60% Level up: 60%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Jun 2018
Location: Tucson Arizona
Own a Commander?: Yes
Model year: 2006
Trim Package: Limited
Power-Train: 5.7L V-8 Hemi
4WD
If 4WD - system: QT-II
Current Mileage: 126.000
Posts: 7
Quote:
Originally Posted by jeep5253 View Post
Yes, it's useless. All you told us was they fixes a loose wire. There are hundreds of wires on a Commander. Without knowing which one it would you would have to check every wire, and that is a daunting task not worth starting.


I completely understand ! It was none the less a pleasant outcome, I'll call on Monday to see if I can nail it down for the group.
jeep5253 likes this.
Alsberryk is offline  
post #6 of 13 (permalink) Old 06-29-2018, 08:25 PM
Super Moderator
Points: 59,244, Level: 100 Points: 59,244, Level: 100 Points: 59,244, Level: 100
Level up: 0% Level up: 0% Level up: 0%
Activity: 91% Activity: 91% Activity: 91%
 
jeep5253's Avatar
 
Join Date: Jun 2006
Own a Commander?: Yes
Model year: 2006
Trim Package: Limited
Power-Train: 5.7L V-8 Hemi
4WD
If 4WD - system: QD-II
Posts: 14,873
Quote:
Originally Posted by Alsberryk View Post
I completely understand ! It was none the less a pleasant outcome, I'll call on Monday to see if I can nail it down for the group.
Thank you.

2006 Steel Blue 5.7L HEMI Limited 4x4 Build Date: June 9, 2006 Hour 14
Interior: Dark Slate/Light Graystone with Saddle Brown Leather Seats
Quadra-Drive II, NAV, DVD, Trailer Tow Group IV, Off-Road Group II, Remote Start, UConnect, Rear Backup Camera, Chrome Wheels,
Magnaflow cat-back exhaust, Daytime Running Lights enabled, 2" Rough Country Lift with 265/70R17 Goodyear Wrangler AT/S
jeep5253 is offline  
post #7 of 13 (permalink) Old 06-29-2018, 09:35 PM
Senior Member
Points: 4,256, Level: 41 Points: 4,256, Level: 41 Points: 4,256, Level: 41
Level up: 53% Level up: 53% Level up: 53%
Activity: 4% Activity: 4% Activity: 4%
 
Join Date: Mar 2015
Location: Monterey California
Own a Commander?: Yes
Model year: 2006
Trim Package: Limited
Power-Train: 5.7L V-8 Hemi
4WD
If 4WD - system: QD-II
Current Mileage: 124000
Posts: 187
It was probably a ground wire.
bdalameda is offline  
post #8 of 13 (permalink) Old 06-30-2018, 12:03 PM
Super Moderator
Points: 23,200, Level: 93 Points: 23,200, Level: 93 Points: 23,200, Level: 93
Level up: 85% Level up: 85% Level up: 85%
Activity: 100% Activity: 100% Activity: 100%
 
Big Blue's Avatar
 
Join Date: Oct 2015
Location: East Coast of Florida
Own a Commander?: Yes
Model year: 2008
Trim Package: Sport
Power-Train: 4.7L V-8
4WD
If 4WD - system: QT-II
Current Mileage: 101,200
Posts: 5,310
Garage
Quote:
Originally Posted by Alsberryk View Post
Greetings everyone:


I'm a new member & owner of a 2006 Jeep Commander Limited/ 5.7 Hemi. Wanted to share a recent event I had this week.
For a few years my Navigation screen would go blank for awhile and then back to normal and then out again. None of the functions on the steering wheel would work but I still could change the modes when the screen popped in.


Fast forward to this week, My fuel pump went out and was replaced. Started the Jeep after the repairs and yes!! the screen was up & running so I quickly set it to satellite radio. Well it stayed on longer than usual, I tested the buttons on the steering wheel and damn they worked ! What happen ? Why is my navigation system screen and function all of a sudden working again? On a hunch I called the repair shop and simply asked if they fixed it for kicks?


Come to find out that while they were replacing the fuel pump a loose wire was noted, It was reconnected and tighten and that my friends fixed the on again off again Nav/ screen and all of the functions. That trip saved me hundreds on buying another complete system ! I haven't a clue as to which wire, But it's worth an investigation for those with the same issue I was having for years....Keep me posted if that cure works for you?
@Alsberryk ;

Welcome to the forum; Post some pics of your Commander when you can.

Here are some links to help you out if you want to do upgrades or repairs to your XK;

Chrysler/Jeep Factory Parts: http://www.factorychryslerparts.com/...ukey_make=1064

Cheapest factory Parts: Find OEM BMW, Fiat, Ford, GM, Mopar, Nissan, Subaru & Toyota Parts & Accessories

JeepinByAl: JBAoffroad.com

JustforJeeps.com - http://www.justforjeeps.com/?gclid=C...9i0hoCSS7w_wcB

Rough County lift kits - Suspension Lift Kits, Body Lifts, Leveling Kit, 4x4, Jeep, Chevy, Dodge, Ford, Off-road Truck | Rough Country Suspension SystemsŪ

AFE: Advanced FLOW Engineering | Engineered Adrenaline

CARiD.com - http://www.carid.com/?gclid=CjwKEAjw...NrrxoCEBbw_wcB

Bilstein shocks & struts - Home

The Steel Armadillo - Jeep Commander (XK/HK) 2006-2010

WAM Custom Bumpers - https://wambumpers.com/

4WheelParts.com - Truck Parts & Jeep Parts - Lift Kits, Winches, Tonneau Covers, Tires, Wheels, Bumpers, Performance ? 4 Wheel Parts

RockAuto - http://www.rockauto.com/en/catalog/j...catalog%2Fjeep

Also, please read this if you haven't done so already - lots of good information in here;

REQUIRED READING!!! New Member Introduction post & other important new member info.

Thanks and again, welcome aboard.
Alsberryk likes this.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Big Blue is offline  
post #9 of 13 (permalink) Old 07-01-2018, 11:32 AM Thread Starter
Junior Member
Points: 30, Level: 1 Points: 30, Level: 1 Points: 30, Level: 1
Level up: 60% Level up: 60% Level up: 60%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Jun 2018
Location: Tucson Arizona
Own a Commander?: Yes
Model year: 2006
Trim Package: Limited
Power-Train: 5.7L V-8 Hemi
4WD
If 4WD - system: QT-II
Current Mileage: 126.000
Posts: 7
Unhappy Navagtion system 2006 Jeep Commander Limited

Well I guess it wasn't a fix completely, Came home to a blank screen BUT the steering wheel controls continue to work and the satellite radio stays put unlike before on startup. Maybe disconnection from the battery reset it temporally?
I guess my search is back on for a OEM head unit without breaking the wallet, I want to keep it all original
Alsberryk is offline  
post #10 of 13 (permalink) Old 07-01-2018, 11:42 AM
Super Moderator
Points: 23,200, Level: 93 Points: 23,200, Level: 93 Points: 23,200, Level: 93
Level up: 85% Level up: 85% Level up: 85%
Activity: 100% Activity: 100% Activity: 100%
 
Big Blue's Avatar
 
Join Date: Oct 2015
Location: East Coast of Florida
Own a Commander?: Yes
Model year: 2008
Trim Package: Sport
Power-Train: 4.7L V-8
4WD
If 4WD - system: QT-II
Current Mileage: 101,200
Posts: 5,310
Garage
Quote:
Originally Posted by Alsberryk View Post
Well I guess it wasn't a fix completely, Came home to a blank screen BUT the steering wheel controls continue to work and the satellite radio stays put unlike before on startup. Maybe disconnection from the battery reset it temporally?
I guess my search is back on for a OEM head unit without breaking the wallet, I want to keep it all original
Definitely sounds like you need to replace your head unit;

Unfortunately the factory head units have proven not to be very reliable. I've had two reconditioned head units installed by FCA in the 4 years I've had my XK - because that's all you can buy anymore and experience has taught me that they do not last, particularly if you live in a hot climate.

That's why I ultimately wound up getting a new Pioneer AVH-X490BS CD/DVD RDS AV head unit with Sirius XM Receiver.

You can't beat the reliability of a new head unit - that is actually new, plus I have Blue Tooth now, which I didn't have before.
Alsberryk likes this.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Big Blue is offline  
Sponsored Links
Advertisement
 
Reply

  Jeep Commander Forums: Jeep Commander Forum > Jeep Commander Discussion > New Member Section

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jeep Commander Forums: Jeep Commander Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome