Tezza - Jeep Commander Forums: Jeep Commander Forum
New Member Section Drop in, say Hi and meet the community

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 12-03-2018, 07:54 PM Thread Starter
Junior Member
Points: 4, Level: 1 Points: 4, Level: 1 Points: 4, Level: 1
Level up: 7% Level up: 7% Level up: 7%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Dec 2018
Own a Commander?: Yes
Model year: 2009
Trim Package: Sport
4WD
If 4WD - system: QT-I
Posts: 1
Tezza

Hi All �� I’m a newbee & have a question .. When I check the oil on my commander just after it’s been driven there is no oil on the stick but if I reinsert the stick & remove again it shows the oil level .. Is this normal ?
Islandcommander is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 12-03-2018, 09:04 PM
Junior Member
Points: 120, Level: 2 Points: 120, Level: 2 Points: 120, Level: 2
Level up: 40% Level up: 40% Level up: 40%
Activity: 0% Activity: 0% Activity: 0%
 
BigRed07's Avatar
 
Join Date: Nov 2018
Location: SC
Own a Commander?: Yes
Model year: 2006
Trim Package: Overland
Power-Train: 5.7L V-8 Hemi
4WD
If 4WD - system: QD-II
Current Mileage: 185000
Posts: 6
Garage
Same question here.
BigRed07 is offline  
post #3 of 5 (permalink) Old 12-03-2018, 09:16 PM
Super Moderator
Points: 23,378, Level: 94 Points: 23,378, Level: 94 Points: 23,378, Level: 94
Level up: 3% Level up: 3% Level up: 3%
Activity: 100% Activity: 100% Activity: 100%
 
Big Blue's Avatar
 
Join Date: Oct 2015
Location: East Coast of Florida
Own a Commander?: Yes
Model year: 2008
Trim Package: Sport
Power-Train: 4.7L V-8
4WD
If 4WD - system: QT-II
Current Mileage: 101,200
Posts: 5,328
Garage
Quote:
Originally Posted by Islandcommander View Post
Hi All �� I’m a newbee & have a question .. When I check the oil on my commander just after it’s been driven there is no oil on the stick but if I reinsert the stick & remove again it shows the oil level .. Is this normal ?
I can't recall having that issue, but, when in doubt, take a ride to the Jeep dealership and ask them - asking questions doesn't cost you anything but a little bit of your time.

Also @Islandcommander please complete your user profile by indicating what power-train you have in your XK....thanks.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Big Blue is offline  
 
post #4 of 5 (permalink) Old 12-03-2018, 10:01 PM
GTF
Member
Points: 1,450, Level: 21 Points: 1,450, Level: 21 Points: 1,450, Level: 21
Level up: 50% Level up: 50% Level up: 50%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Apr 2018
Own a Commander?: Yes
Model year: 2006
Trim Package: Limited
Power-Train: 5.7L V-8 Hemi
4WD
If 4WD - system: QD-II
Posts: 85
Quote:
Originally Posted by Islandcommander View Post
Hi All �� Iím a newbee & have a question .. When I check the oil on my commander just after itís been driven there is no oil on the stick but if I reinsert the stick & remove again it shows the oil level .. Is this normal ?
I think it's normal. The oil coats the stick so you can't see a defined line between dry and oil coated. IMHO, the dipstick on the Hemi is too long and curved, and is difficult to read under the best of circumstances. To get a proper reading, you need to remove and clean the dipstick with a rag before reinserting & removing again to actually check the oil.

Now, if you do this and you STILL aren't seeing any oil, you probably need to add a quart... at least.
GTF is offline  
post #5 of 5 (permalink) Old 12-04-2018, 09:03 AM
Senior Member
Points: 5,085, Level: 45 Points: 5,085, Level: 45 Points: 5,085, Level: 45
Level up: 68% Level up: 68% Level up: 68%
Activity: 4% Activity: 4% Activity: 4%
 
Join Date: Jun 2014
Location: Houston ,Texas
Own a Commander?: Yes
Model year: 2006
Trim Package: Limited
Power-Train: 4.7L V-8
2WD
If 4WD - system: QT-I
Current Mileage: 253,000
Posts: 132
Quote:
Originally Posted by Islandcommander View Post
Hi All �� Iím a newbee & have a question .. When I check the oil on my commander just after itís been driven there is no oil on the stick but if I reinsert the stick & remove again it shows the oil level .. Is this normal ?
Three things come to mind. Either you're not checking your oil on a level surface. Meaning the car needs to be parked on level ground. Or your engine could be sludged up. Or some of the ports are clogged that allow the oil drain back to the pan,in a reasonable time. Which is not good.
Or third, maybe you're just low on oil.
As soon as you turn your car off, all the oil should be back in the pan in a matter of a few seconds , with hot oil.
If you check it cold in the morning, on level ground that's going to be an accurate measurement also. And if you check it hot, after the engine gets turned off. In a matter of seconds and there's still no oil on the dipstick, you may have a sludge issue.
Make sure you wipe your dipstick with a clean rag before you insert it and then check it again.
Good luck. Let us know what you figure out.

Sent from my Samsung Galaxy, using speech to text
Spraygun is offline  
Sponsored Links
Advertisement
 
Reply

  Jeep Commander Forums: Jeep Commander Forum > Jeep Commander Discussion > New Member Section

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jeep Commander Forums: Jeep Commander Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome