Love My 2006 XK Hemi - Jeep Commander Forums: Jeep Commander Forum
New Member Section Drop in, say Hi and meet the community

 1Likes
  • 1 Post By Big Blue
 
LinkBack Thread Tools Display Modes
post #1 of 10 (permalink) Old 01-12-2019, 02:54 PM Thread Starter
Junior Member
Points: 416, Level: 8 Points: 416, Level: 8 Points: 416, Level: 8
Level up: 32% Level up: 32% Level up: 32%
Activity: 0% Activity: 0% Activity: 0%
 
rewdboy's Avatar
 
Join Date: Aug 2018
Location: CALI
Own a Commander?: Yes
Model year: 2006
Trim Package: Limited
Power-Train: 5.7L V-8 Hemi
4WD
If 4WD - system: QT-II
Current Mileage: 119600
Posts: 4
Garage
Love My 2006 XK Hemi

Been a member of this forum since last year - Thanks for all the advice and information!

I'm searching for any previous posts regarding issues encountered during install of a bug deflector - Wanted to create a new post, but I think I have to complete this step first -

I'm having issues installing a "simple" AVS bug deflector on the hood - once deflector is installed, hood will not close securely -
I have made several adjustments, only to end up with the same results -

any of you fellow jeepers have advice on how to remedy this issue?

Thanks in advance!

Last edited by rewdboy; 01-12-2019 at 03:07 PM.
rewdboy is offline  
Sponsored Links
Advertisement
 
post #2 of 10 (permalink) Old 01-12-2019, 08:11 PM
Senior Member
Points: 6,596, Level: 53 Points: 6,596, Level: 53 Points: 6,596, Level: 53
Level up: 23% Level up: 23% Level up: 23%
Activity: 22% Activity: 22% Activity: 22%
 
consumedbywater's Avatar
 
Join Date: Jun 2013
Location: California
Own a Commander?: Yes
Model year: 2006
Trim Package: Limited
Power-Train: 5.7L V-8 Hemi
4WD
If 4WD - system: QD-II
Current Mileage: 175,000
Posts: 473
Garage
Have you tried adjusting the hood stops? They're the hexagonal pieces sticking up on either side of the radiator support bar, and you can unscrew them or screw them in to raise or lower the hood's resting position. Maybe you can adjust them to get the hood correctly positioned.

2006 XK Limited, Hemi, QDII
245/70R17 General Grabber AT2s
Ported/Polished Throttle Body
Flowmaster Super 44
Stock Height Again (For Now)
consumedbywater is offline  
post #3 of 10 (permalink) Old 01-14-2019, 12:53 PM Thread Starter
Junior Member
Points: 416, Level: 8 Points: 416, Level: 8 Points: 416, Level: 8
Level up: 32% Level up: 32% Level up: 32%
Activity: 0% Activity: 0% Activity: 0%
 
rewdboy's Avatar
 
Join Date: Aug 2018
Location: CALI
Own a Commander?: Yes
Model year: 2006
Trim Package: Limited
Power-Train: 5.7L V-8 Hemi
4WD
If 4WD - system: QT-II
Current Mileage: 119600
Posts: 4
Garage
awesome! thanks for the advice, I will try that today and report back!
Love this forum!

Our chariot to adventure - GINASJP -

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
rewdboy is offline  
 
post #4 of 10 (permalink) Old 01-15-2019, 06:49 PM
Member
Points: 5,463, Level: 47 Points: 5,463, Level: 47 Points: 5,463, Level: 47
Level up: 57% Level up: 57% Level up: 57%
Activity: 0% Activity: 0% Activity: 0%
 
BenSmith's Avatar
 
Join Date: Sep 2013
Location: Shreveport, LA
Own a Commander?: Yes
Model year: 2006
Trim Package: Limited
Power-Train: 5.7L V-8 Hemi
4WD
If 4WD - system: QD-II
Current Mileage: 120,000
Posts: 76
I love my 2006 XK Hemi too! Even after a catastrophic engine failure, a ridiculous recall that stole my 4wd low, lifter issues, and lots of minor headaches.
Attached Thumbnails
Click image for larger version

Name:	20ACCB49-87B8-4340-A3E4-28C9913B6446_1547599739153.jpg
Views:	40
Size:	319.0 KB
ID:	33571  

Mine: '06 XK Limited Hemi, QD II, RC Lift, Moog UCAs, F-150 rear shocks, CB, Brake Controller, Reman from Pro-Engines

Hers: '19 Honda Odyssey EX-L (3 kids)
BenSmith is offline  
post #5 of 10 (permalink) Old 01-17-2019, 12:51 PM Thread Starter
Junior Member
Points: 416, Level: 8 Points: 416, Level: 8 Points: 416, Level: 8
Level up: 32% Level up: 32% Level up: 32%
Activity: 0% Activity: 0% Activity: 0%
 
rewdboy's Avatar
 
Join Date: Aug 2018
Location: CALI
Own a Commander?: Yes
Model year: 2006
Trim Package: Limited
Power-Train: 5.7L V-8 Hemi
4WD
If 4WD - system: QT-II
Current Mileage: 119600
Posts: 4
Garage
yowza! sounds painful! what led to the engine failure and what was the recall?

Our chariot to adventure - GINASJP -

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
rewdboy is offline  
post #6 of 10 (permalink) Old 01-18-2019, 02:00 PM
Junior Member
Points: 1,162, Level: 18 Points: 1,162, Level: 18 Points: 1,162, Level: 18
Level up: 62% Level up: 62% Level up: 62%
Activity: 0% Activity: 0% Activity: 0%
 
HyperionAlpha's Avatar
 
Join Date: Oct 2017
Location: Miami
Own a Commander?: Yes
Model year: 2008
Trim Package: Limited
Power-Train: 4.7L V-8
4WD
If 4WD - system: QT-II
Current Mileage: 119,321
Posts: 6
If it's what I'm guessing, the 2006-2010 line had valve issues. The seats would break and fall into the chamber, highly likely that the kind of catastrophic failure this would cause could damage the intake manifold when metal flies upwards into it, leaving it to be replaced as well. Mine made it to 108k before this failure, most of them start to break from this at around 75-85k. Mine lasted til 108k, then it was time for a reman. I'm looking to keep it for another ten years at least.
HyperionAlpha is offline  
post #7 of 10 (permalink) Old 01-20-2019, 07:02 PM
Super Moderator
Points: 20,960, Level: 91 Points: 20,960, Level: 91 Points: 20,960, Level: 91
Level up: 22% Level up: 22% Level up: 22%
Activity: 100% Activity: 100% Activity: 100%
 
Big Blue's Avatar
 
Join Date: Oct 2015
Location: East Coast of Florida
Own a Commander?: Yes
Model year: 2008
Trim Package: Sport
Power-Train: 4.7L V-8
4WD
If 4WD - system: QT-II
Current Mileage: 102,100
Posts: 5,075
Garage
Quote:
Originally Posted by rewdboy View Post
Been a member of this forum since last year - Thanks for all the advice and information!

I'm searching for any previous posts regarding issues encountered during install of a bug deflector - Wanted to create a new post, but I think I have to complete this step first -

I'm having issues installing a "simple" AVS bug deflector on the hood - once deflector is installed, hood will not close securely -
I have made several adjustments, only to end up with the same results -

any of you fellow jeepers have advice on how to remedy this issue?

Thanks in advance!
Remove your bug deflector; Problem solved.
Wombler likes this.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Big Blue is offline  
post #8 of 10 (permalink) Old 01-21-2019, 11:08 AM
Senior Member
Points: 2,916, Level: 33 Points: 2,916, Level: 33 Points: 2,916, Level: 33
Level up: 11% Level up: 11% Level up: 11%
Activity: 50% Activity: 50% Activity: 50%
 
drm4633's Avatar
 
Join Date: Oct 2017
Location: Middle TN
Own a Commander?: Yes
Model year: 2007
Trim Package: Limited
Power-Train: 5.7L V-8 Hemi
4WD
If 4WD - system: QD-II
Current Mileage: 130k
Posts: 291
Quote:
Originally Posted by consumedbywater View Post
Have you tried adjusting the hood stops? They're the hexagonal pieces sticking up on either side of the radiator support bar, and you can unscrew them or screw them in to raise or lower the hood's resting position. Maybe you can adjust them to get the hood correctly positioned.

wonder if he's coming back?
drm4633 is offline  
post #9 of 10 (permalink) Old 01-21-2019, 03:04 PM
Super Moderator
Points: 20,960, Level: 91 Points: 20,960, Level: 91 Points: 20,960, Level: 91
Level up: 22% Level up: 22% Level up: 22%
Activity: 100% Activity: 100% Activity: 100%
 
Big Blue's Avatar
 
Join Date: Oct 2015
Location: East Coast of Florida
Own a Commander?: Yes
Model year: 2008
Trim Package: Sport
Power-Train: 4.7L V-8
4WD
If 4WD - system: QT-II
Current Mileage: 102,100
Posts: 5,075
Garage
Quote:
Originally Posted by drm4633 View Post
wonder if he's coming back?
FYI - @rewdboy has been back on the forum since cbw's reply on the 12th; He has posted in this very thread on the 14th & the 17th; he just has not responded to @consumedbywater's reply for whatever reason.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Last edited by Big Blue; 01-21-2019 at 03:10 PM.
Big Blue is offline  
post #10 of 10 (permalink) Old 02-12-2019, 07:53 PM Thread Starter
Junior Member
Points: 416, Level: 8 Points: 416, Level: 8 Points: 416, Level: 8
Level up: 32% Level up: 32% Level up: 32%
Activity: 0% Activity: 0% Activity: 0%
 
rewdboy's Avatar
 
Join Date: Aug 2018
Location: CALI
Own a Commander?: Yes
Model year: 2006
Trim Package: Limited
Power-Train: 5.7L V-8 Hemi
4WD
If 4WD - system: QT-II
Current Mileage: 119600
Posts: 4
Garage
Quote:
Originally Posted by Big Blue View Post
FYI - @rewdboy has been back on the forum since cbw's reply on the 12th; He has posted in this very thread on the 14th & the 17th; he just has not responded to @consumedbywater's reply for whatever reason.
I'm back - didn't have an opportunity to adjust the hood settings until the other day - this simple adjustment did the trick, just a few twists to lower the hood stops on each side was all that was needed - thanks @consumedbywater !
@BigBlue : didn't bother with your suggestion since this would totally invalidate the purpose of purchasing the bug deflector -

Love this forum!

Our chariot to adventure - GINASJP -

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
rewdboy is offline  
Sponsored Links
Advertisement
 
Reply

  Jeep Commander Forums: Jeep Commander Forum > Jeep Commander Discussion > New Member Section

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jeep Commander Forums: Jeep Commander Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome