new BFG KO2s installed, trans over temp - Jeep Commander Forums: Jeep Commander Forum
New Member Section Drop in, say Hi and meet the community

 1Likes
  • 1 Post By g_ster
 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 05-04-2019, 09:20 PM Thread Starter
Junior Member
Points: 741, Level: 14 Points: 741, Level: 14 Points: 741, Level: 14
Level up: 41% Level up: 41% Level up: 41%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: May 2018
Location: Texas
Own a Commander?: Yes
Model year: 2006
Trim Package: Limited
Power-Train: 5.7L V-8 Hemi
4WD
If 4WD - system: QT-II
Current Mileage: 113080
Posts: 2
Send a message via AIM to bryankodiak Send a message via MSN to bryankodiak Send a message via Yahoo to bryankodiak
new BFG KO2s installed, trans over temp

anyone currently wearing these tires on their commander? opinions?

just put them on and for the first time ever, I am getting the TRANS TEMPERATURE OVER LIMIT message everytime i come to a stop. The old tires wrere nearly bald, these KO2s have 14/32 of tread, but same size tires (245,65,17) fluid level is , recently checked
but havent done filter change yet, (P.O "forgot" when he last changed it) so going to do that next paycheck
bryankodiak is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 05-05-2019, 05:59 AM
Senior Member
Points: 3,435, Level: 36 Points: 3,435, Level: 36 Points: 3,435, Level: 36
Level up: 57% Level up: 57% Level up: 57%
Activity: 5% Activity: 5% Activity: 5%
 
Join Date: Dec 2015
Location: Michigan
Own a Commander?: Yes
Model year: 2008
Trim Package: Limited
Power-Train: 5.7L V-8 Hemi
4WD
If 4WD - system: QD-II
Current Mileage: 130000
Posts: 132
You'll need two filters when you go to change the trans fluid. Wix makes a kit with a gasket. I've read on this forum that you should stick with OEM trans filters. I went with OEM the 1st time but have a Wix kit for the next. Maybe someone who has experience with the Wix will chime in here.
quickster2 is offline  
post #3 of 5 (permalink) Old 05-07-2019, 07:05 AM
Junior Member
Points: 32, Level: 1 Points: 32, Level: 1 Points: 32, Level: 1
Level up: 64% Level up: 64% Level up: 64%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Jan 2019
Location: Sunshine State
Own a Commander?: Yes
Model year: 2006
Trim Package: Limited
Power-Train: 5.7L V-8 Hemi
2WD
Current Mileage: 125K
Posts: 14
Food for thought:

Bought my 2006 in October 2018, 1 month later wife driving it and said it was doing se same thing. Had not changed anything with tires/etc. All stock Commander.

1/2 month later, it locked up. Motor gone. Transmission over heat was only indicator of issues. Turns out, slight leaking of water pump, air in system meant engine temp never registered even though it was baking.

Double check cooling system just to be sure. Would hate for someone to have to go through what I did. Just a thought....
Big Blue likes this.
g_ster is offline  
 
post #4 of 5 (permalink) Old 05-07-2019, 10:16 PM
Senior Member
Points: 2,916, Level: 33 Points: 2,916, Level: 33 Points: 2,916, Level: 33
Level up: 11% Level up: 11% Level up: 11%
Activity: 50% Activity: 50% Activity: 50%
 
drm4633's Avatar
 
Join Date: Oct 2017
Location: Middle TN
Own a Commander?: Yes
Model year: 2007
Trim Package: Limited
Power-Train: 5.7L V-8 Hemi
4WD
If 4WD - system: QD-II
Current Mileage: 130k
Posts: 291
the word is that aftermarket return line spin on filters do not have check valves and allow fluid to drain causing a delayed shift after startup. you can easily monitor trans temp using torque app on your phone and a cheap bluetooth obdii adapter...
I have a set of mopar filters waiting to be installed soon. i did the wix filters 30k ago and have noticed some delayed shifts and downshift clunks lately.
drm4633 is offline  
post #5 of 5 (permalink) Old 05-08-2019, 04:56 AM
Senior Member
Points: 3,435, Level: 36 Points: 3,435, Level: 36 Points: 3,435, Level: 36
Level up: 57% Level up: 57% Level up: 57%
Activity: 5% Activity: 5% Activity: 5%
 
Join Date: Dec 2015
Location: Michigan
Own a Commander?: Yes
Model year: 2008
Trim Package: Limited
Power-Train: 5.7L V-8 Hemi
4WD
If 4WD - system: QD-II
Current Mileage: 130000
Posts: 132
Good to know on the Wix. Will sell them in a garage sale or on E-bay. Stick with OEM. Thx
quickster2 is offline  
Sponsored Links
Advertisement
 
Reply

  Jeep Commander Forums: Jeep Commander Forum > Jeep Commander Discussion > New Member Section

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jeep Commander Forums: Jeep Commander Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
"Transmission Over Temp" = DOA?! JacFlash Problems / Dealer Service 47 05-26-2015 07:30 AM
adding a trans temp gauge stevehendo34 General Commander Discussion 9 09-19-2014 07:30 AM
Should 'trans over temp' show momentarily at start up?" chrali Problems / Dealer Service 5 11-24-2012 01:56 PM
Trans Temp NaNIs23 Regular Service / Maintenance 3 07-28-2011 12:15 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome