Low Beams - Jeep Commander Forums: Jeep Commander Forum
New Member Section Drop in, say Hi and meet the community

 2Likes
  • 1 Post By rlb62
  • 1 Post By dar124
 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 10-04-2019, 07:43 PM Thread Starter
Junior Member
Points: 343, Level: 6 Points: 343, Level: 6 Points: 343, Level: 6
Level up: 86% Level up: 86% Level up: 86%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Apr 2019
Own a Commander?: Yes
Model year: 2010
Trim Package: Sport
Power-Train: 3.7L V-6
4WD
If 4WD - system: QT-I
Current Mileage: 118000
Posts: 5
Low Beams

Hi all. My low beams won't turn on. All other lights work, including high beams, and fog lights. Could this be a fuse?



Thanks
rlb62 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 10-04-2019, 08:52 PM
Super Moderator
Points: 24,590, Level: 95 Points: 24,590, Level: 95 Points: 24,590, Level: 95
Level up: 24% Level up: 24% Level up: 24%
Activity: 100% Activity: 100% Activity: 100%
 
Big Blue's Avatar
 
Join Date: Oct 2015
Location: East Coast of Florida; Proud to have served.
Own a Commander?: Yes
Model year: 2008
Trim Package: Sport
Power-Train: 4.7L V-8
4WD
If 4WD - system: QT-II
Current Mileage: 101,200
Posts: 5,641
Garage
Quote:
Originally Posted by rlb62 View Post
Hi all. My low beams won't turn on. All other lights work, including high beams, and fog lights. Could this be a fuse?

Thanks
@rlb62;

Just spit-balling here but as I see it, it could be one of three things;

1) A bad fuse as you have stated;

2) The switch for your low beams has gone bad or;

3) Both of your low beam halogen bulbs have burnt out.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Last edited by Big Blue; 10-04-2019 at 08:56 PM.
Big Blue is online now  
post #3 of 4 (permalink) Old 10-04-2019, 09:21 PM Thread Starter
Junior Member
Points: 343, Level: 6 Points: 343, Level: 6 Points: 343, Level: 6
Level up: 86% Level up: 86% Level up: 86%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Apr 2019
Own a Commander?: Yes
Model year: 2010
Trim Package: Sport
Power-Train: 3.7L V-6
4WD
If 4WD - system: QT-I
Current Mileage: 118000
Posts: 5
Thanks for your reply. I know it's not the bulbs. Will check the fuse.
Big Blue likes this.
rlb62 is offline  
 
post #4 of 4 (permalink) Old 10-05-2019, 09:11 AM
Member
Points: 249, Level: 4 Points: 249, Level: 4 Points: 249, Level: 4
Level up: 98% Level up: 98% Level up: 98%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Jul 2019
Location: Cleveland, OH
Own a Commander?: Yes
Model year: 2006
Trim Package: Sport
Power-Train: 4.7L V-8
4WD
If 4WD - system: QT-II
Posts: 32
I've had both headlight bulbs go out at the same time before in a previous car. I even took into a shop to have it looked at because I thought it was an electrical issue. Felt like an idiot when they told me it was just the bulbs!! What are the odds of that happening!!!
Big Blue likes this.
dar124 is offline  
Sponsored Links
Advertisement
 
Reply

  Jeep Commander Forums: Jeep Commander Forum > Jeep Commander Discussion > New Member Section

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jeep Commander Forums: Jeep Commander Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome