New member/need help/strange electrical problem - Jeep Commander Forums: Jeep Commander Forum
New Member Section Drop in, say Hi and meet the community

 
LinkBack Thread Tools Display Modes
post #1 of 8 (permalink) Old 10-17-2019, 10:22 AM Thread Starter
Junior Member
Points: 6, Level: 1 Points: 6, Level: 1 Points: 6, Level: 1
Level up: 11% Level up: 11% Level up: 11%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Oct 2019
Location: Utah
Own a Commander?: Yes
Model year: 2008
Trim Package: Sport
Power-Train: 3.7L V-6
4WD
If 4WD - system: QT-I
Current Mileage: 156000
Posts: 1
Question New member/need help/strange electrical problem

Hello,
Thanks for this website,
I have had my 08 commander for 7 years. Been one of the best vehicles I have ever had.
Have had a very confusing problem for about a year.

Sometimes, the heater/ac blower completely stops + the dash directional LED display (N,S,E,W) turns to two solid dash lines --, AND the dash airbag light comes on all at the same time.
It usually happens when its hot outside, but now it happened in the cold. Usually it would be for just a few seconds then all go back to normal. Sometimes it would only fix itself if I turned the engine off and restarted it.

After one time, It reset, but the airbag light stayed on. So I got that checked and they replaced the mainspring. Everything was working great.
Then yesterday, it all happened at the same time again, but this time would not reset itself no matter what.

I assume there is some sort of electrical issue, but cannot figure out what connects AC/Heater blower + Nav. directional display + airbag light. It has always been all three or none of the three.
Any thoughts would be appreciated since it is getting cold here in Utah and my heater blower needs to work.

Thanks

Last edited by [email protected]; 10-17-2019 at 10:24 AM. Reason: update title
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old 10-17-2019, 11:48 AM
Senior Member
Points: 59,678, Level: 100 Points: 59,678, Level: 100 Points: 59,678, Level: 100
Level up: 0% Level up: 0% Level up: 0%
Activity: 50% Activity: 50% Activity: 50%
 
jeep5253's Avatar
 
Join Date: Jun 2006
Own a Commander?: Yes
Model year: 2006
Trim Package: Limited
Power-Train: 5.7L V-8 Hemi
4WD
If 4WD - system: QD-II
Posts: 14,912
Quote:
Originally Posted by [email protected] View Post
Hello,
Thanks for this website,
I have had my 08 commander for 7 years. Been one of the best vehicles I have ever had.
Have had a very confusing problem for about a year.

Sometimes, the heater/ac blower completely stops + the dash directional LED display (N,S,E,W) turns to two solid dash lines --, AND the dash airbag light comes on all at the same time.
It usually happens when its hot outside, but now it happened in the cold. Usually it would be for just a few seconds then all go back to normal. Sometimes it would only fix itself if I turned the engine off and restarted it.

After one time, It reset, but the airbag light stayed on. So I got that checked and they replaced the mainspring. Everything was working great.
Then yesterday, it all happened at the same time again, but this time would not reset itself no matter what.

I assume there is some sort of electrical issue, but cannot figure out what connects AC/Heater blower + Nav. directional display + airbag light. It has always been all three or none of the three.
Any thoughts would be appreciated since it is getting cold here in Utah and my heater blower needs to work.

Thanks
Welcome to the forum, @[email protected] ! Your problem is one I haven't seen here before, so I have no help to offer. Hopefully one of the members can give you some guidance on what to do. Also, it is not recommended to use your email address as your username.

.

2006 Steel Blue 5.7L HEMI Limited 4x4 Build Date: June 9, 2006 Hour 14
Interior: Dark Slate/Light Graystone with Saddle Brown Leather Seats
Quadra-Drive II, NAV, DVD, Trailer Tow Group IV, Off-Road Group II, Remote Start, UConnect, Rear Backup Camera, Chrome Wheels,
Magnaflow cat-back exhaust, Daytime Running Lights enabled, 2" Rough Country Lift with 265/70R17 Goodyear Wrangler AT/S
jeep5253 is offline  
post #3 of 8 (permalink) Old 10-19-2019, 01:58 AM
Super Moderator
Points: 24,685, Level: 95 Points: 24,685, Level: 95 Points: 24,685, Level: 95
Level up: 34% Level up: 34% Level up: 34%
Activity: 100% Activity: 100% Activity: 100%
 
Big Blue's Avatar
 
Join Date: Oct 2015
Location: East Coast of Florida; Proud to have served.
Own a Commander?: Yes
Model year: 2008
Trim Package: Sport
Power-Train: 4.7L V-8
4WD
If 4WD - system: QT-II
Current Mileage: 101,200
Posts: 5,666
Garage
Quote:
Originally Posted by [email protected] View Post
Hello,
Thanks for this website,
I have had my 08 commander for 7 years. Been one of the best vehicles I have ever had.
Have had a very confusing problem for about a year.

Sometimes, the heater/ac blower completely stops + the dash directional LED display (N,S,E,W) turns to two solid dash lines --, AND the dash airbag light comes on all at the same time.
It usually happens when its hot outside, but now it happened in the cold. Usually it would be for just a few seconds then all go back to normal. Sometimes it would only fix itself if I turned the engine off and restarted it.

After one time, It reset, but the airbag light stayed on. So I got that checked and they replaced the mainspring. Everything was working great.
Then yesterday, it all happened at the same time again, but this time would not reset itself no matter what.

I assume there is some sort of electrical issue, but cannot figure out what connects AC/Heater blower + Nav. directional display + airbag light. It has always been all three or none of the three.
Any thoughts would be appreciated since it is getting cold here in Utah and my heater blower needs to work.

Thanks
Welcome to the forum @[email protected] ; My first thought would be to have your battery checked to make sure it is putting out the proper voltage; A weak battery putting out less than optimal voltage can cause all kinds of electrical gremlins; I'd also have your alternator checked out, while you're at it.

Anyway, Post some pics of your Commander when you can; Here are some links if you want to order any parts for repairs or upgrades to your XK;

Chrysler/Jeep Factory Parts: https://www.factorychryslerparts.com/

North American Parts: https://northamericanparts.rpmware.c...unt/login.aspx

JeepinByAl: JBAoffroad.com

JustforJeeps.com - https://www.justforjeeps.com/

Rough County lift kits - Suspension Lift Kits, Body Lifts, Leveling Kit, 4x4, Jeep, Chevy, Dodge, Ford, Off-road Truck | Rough Country Suspension SystemsŪ

AFE: Advanced FLOW Engineering | Engineered Adrenaline

CARiD.com - https://www.carid.com/?gclid=CjwKEAj...NrrxoCEBbw_wcB

Bilstein shocks & struts - Home

WAM Custom Bumpers - https://wambumpers.com/

4WheelParts.com - Truck Parts & Jeep Parts - Lift Kits, Winches, Tonneau Covers, Tires, Wheels, Bumpers, Performance ? 4 Wheel Parts

RockAuto - https://www.rockauto.com/en/catalog/...catalog%2Fjeep

Also, please read the new member required reading below if you haven't done so already; lots of good information in here;

REQUIRED READING!!! New Member Introduction post & other important new member info.

Thanks and again, welcome aboard.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Big Blue is offline  
 
post #4 of 8 (permalink) Old 10-19-2019, 12:16 PM
Member
Points: 5,232, Level: 46 Points: 5,232, Level: 46 Points: 5,232, Level: 46
Level up: 41% Level up: 41% Level up: 41%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: May 2013
Location: Littleton, Colorado
Own a Commander?: Yes
Model year: 2006
Trim Package: Limited
Power-Train: 5.7L V-8 Hemi
4WD
If 4WD - system: QD-II
Current Mileage: 125000
Posts: 39
I had an electrical situation not all that dissimilar, though not as severe, and it turned out to be my ignition key cylinder. It was a noted problem that in severe cases would cause the truck to shut down for no apparent reason. You might be able to check it by supporting the key vertically to check for sagging. May not be the answer but something easy to check.
geauxgolf is offline  
post #5 of 8 (permalink) Old 10-19-2019, 01:08 PM
Super Moderator
Points: 24,685, Level: 95 Points: 24,685, Level: 95 Points: 24,685, Level: 95
Level up: 34% Level up: 34% Level up: 34%
Activity: 100% Activity: 100% Activity: 100%
 
Big Blue's Avatar
 
Join Date: Oct 2015
Location: East Coast of Florida; Proud to have served.
Own a Commander?: Yes
Model year: 2008
Trim Package: Sport
Power-Train: 4.7L V-8
4WD
If 4WD - system: QT-II
Current Mileage: 101,200
Posts: 5,666
Garage
Quote:
Originally Posted by geauxgolf View Post
I had an electrical situation not all that dissimilar, though not as severe, and it turned out to be my ignition key cylinder. It was a noted problem that in severe cases would cause the truck to shut down for no apparent reason. You might be able to check it by supporting the key vertically to check for sagging. May not be the answer but something easy to check.
@geauxgolf; It almost sounds like you're referring to the P57 ignition switch recall, which was specific to the 2008 model year - see the attached .PDF;

Also you are receiving a forum warning for your user profile being incomplete; Please follow the guidance in the forum warning & complete your user profile as directed; Thank you.
Attached Files
File Type: pdf P57.pdf (183.6 KB, 4 views)


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Big Blue is offline  
post #6 of 8 (permalink) Old 10-19-2019, 01:17 PM
Super Moderator
Points: 24,685, Level: 95 Points: 24,685, Level: 95 Points: 24,685, Level: 95
Level up: 34% Level up: 34% Level up: 34%
Activity: 100% Activity: 100% Activity: 100%
 
Big Blue's Avatar
 
Join Date: Oct 2015
Location: East Coast of Florida; Proud to have served.
Own a Commander?: Yes
Model year: 2008
Trim Package: Sport
Power-Train: 4.7L V-8
4WD
If 4WD - system: QT-II
Current Mileage: 101,200
Posts: 5,666
Garage
Quote:
Originally Posted by [email protected] View Post
Hello,
Thanks for this website,
I have had my 08 commander for 7 years. Been one of the best vehicles I have ever had.
Have had a very confusing problem for about a year.

Sometimes, the heater/ac blower completely stops + the dash directional LED display (N,S,E,W) turns to two solid dash lines --, AND the dash airbag light comes on all at the same time.
It usually happens when its hot outside, but now it happened in the cold. Usually it would be for just a few seconds then all go back to normal. Sometimes it would only fix itself if I turned the engine off and restarted it.

After one time, It reset, but the airbag light stayed on. So I got that checked and they replaced the mainspring. Everything was working great.
Then yesterday, it all happened at the same time again, but this time would not reset itself no matter what.

I assume there is some sort of electrical issue, but cannot figure out what connects AC/Heater blower + Nav. directional display + airbag light. It has always been all three or none of the three.
Any thoughts would be appreciated since it is getting cold here in Utah and my heater blower needs to work.

Thanks
@[email protected]; Have you ever checked to see if all of your Commander's safety recalls & campaigns have been completed?

You can check to see if all of the factory recalls & campaigns have been completed for your Commander by clicking on the hyperlink below & plugging in the VIN;

https://www.mopar.com/en-us/my-vehic...ls/search.html

To get the factory build sheet for your Commander, enter your VIN here:

https://fcacommunity.force.com/RAM/s/equipment-listing

The factory build sheet will list all of the factory options & optional preferred equipment packages that your vehicle had installed from the factory when it was built.

The difference between a safety recall and a campaign is this; a safety recall pertains to a vehicle problem that is a safety concern; a campaign is a vehicle problem that is not a safety concern, but, pertains to customer satisfaction.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Last edited by Big Blue; 10-19-2019 at 01:20 PM.
Big Blue is offline  
post #7 of 8 (permalink) Old 10-19-2019, 01:29 PM
Member
Points: 5,232, Level: 46 Points: 5,232, Level: 46 Points: 5,232, Level: 46
Level up: 41% Level up: 41% Level up: 41%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: May 2013
Location: Littleton, Colorado
Own a Commander?: Yes
Model year: 2006
Trim Package: Limited
Power-Train: 5.7L V-8 Hemi
4WD
If 4WD - system: QD-II
Current Mileage: 125000
Posts: 39
Got the required update completed, thanks for the heads up.
geauxgolf is offline  
post #8 of 8 (permalink) Old 10-19-2019, 01:35 PM
Super Moderator
Points: 24,685, Level: 95 Points: 24,685, Level: 95 Points: 24,685, Level: 95
Level up: 34% Level up: 34% Level up: 34%
Activity: 100% Activity: 100% Activity: 100%
 
Big Blue's Avatar
 
Join Date: Oct 2015
Location: East Coast of Florida; Proud to have served.
Own a Commander?: Yes
Model year: 2008
Trim Package: Sport
Power-Train: 4.7L V-8
4WD
If 4WD - system: QT-II
Current Mileage: 101,200
Posts: 5,666
Garage
Quote:
Originally Posted by geauxgolf View Post
Got the required update completed, thanks for the heads up.
@geauxgolf; Thank you very much for the speedy response; I appreciate it. I wish there were more members here like you.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Last edited by Big Blue; 10-19-2019 at 01:38 PM.
Big Blue is offline  
Sponsored Links
Advertisement
 
Reply

  Jeep Commander Forums: Jeep Commander Forum > Jeep Commander Discussion > New Member Section

Tags
electrical problems , need help , new post

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jeep Commander Forums: Jeep Commander Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome