WA580 pan leak - what would you do? - Jeep Commander Forums: Jeep Commander Forum
Problems / Dealer Service Having a problem with your vehicle? Were you treated fairly or poorly at a dealer? Warranty issues? Let us know.

 4Likes
  • 1 Post By Big Blue
  • 1 Post By Aerogt01
  • 1 Post By Aerogt01
  • 1 Post By Spraygun
 
LinkBack Thread Tools Display Modes
post #1 of 10 (permalink) Old 08-02-2019, 09:42 AM Thread Starter
Member
Points: 2,280, Level: 28 Points: 2,280, Level: 28 Points: 2,280, Level: 28
Level up: 87% Level up: 87% Level up: 87%
Activity: 26% Activity: 26% Activity: 26%
 
chaaz01's Avatar
 
Join Date: Jul 2017
Location: Berkley, Mi
Own a Commander?: Yes
Model year: 2010
Trim Package: Sport
Power-Train: 3.7L V-6
4WD
If 4WD - system: QT-I
Current Mileage: 79000
Posts: 54
Garage
Send a message via Skype™ to chaaz01
WA580 pan leak - what would you do?

My commander has a highly renowned WA580 transmission; its heritage comes from Mercedes during the daimlerchrysler days

It has a pan leak.

Common wisdom says replace the pan gasket

My issue is in opening this system, i lose some fluid.

Other common wisdom i've learned is don't replace the fluid in a 100K mileage transmission.

I guess I cant let the slow weepage to continue or ill suffer a different problem.

Do you guys think im in for a failure by replacing the gasket, losing the pan fluid and replacing it with new?


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Last edited by chaaz01; 08-02-2019 at 09:49 AM.
chaaz01 is offline  
Sponsored Links
Advertisement
 
post #2 of 10 (permalink) Old 08-03-2019, 11:22 PM
Super Moderator
Points: 21,500, Level: 92 Points: 21,500, Level: 92 Points: 21,500, Level: 92
Level up: 15% Level up: 15% Level up: 15%
Activity: 100% Activity: 100% Activity: 100%
 
Big Blue's Avatar
 
Join Date: Oct 2015
Location: East Coast of Florida
Own a Commander?: Yes
Model year: 2008
Trim Package: Sport
Power-Train: 4.7L V-8
4WD
If 4WD - system: QT-II
Current Mileage: 102,100
Posts: 5,193
Garage
Quote:
Originally Posted by chaaz01 View Post
My commander has a highly renowned WA580 transmission; its heritage comes from Mercedes during the daimlerchrysler days

It has a pan leak.

Common wisdom says replace the pan gasket

My issue is in opening this system, i lose some fluid.

Other common wisdom i've learned is don't replace the fluid in a 100K mileage transmission.

I guess I cant let the slow weepage to continue or ill suffer a different problem.

Do you guys think im in for a failure by replacing the gasket, losing the pan fluid and replacing it with new?
I'm kind of wondering where you heard that Chuck;

Draining & replacing the transmission fluid & filter is a 60,000 mile check on the Commander's maintenance schedule.

If I was in your position and you haven't changed the fluid in your transmission yet, I'd have everything changed; Gasket, Filter and the transmission fluid.

I understand there are different maintenance schedules based on how you drive your vehicle and how much towing you do, driving in stop & go traffic etc. but, I'd say 60,000 miles is a good guideline to use; I think I had mine changed at around 80,000 miles if I remember correctly, but, mine had 62,000 miles on it when I bought it in July of 2014.

The below pic is out of a 2007 Jeep Commander Owners manual but I don't think the model year really matters that much in this regard;



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Last edited by Big Blue; 08-03-2019 at 11:44 PM.
Big Blue is offline  
post #3 of 10 (permalink) Old 08-04-2019, 09:52 AM
Senior Member
Points: 2,150, Level: 27 Points: 2,150, Level: 27 Points: 2,150, Level: 27
Level up: 50% Level up: 50% Level up: 50%
Activity: 84% Activity: 84% Activity: 84%
 
Stircrayzy's Avatar
 
Join Date: Mar 2017
Location: East Detroit
Own a Commander?: Yes
Model year: 2006
Trim Package: Limited
Power-Train: 5.7L V-8 Hemi
4WD
If 4WD - system: QD-II
Current Mileage: 123000
Posts: 110
Quote:
Originally Posted by Big Blue View Post
I'm kind of wondering where you heard that Chuck;
Better question is , Who hasnt heard that ? Thats one of the first fairy tales you learn and debunk when you start buying older cars!
Stircrayzy is offline  
 
post #4 of 10 (permalink) Old 08-04-2019, 10:55 AM
Super Moderator
Points: 21,500, Level: 92 Points: 21,500, Level: 92 Points: 21,500, Level: 92
Level up: 15% Level up: 15% Level up: 15%
Activity: 100% Activity: 100% Activity: 100%
 
Big Blue's Avatar
 
Join Date: Oct 2015
Location: East Coast of Florida
Own a Commander?: Yes
Model year: 2008
Trim Package: Sport
Power-Train: 4.7L V-8
4WD
If 4WD - system: QT-II
Current Mileage: 102,100
Posts: 5,193
Garage
Quote:
Originally Posted by Stircrayzy View Post
Better question is , Who hasnt heard that ? Thats one of the first fairy tales you learn and debunk when you start buying older cars!
I see where you're coming from, but honestly, I've never heard that before.
Stircrayzy likes this.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Big Blue is offline  
post #5 of 10 (permalink) Old 08-05-2019, 12:39 AM
Member
Points: 5,412, Level: 47 Points: 5,412, Level: 47 Points: 5,412, Level: 47
Level up: 31% Level up: 31% Level up: 31%
Activity: 68% Activity: 68% Activity: 68%
 
Join Date: Jul 2012
Own a Commander?: Yes
Model year: 2007
Trim Package: Sport
Power-Train: 4.7L V-8
4WD
If 4WD - system: QT-II
Current Mileage: 157k
Posts: 61
I think it's more of: If you're already having problems don't change the fluid.

However, you've got bigger fish to fry if dirty fluid is what's holding your tranny together. Best get that 100k fluid changed out.
Big Blue likes this.
Aerogt01 is offline  
post #6 of 10 (permalink) Old 08-05-2019, 12:09 PM
Senior Member
Points: 4,295, Level: 41 Points: 4,295, Level: 41 Points: 4,295, Level: 41
Level up: 73% Level up: 73% Level up: 73%
Activity: 89% Activity: 89% Activity: 89%
 
Wombler's Avatar
 
Join Date: Jun 2014
Location: California
Own a Commander?: Yes
Model year: 2006
Trim Package: Limited
Power-Train: 5.7L V-8 Hemi
4WD
If 4WD - system: QD-II
Current Mileage: 113676
Posts: 104
Garage
Yea, my dad taught me that old saying for tranny fluid and diff fluids.
"Don't change them" ....I don't exactly remember what his reasoning was, honestly. Something about everything in it is adapted to the fluid, or new fluid takes stuff out/away, or something.

.....I don't live by that anymore

2006 Dark Khaki Limited, Hemi, QD-II w/ all the options.
Inertia Performance Heads, Full SRT 6.1 Valve Train, Custom Crower Cam, Double Roller Timing Set, Trend Performance forged Pushrods, High PSI Oil Pump, ARH Long Tube Headers and Mids, Borla Catback, aFe Stage 2 Intake, AEM X-Series WB UEGO & 100psi Oil Guages, PowerStop Drilled & Slotted Rotors, MDS On Light, Kenwood in-dash Nav, HID Projectors and full LED lighting upgrade

Need to get it on a dyno....
Wombler is offline  
post #7 of 10 (permalink) Old 08-06-2019, 09:21 AM Thread Starter
Member
Points: 2,280, Level: 28 Points: 2,280, Level: 28 Points: 2,280, Level: 28
Level up: 87% Level up: 87% Level up: 87%
Activity: 26% Activity: 26% Activity: 26%
 
chaaz01's Avatar
 
Join Date: Jul 2017
Location: Berkley, Mi
Own a Commander?: Yes
Model year: 2010
Trim Package: Sport
Power-Train: 3.7L V-6
4WD
If 4WD - system: QT-I
Current Mileage: 79000
Posts: 54
Garage
Send a message via Skype™ to chaaz01
Hi again - maybe im generalizing based on the historic knowledge i had from owning a suburban for years. My transmission is at 102K now and im leery about doing this because I suspected that it might do more damage and not knowing if it had ever been changed before.

oh and after researching i believe its an NAG1 not a WA580 - not sure if that makes a difference.

As for clearances, it looks like my NAG1 pan drops pretty easily so I could drop the pan and replace the gasket/filter. Just dont understand how im going to properly fill / measure the fullness once i do that because it doesn't appear to have a filler?

Thanks in advance for your thoughts / wisdom / experience on this matter.

BTW - suspension mods are doing well - one thing i thought i should consider is elongated sway bar links as with a 2" RC lift, they look pulled upward with standard links attached. unsure if it matters


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
chaaz01 is offline  
post #8 of 10 (permalink) Old 08-06-2019, 11:06 AM
Super Moderator
Points: 21,500, Level: 92 Points: 21,500, Level: 92 Points: 21,500, Level: 92
Level up: 15% Level up: 15% Level up: 15%
Activity: 100% Activity: 100% Activity: 100%
 
Big Blue's Avatar
 
Join Date: Oct 2015
Location: East Coast of Florida
Own a Commander?: Yes
Model year: 2008
Trim Package: Sport
Power-Train: 4.7L V-8
4WD
If 4WD - system: QT-II
Current Mileage: 102,100
Posts: 5,193
Garage
Quote:
Originally Posted by chaaz01 View Post
Hi again - maybe im generalizing based on the historic knowledge i had from owning a suburban for years. My transmission is at 102K now and im leery about doing this because I suspected that it might do more damage and not knowing if it had ever been changed before.

oh and after researching i believe its an NAG1 not a WA580 - not sure if that makes a difference.

As for clearances, it looks like my NAG1 pan drops pretty easily so I could drop the pan and replace the gasket/filter. Just dont understand how im going to properly fill / measure the fullness once i do that because it doesn't appear to have a filler?

Thanks in advance for your thoughts / wisdom / experience on this matter.

BTW - suspension mods are doing well - one thing i thought i should consider is elongated sway bar links as with a 2" RC lift, they look pulled upward with standard links attached. unsure if it matters
Chuck;

The W5A580 and NAG1 transmission are one and the same; It's just another name that transmission is known by. Same transmission I had in my previous vehicle, which was a 2008 WK with the 3.7L V-6.

You have to have the transmission fluid & filters changed; that's almost as bad as driving your engine for 100,000 miles and never changing the oil & filter. Obviously transmission fluid doesn't break down nearly as fast as engine oil, but, you catch my drift I hope.

Budget aside, I would probably take it into a reputable shop and have it done. You can either pay now, or, pay later - but ignoring the problem or putting it off, certainly won't make it go away. Here is some additional info for you;

https://www.transmissionrepaircostgu...sion-problems/


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Last edited by Big Blue; 08-06-2019 at 11:18 AM.
Big Blue is offline  
post #9 of 10 (permalink) Old 08-06-2019, 11:16 AM
Member
Points: 5,412, Level: 47 Points: 5,412, Level: 47 Points: 5,412, Level: 47
Level up: 31% Level up: 31% Level up: 31%
Activity: 68% Activity: 68% Activity: 68%
 
Join Date: Jul 2012
Own a Commander?: Yes
Model year: 2007
Trim Package: Sport
Power-Train: 4.7L V-8
4WD
If 4WD - system: QT-II
Current Mileage: 157k
Posts: 61
Fill it by the dipstick tube, with approximately as much as you drained.

DO NOT OVERFILL (removing fluid will involve sticking a hose down the dipstick tube and pulling some out with a syringe).

Check the level with it cold after engaging fwd/reverse gears, add as necessary. Drive it to get it warmed up, and check again against the hot level.

Be VERY careful putting the pan back on, though. It it's easy to accidentally cross thread the bolts, and then you need to go buy yourself helicoil kit (ask me how I know...).
Wombler likes this.
Aerogt01 is offline  
post #10 of 10 (permalink) Old 08-06-2019, 11:56 AM
Senior Member
Points: 4,977, Level: 45 Points: 4,977, Level: 45 Points: 4,977, Level: 45
Level up: 14% Level up: 14% Level up: 14%
Activity: 15% Activity: 15% Activity: 15%
 
Join Date: Jun 2014
Location: Houston ,Texas
Own a Commander?: Yes
Model year: 2006
Trim Package: Limited
Power-Train: 4.7L V-8
2WD
If 4WD - system: QT-I
Current Mileage: 253,000
Posts: 129
Do yourself and your wallet a favor. Take it to the Chrysler dealer.
You're right. Your transmission probably doesn't have a dipstick. Because those transmissions don't. They have a filler cap. There are special tools to measure the oil level. And they're not left in the dipstick filler tube. And also the temperature has to be measured as well.
You can buy your own measuring tool. But then you have to figure out how you're going to measure the temperature of the oil.That's one of the most crucial parts of doing the procedure.
At one hundred thousand miles. You're there. It's time to do it now. There really are just too many procedures and hassles for the average do it yourselfer. Plus you have to drop the pan and all the oil spills out. That's also going to be hard, unless you have a lift at your house.
you wanted some thoughts, wisdom and experience on this matter.Well, I just gave you some.
Go to the dealer. Now.

Sent from my Samsung Galaxy, using speech to text
Big Blue likes this.
Spraygun is offline  
Sponsored Links
Advertisement
 
Reply

  Jeep Commander Forums: Jeep Commander Forum > Jeep Commander Discussion > Problems / Dealer Service

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jeep Commander Forums: Jeep Commander Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome