Jeep Commander Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Hello all! New to the forums but not to Jeeps!

I have been searching all over the web, talking to dealerships and local shade treeirs. I have some questions that I think I have the answers to BUT....

#1= The motor runs rough and misses. The codes are P0032 and P1128. So with research I have found the it is the O2 Bank 1 Sensor 1. I have bough all new O2 sensors and plan on replacement today, if the weather holds. In my past experience with Jeep the O2 sensor will cause all kinds of issues, to include the rough and miss running. THE question is... Would it also limit the RPMs to 4k (or less)?

#2= The motor has an small oil leak on the drivers side at the base of the oil fill neck. I have not taken anything apart yet to see if it is cracked or just a seal. Is this a common leak? No mention of it on the engine posts.

#3= The Nav screen does not work. I have found all kinds of suggestions for "quick fix" none of it works. Can I just replace it with a new one from Crutchfield of BestBuy ETC? What will be the issues that I have with doing a replacement?

#4= This Jeep has the DVD/Screen in the back. Can this be removed? My kids are not little and they have ZERO interest in using this thing. What parts would I need to cover up the holes? I cant seem to find that anywhere.

Last question whats a good "Book" for diagrams and pictures of breakdowns of parts and stuff for this Jeep? I have had Chiltons manuals since I was able to hold a wrench but they seem to have fallen off in popularity for YouTube and the Web.

Thank all that read. And Double thank you for anyone responding! :D

Patrick
 

·
Registered
Joined
·
16 Posts
Hi there.
#1. It sound like you might be in limp mode because of the bad sensor(s). I would replace all the O2 sensors at the same time. Hopefully that will make the engine happy.
#3 The radio screen can easily be replaced if you can find the part. There are also companies who repair your existing radio for about $200. Google Infotainment. You can put an aftermarket double din radio in as a replacement. Crutchfield is a good company that can help you with information on any cables you need to do the swap.
#4 There will be a big square hole on the headliner when you remove the VES. It may also hurt your resale price if you ever sell your Commander since it was a upgrade option. I would just fold it up and forget it.
John
 

·
Registered
Joined
·
16 Posts
Also, you can get service manuals on disc on eBay. I don’t know how good they are but they are described as factory service manuals.
John
 

·
Registered
Joined
·
162 Posts
ive looked everywhere for a chiltons/haynes, and they do not exist for the commander. I bought the Ebay pdf version of the factory service manual, but at 5700+pages, its not the most intuitive thing to use for repairs. However, once you find what you need the info is Plentiful!
The other option is buy the chiltons for a grand cherokee, they are very similar mechanically, and would likely get you through most repairs.
I agree with John. would not remove the DVD player, its not even in the way. If you get one of those little ataris or NES, they can be gaming back there too using the RCA Inputs!
 

·
Registered
Joined
·
4 Posts
Discussion Starter #5
Thanks for the replies!

My O2 sensors are driving me batty. Im a BIG guy (6'5" 325lbs) I CAN NOT FOR THE LIFE OF ME get my fat ass arm in to unplug the sensors. I got the drivers side with little issues. The passenger side ones are killing me. I guess I will have to get creative ;) Once they are changed do I need to "reset" the system to get it out of limp mode? or will it just fix itself? My WJ 4.7 did this to me once and after turning it off and back on it seemed to fix that.

After talking to my wife we are going to just leave the DVD player in place. I may try to find a local aftermarket shop that may do a custom install of something but that's kinda expensive and not really a bit deal right now.

I think I will order the PDF Factory Service manual. I LOVE having plenty of info.

Thanks again!
 

·
Registered
Joined
·
16 Posts
It should reset its self on start up after you install the new sensors. You might unhook the negative battery cable for a bit to reset the computer. After you complete a “driving cycle” and it doesn’t go back into limp mode you should be good. A driving cycle usually takes a day or two of normal driving.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #8
So if anyone is following this..... I changed the spark plugs. They where black that base and the tip was browns and chalky looking. Nothing bad but looks like they where the original plugs. With only 122k on it and the last owner being a young lady that was GIVEN the Jeep, I would say they where original.

Next. I still CAN NOT get the O2 sensors on the pass side. The Upstream on the pass side and both downstream. Do I have to drop the Y pipe to get these?
ALSO: The code keeps coming back as P0032 (Only code I have now) That is listed as Bank 1 Sensor 1.... I changed the driver side upstream. I was able to get to that one. Is the driver side Bank 1? or is the pass side Bank 1?

The motor will not go over 4k. Ive reset the codes, I disconnected the battery for 30 mins. I started it back up. Engine light came on RIGHT away with code P0032 and it wont rev past 4k. The limiter starts to kick in at 3500 and it wont go over 4k. Is this normal for a having a code? or is this the normal limiter for the motor?

Thanks again

Patrick
 
1 - 9 of 9 Posts
Top