Jeep Commander Forum banner

21 - 24 of 24 Posts

·
Administrator
Joined
·
15,246 Posts
Also the trans has stared to shift hard when under a load (Heavy pedal use to accelerate) If you take it easy or just normal it shifts fine. Any ideas for me to look at? I have the Trans filters and fluid to change tomorrow and the oil also. HOPING that will fix it.
@cjxjman If I were you I would only use the OEM Mopar filters. And be sure to use ATF+4 transmission fluid. Also, a certified Jeep mechanic told me not to use a gasket on the pan. It comes from the factory without one. You should only seal it with RTV sealant, otherwise it will leak he said.

.
 

·
Registered
Joined
·
12 Posts
Discussion Starter #22
The filters I got where from Advance but say CarQuest on them. I was hoping they would be better then the Autozone ones that just say china..... I would believe that about the seal. My old 96 XJ I used the seal but also used a small amount of RTV on both sides. It never leaked after the filter change. It had 234k on it before I parted ways with it.
 

·
Administrator
Joined
·
6,288 Posts
UPDATE: Got a new PCM/ECU/TCM and everything seems to have resolved. The only issue I still have is the P0032 code comes back up. And it is immediate. Not after a few mins or what not. As soon as the code is cleared the light comes back on. I believe the wire is broken or maybe a back heater circuit.

The next thing I have an issue with is that when I am sitting still at idle I can not turn the wheels. There its like the power steering is turned off. Step on the gas and you can turn the wheel as long as you rev up the motor past 1k rpms.

Also the trans has stared to shift hard when under a load (Heavy pedal use to accelerate) If you take it easy or just normal it shifts fine. Any ideas for me to look at? I have the Trans filters and fluid to change tomorrow and the oil also. HOPING that will fix it.

Thanks again in advance for any ideas or help!

Patrick

ps Wife agreed to let me put a 2" spacer lift on it and more aggressive tires. She says that its a family car not an off roader. So I guess I will have to look at my WJ for off road 4" Lift Bigger tires... New axles .... lol
Patrick; Like I told you 2 weeks ago, change your transmission fluid & filters and see where you're at when it's done.
 

·
Registered
Joined
·
377 Posts
Sounds like you almost have it.Gasket will work fine as long as your torque it right. The pan filter has a seal that needs to be seated correctly or you will have issues. I used a wix filter kit w/ 2 filters and a gasket.
 
21 - 24 of 24 Posts
Top