Jeep Commander Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Looking for help with wiring diagrams for BA OEM factory stereo. My factory amp works w stock head unit but not aftermarket. I believe the factory amp is not turning on because there is another wiring harness that normally hooks up to stock stereo but not to the wiring harness for an aftermarket head unit. Looking at the second small harness it says amp right on it in small letters...just as the other harness has written on it for the speaker wires going to amp. I think this little problem has caused a lot of issues for a lot of people...thinking the factory amp was bad and needing to be replaced and so on... Thanks.
 

·
Administrator
Joined
·
15,503 Posts
@WESTCOAST BC420 Welcome to the forum! Please tell us a little about your Commander (model trim, engine, drive train, mileage, etc.) And please post some pics when you get a chance. We love seeing the members Commanders. Thanks.

.
 

·
Administrator
Joined
·
6,634 Posts
Looking for help with wiring diagrams for BA OEM factory stereo. My factory amp works w stock head unit but not aftermarket. I believe the factory amp is not turning on because there is another wiring harness that normally hooks up to stock stereo but not to the wiring harness for an aftermarket head unit. Looking at the second small harness it says amp right on it in small letters...just as the other harness has written on it for the speaker wires going to amp. I think this little problem has caused a lot of issues for a lot of people...thinking the factory amp was bad and needing to be replaced and so on... Thanks.
Looking for help with wiring diagrams for BA OEM factory stereo. My factory amp works w stock head unit but not aftermarket. I believe the factory amp is not turning on because there is another wiring harness that normally hooks up to stock stereo but not to the wiring harness for an aftermarket head unit. Looking at the second small harness it says amp right on it in small letters...just as the other harness has written on it for the speaker wires going to amp. I think this little problem has caused a lot of issues for a lot of people...thinking the factory amp was bad and needing to be replaced and so on... Thanks.
@WESTCOAST BC420;



Welcome to the forum.

Here are some links if you need to order any more parts for repairs or upgrades to your XK;

Chrysler/Jeep Factory Parts: https://www.factorychryslerparts.com/

North American Parts: https://northamericanparts.rpmware.c...unt/login.aspx

JeepinByAl: JBAoffroad.com

JustforJeeps.com - https://www.justforjeeps.com/

Rough County lift kits - Suspension Lift Kits, Body Lifts, Leveling Kit, 4x4, Jeep, Chevy, Dodge, Ford, Off-road Truck | Rough Country Suspension Systems®

4 inch XK Superlift;
AFE: Advanced FLOW Engineering | Engineered Adrenaline

CARiD.com - https://www.carid.com/?gclid=CjwKEAj...NrrxoCEBbw_wcB

Bilstein shocks & struts - Home

WAM Custom Bumpers - https://wambumpers.com/

Jeep Steel Bumpers
4WheelParts.com - Truck Parts & Jeep Parts - Lift Kits, Winches, Tonneau Covers, Tires, Wheels, Bumpers, Performance ? 4 Wheel Parts

RockAuto - https://www.rockauto.com/en/catalog/...catalog%2Fjeep

Also, please read the New Member Required Reading below; Lots of good information for new members here;

REQUIRED READING!!! New Member Introduction post & other important new member info.

Thanks & again, welcome aboard.
 

·
Registered
Joined
·
390 Posts
Goto crutchfield.com and plug in what you have and they will tell you what you need. Believe the BA amp uses speaker level inputs, not preamp.
 
1 - 4 of 4 Posts
Top