Jeep Commander Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
I have an 06 commander limited, and recently the cd changer has just started cycling while the vehicle is on and off which is killing my battery. Ive taken the dash apart and unplugged the unit.

has anyone had any similar problems?

I was thinking about replacing it anyways, but the next questions is, What's the best solution so I can still use the Uconnect, steering wheel controls and the VES?


thanks guys
 

·
Premium Member
Joined
·
2,337 Posts
Buy another stock unit if you want to maintain full functionality, especially with the UConnect and VES systems. You can find them at decent prices on Ebay, or from other used parts vendors on the web.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
Thanks :)

do you know if the later models will work? 07 or 08? they have the aux plug which mine does not...
 

·
Super Moderator
Joined
·
14,938 Posts
Thanks :)

do you know if the later models will work? 07 or 08? they have the aux plug which mine does not...
'07 will be plug and play. '08 and up you will need a Lockpick adapter.
 

·
Registered
Joined
·
13 Posts
I just mailed mine to Jimmy Chen to repair the 6 disc changer. Apparently its a pretty common problem on the early REC units. I have an 06 as well. The manufacture date on the nav unit in mine was April 05. Here is his contact info. $150 to repair and you have to ship it to him.

Here is his paypal/email address
[email protected]


Here is his shipping address
ALPINE AUTO SOUND
140 HIRSCHFIELD PL
NEW MILFORD, NJ 07646


In my case I bought a used REC unit on ebay (it was 4 years newer) and just swapped them so I wouldn't have to go with a hole in the dash for 2 weeks. I plan on re-selling mine once I get it back. If you buy another one make sure it has the reverse camera port on the back. http://www.wkjeeps.com/wk_nav.htm (scroll down to "radio removal" for pics of the back) This way you can add that option later if you chose. The early REC units don't have it. I ran everything this weekend for the reverse camera and even tapped into my factory VES so I can play the video on the Nav screen as well as the overhead screen. I plan on doing a write up once I have it complete. The lockpick is out for delivery today to complete the setup. I took pics of which wires to tap into on the DVD player since there wasn't anything out there I could find that was correct.
 
1 - 6 of 6 Posts
Top