Jeep Commander Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter #1
A month or so ago I started getting a error with my Nav system saying that it can't read the disc. I have yet to try another disc but have one available to try. Last week I lost all of my preset radio stations somehow and now the Uconnect isn't working. I can't even get my phone to pick up the bluetooth.

I imagine all of these issues are somehow related but I have no clue how to fix it. Will I most likely have to buy a new radio?
 

·
Registered
Joined
·
953 Posts
When in doubt... reboot! That's one of the first things I do with computers. Maybe you should try that with yout truck. Disconnect the battery for 20-30 minutes to reset the computer. Also, you might want to have your battery tested to see if it's still ok. It seems a few of our members with '06 XKs are replacing weak batteries lately.

Good luck.

:eek:rangehat:
 

·
Registered
Joined
·
1,514 Posts
I had that problem (can't read disk)with my 06 just a couple hunderd miles after the warranty ran out. Service writer at dealer allowed me to get it repaired under warranty which was very nice. They tried a new disk and that didn't work, then they replaced the radio and another new disk no problems since.
 

·
Registered
Joined
·
953 Posts
If it were just that it can't read the disc, I'd say it' the disc or worse, the radio, but there are a bunch of other electrical problems. I'd hate for it to be the BUS, so starting with a reboot and a check of the battery are the simple, and basic, things to do.
 

·
Banned
Joined
·
277 Posts
I had the same problem almost a year ago with my 2006. Dealership tested a new disc and that solved it - unfortunately the discs are around $210 a piece. Good Luck
 

·
Registered
Joined
·
3,262 Posts
JeepMann,
As already stated, disco battery but before disconnecting, shut key off with radio turned on.
Disconnect negative cable and turn key on.
This will allow the radio to dump if you will, any residuals.
10 to 20 minutes later, turn key off and remove from switch.
Reconnect battery.
Start vehicle, go cruising, see how you did.
Anticipate strange upshifting while the computer goes through a relearn process.

Can't beat the price!

Good luck, Rob
 

·
Registered
Joined
·
14 Posts
Discussion Starter #7
JeepMann,
As already stated, disco battery but before disconnecting, shut key off with radio turned on.
Disconnect negative cable and turn key on.
This will allow the radio to dump if you will, any residuals.
10 to 20 minutes later, turn key off and remove from switch.
Reconnect battery.
Start vehicle, go cruising, see how you did.
Anticipate strange upshifting while the computer goes through a relearn process.

Can't beat the price!

Good luck, Rob

I tried this but no luck. Does the UConnect work through the radio or is it separate. Not sure if I am looking at electrical issues or just a bad head unit.
 

·
Registered
Joined
·
14 Posts
Discussion Starter #8
I found a procedure to reset the UConnect and it is now working. I also had a chance to try another Nav disc and it works! Now I need to find a new disc. Is there a list somewhere that shows the disc revisions and what is the most recent?
 
1 - 8 of 8 Posts
Top