Jeep Commander Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
Hey everyone. I just got done replacing the shift solenoids and conductor plate on my 06 3.7 commander with the nag1 transmission. I went to crank it up (with high hopes I had solved my previous problem of getting stuck in 3rd or 4th gear but upon turning it off and restarting it would be fine for a little bit) only to find that I am now stuck in first gear and it will not allow me to gear select. I don't have access to a code reader at the time but plan to scan it asap to see what the codes are. However, reading through countless posts I think it may have something to do with the wire connector that goes in to the transmission on the passenger side. It does have transmission fluid on it from when I was working on it. Do you guys/gals think that it shorted the wiring there? or maybe theres fluid inside the connector on the transmission that needs to be cleaned out??? Any help would be greatly appreciated, and tia for your time.


I really hope someone can help....I miss driving my jeep...
 

·
Registered
Joined
·
151 Posts
I doubt the oil shorted the connection however it might insulate the connection from working so why not just clean it up with a little brake cleaner? Anyway, no one can guess your problem from nothing, you need to scan your error codes.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #4 ·
Ok so I was able to pull a code and I'm getting code P0757 shift solenoid B stuck open. I searched the forums and literally 0 results came back. Has anyone had this issue? Any recommendations on how to fix it?
 
1 - 4 of 4 Posts
Top