Jeep Commander Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
31 Posts
Discussion Starter #1
I have a 06 jeep commander 4.7. My fuel pump will not run. I parked the car, went into a store and when I came back out the jeep would not start. I towed it home. In turning the key to the on position and having my ear at the gas filler pipe I determined that the fuel pump was not running. I dropped the tank and replaced the pump. The jeep ran for 3 days and then stranded me as before. Towed it home and found the pump not to be running. Pulled the pump and bench tested the pump - it ran. I tested the old pump and it ran also. I checked the voltage at the pump and I had 12v present. I ran 2 wires from the battery to the fuel pump - bypassing everything and the jeep runs all day long. I did some research and replaced the the crank position sensor and the jeep ran for 3 days and stranded me again. Towed it home and replaced the CPR again, it would not start. I did some more research and replaced the cam position sensor. The jeep ran for about 2 1/2 weeks and then stranded me as before. I tried a second cam sensor and it did not start. I've replaced the fuse, relay, the crank position sensor, cam position sensor and now the powertrain control module. Nothing is making this jeep power the fuel pump. Where can I get a wiring diagram for the fuel pump system? I'm running low on patience, time and money with this jeep. any help would be appreciated, thanks.:brickwall:
 

·
Registered
Joined
·
452 Posts
Bring it to the dealer.... at least if they didn't fix it the first time, you would have paperwork/invoice for troubleshooting and whatever costs you incur for parts on the first visit; as a standard courtesy, they shouldn't charge you again for troubleshooting and surely something can be worked out for getting the 'right' diagnosis and part(s) replaced.

What you described is almost like a cat/mice or hit/miss game...and that's actually just as costly financially and a waste of your time.

That's my 2 cents.... hope you have it resolved already.
 

·
Registered
Joined
·
60 Posts
Sounds like you touched everything I would have suggested. Heres a link to an online chiltons. https://elibrary.mel.org/validate?url=http://0-infotrac.galegroup.com.elibrary.mel.org:80/itweb/lom_accessmich?db=CHLL
Copy and paste when it asks you for a DL. put in one letter and twelve numbers any combination will work. Hope this works. sounds like an intermittent short. Keep us posted and dont get discouraged. The only thing you havent checked is your ignition switch. That might be worth looking at and not very expensive or hard to put in.

Good Luck
 
1 - 3 of 3 Posts
Top