Jeep Commander Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Hello friends, I have a few issues with my 08 commander sport 4x4 135k miles i am looking for advice about.

The first is the other day it would not start or turn over just a click when trying to start it. My first thought was a bad battery so i hooked it up to the charger, put it on start, and attempted to start it. First attempt it did not start or turn over but second and subsequent attempts it did start. I took it to AutoZone and had the battery tested but they said it was ok. When it would not start all the lights and electronics worked fine and i could hear the clicks of the relays. The starter itself seems fine. I do not hear any noises or grinding from it. So the remaining possible causes for this would be: fuse box relay, neutral safety switch, and/or starter selenoid... any other causes? It is my understanding the neutral safety switch is part of the powertrain and therefore covered under the lifetime warranty correct? I of course cannot get it to replicate when i need to diagnose. It starts fine every time now.

Second issue is that when i turn the right blinker on the radio and the dash lights will dim. Only the right blinker not the left. Ideas? A short somewhere? How would someone even go about finding that and is it even worth it?

Next at higher speeds there is a humming noise that will start around 65 get louder and then go away around 70. If i let off the accelerator in that range the humming will go away and return when i give it gas again. Ideas? I thought it might have been the tires because this issue seemed to come about when i got new tires but then why would it go away when letting off the accelerator?

Lastly, When i go over a decent bump such as a speed hump it sounds like an old door is being opened or closed kinda like a creaking noise. The ride has not seemed to change at all. I assume this is the shocks/struts correct? I was reading that the rear are very easy to replace but unless you really know when you are doing then it would be best to have the front done by professionals. Is that correct advice?

Thanks!
 

·
Registered
Joined
·
1,585 Posts
The first problem is almost definitely the infamous "YELLOW WIRE" issue. It corrodes @ the connector to the starter. There are a million posts about it.

You can replace the harness and this is what most dealers do IIRC.

Its also possible to simply cut the end off and put a new connector with lots of dielectric grease and marine double layer heat shrink to prevent future corrosion.
 

·
Super Moderator
Joined
·
5,846 Posts
Hello friends, I have a few issues with my 08 commander sport 4x4 135k miles i am looking for advice about.

The first is the other day it would not start or turn over just a click when trying to start it. My first thought was a bad battery so i hooked it up to the charger, put it on start, and attempted to start it. First attempt it did not start or turn over but second and subsequent attempts it did start. I took it to AutoZone and had the battery tested but they said it was ok. When it would not start all the lights and electronics worked fine and i could hear the clicks of the relays. The starter itself seems fine. I do not hear any noises or grinding from it. So the remaining possible causes for this would be: fuse box relay, neutral safety switch, and/or starter selenoid... any other causes? It is my understanding the neutral safety switch is part of the powertrain and therefore covered under the lifetime warranty correct? I of course cannot get it to replicate when i need to diagnose. It starts fine every time now.

Thanks!
This particular issue sounds like it could possibly be a bad alternator.

That's something I would check out anyway.
 
1 - 3 of 3 Posts
Top