Jeep Commander Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
36 Posts
Discussion Starter #1 (Edited)
2" lift kit and minor problems

Hi all,

since I installed my 2" lift kit (with original shocks and struts, and tires 265/65/17) I have two minor problems, and I need your advice:

1) I hear a hit sound from the front when I go up a bump with speed like 10 - 15 KM ..
2) On a full lock (when doing a U turn), sometime the ESP light goes on.

any advices how to fix that?

thanks
 

·
Registered
Joined
·
2,194 Posts
I have exactly the same setup with 265/65/17 Mastercraft A/T tires and have no issues with ESP and bumps at all... even this size can fit stock commanders too without problem.
 

·
Registered
Joined
·
401 Posts
Make sure everything is tightened. I had a light knocking/hitting sound at low speeds over small bumps. I tightened my rear shocks and poof - no more knocking...
 

·
Registered
Joined
·
451 Posts
Hosnims;
The clunking is probably the steering rack/tie rods/balljoints/swaybar links that we have all gone through. The ESP light is just that you now have a little more difference in the tire rpm at full lock.
I would get the clunk taken care of especially if you have any warrenty left. The solution to the ESP light is...well... Don't turn so sharp!!!!!
 

·
Premium Member
Joined
·
2,337 Posts
I agree with JJ on the front components. I'm taking mine back in for the 4th time in under 12 months for the front end clunking, this time to a different dealer, hopefully they'll get the problem fixed this time.
 
1 - 6 of 6 Posts
Top