Jeep Commander Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Hello - I just finished replacing the water pump on my 4.7 Commander. I'm having an issue getting the coolant to circulate properly / fill the entire system. My heater is blowing cold and the temp gauge is running slightly over normal operating temp. Is there a way to bleed / burp the system? Thank you in advance for any and all advice!

Neal
 

·
Administrator
Joined
·
15,209 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #3
Thanks for the information. I was able to figure it out and get the Commander back on the road.
 

·
Administrator
Joined
·
15,209 Posts
Thanks for the information. I was able to figure it out and get the Commander back on the road.
What did you do ?
 

·
Registered
Joined
·
3,037 Posts
The safest thing to do is to follow the manufacturer's recommendations.

I have NOT changed coolant in my Commander yet, BUT, I have in other Chrysler Vehicles that have the same problem with air trapped in the cooling system.

To get all the old coolant out and the water I used to flush, I often pull the block drains and I disconnect a heater hose and use compressed air to blow the fluid out of the heater core.

A couple of tricks that have worked for me:

*When I refill, I leave the heater hose disconnected and elevated above the engine, fill till I get coolant to the top of the heater hose and reconnect it.

*After filling, I start the motor, rev it a bit, then shut it down and pull the pressure cap and top off the coolant level. Revving the motor causes the water pump to surge the coolant flow and will help move the air pockets out.

*Realizing I likely have trapped air in the cooling system, the first test drive is very short, just down the street and back, expecting it to overheat. Let it idle in the driveway watching the temp gauge, give the engine a rev or two, then let it cool off, pull the pressure cap and top off the cooling system.

*That usually gets enough air out that it won't over heat. The big clue if there is still enough air in the cooling system that you're in risk of overheating, the heater doesn't produce any heat because it still has air in it. When I'm getting heat out of the heater, I may NOT have all the air out of the system, but I got enough out that I have never had an overheating problem. I can't get heat out of the heater (and the engine is warmed up of course) I have run into overheating (NOT every time) and I don't consider the vehicle road worthy until I get that air out.

*Pulling that air bleed plug at the top (if it has one) near the top of the engine, often by or on the take-off for the upper radiator hose, can get the air out, remember you need to fill the system with the plug out. Or pulling a heater hose and elevate it above the engine as you fill helps also.

After this is all done, check the coolant level several times during the next dozen starts, warm up, cool down and top off as necessary. The air trapped in the system will work its way out over this time and the coolant level will drop.

Remember, to properly check coolant level, don't just check the coolant level in the Reservoir, with the engine cool, pull the pressure cap and make sure coolant is within an inch of the pressure cap. (The Reservoir is really an overflow tank, as the coolant warms it expands and forces it way past the pressure cap and into the reservoir/overflow tank, as the coolant cools it contracts forms a vacuum and sucks the coolant back into the system from the reservoir/overflow tank). So, if you have a leak in your coolant system, it will suck air back into the cooling system and NOT coolant from the reservoir/overflow tank, the tank level will remain the same, making you think your coolant level is good, but in reality you have air in the cooling system and the coolant level is dropping. So you have to pull the pressure cap and make sure the coolant level is within an inch of that pressure cap (of course, never pull that pressure cap until the coolant is cool).
 

·
Registered
Joined
·
5 Posts
Discussion Starter #6
What did you do ?
I was successful in burping the system after a series of short engine runs and adding coolant to the system. I first started by adding coolant to the radiator until full. I then filled the reservoir with coolant and started the vehicle. Once the temperature gauged reached operational temperature (which did not take long) I shut the engine off, relieved the pressure by backing off the radiator cap (use extreme caution) which would cause air to release into the coolant reservoir. I then let the engine cool which would cause the system to pull coolant from the reservoir. I repeated the above steps until my upper coolant hose had pressure on it while the engine was running and was hot to touch. I continued to keep an eye on the engine temperature gauge and reservoir level adding as needed.
I did see the removable plug on top of the engine and upper coolant hose... I tried removing to assist the evacuation of air from the system. I applied a comfortable amount of force to the aluminum components but, was unsuccessful in removing it.

I hope this helps...

Neal
 
1 - 6 of 6 Posts
Top