Jeep Commander Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
We just purchased a new Jeep Commander Limited with all the options and the 5.7 Hemi. Less than 1500 km ( Toronto, Canada ) the power steering failed - all the hydraulic fluid was lost. Went in for repair, Came back with engine problems, it's running rougher than before a very noticeable difference..Additionally while driving the tire pressure indicators intermittently drop in 7 PSI amounts - This happens on all for wheels and is very sporadic eg: the 2 front may indicate 234 and the rear tires are at 227, then it will reverse or sometimes only one will show the correct pressure. I suspect this is software related and maybe the onboard computer is trying to compensate in some strange way - hence the rough engine? Any one seen this. PS My dealership Unique Chrysler (Burlington) here in Ontario is absolutely useless..

Anyone aware if there is a "Lemon" law here in Ontario like some of the US states..

Cheers,
 

·
Registered
Joined
·
114 Posts
Well, that's distressing as h*ll -- very sorry to hear about your bad experiences. What happened with the hydraulics? A hose clamp or something more complicated?

Surely after you've exhausted your dealer's ability to help you should be able to get this fixed via Chrysler Canada? Now would not be the time for DC to let word of bad Commander experiences flourish...

Commo
Dearborn, MI
 

·
Registered
Joined
·
170 Posts
I'm not sure about lemon laws in Canada. If I were you, I'd take it upon yourself to contact DC direct. Goas far up the chain as possible. They may have you take it back in for more service but if the problems can not be fixed, I'd be on the phone to DC to negotiate that they buy it back and give you another one.
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top