Jeep Commander Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
Hey all, love reading the posts and find them helpfull, but now I need some help. I recently purchased a 2008 Jeep Commander. When I test drove it seemed fine but first the radio had no power to it at all, and sometimes it wouldn't start ether. I managed to trace that issue to the yellow starter wire so I just need a new wiring harness for the starter.

I had a friend run a wire from the stereo to the fuse box under the dash. He soft wired it into a 10amp fuse and now the stereo works.

But now the power windows and locks aren't working on any of the doors, The power seats are also not working nor is the heated seats, And the sunroof is also not working. I found a 20amp fuse blown under the dash and replaced it with no change. I removed the stereo wire from the fuse and still no change. I also tried disconnecting the Negative cable on the Battery for 10 mins and that didn't work ether.

I need help, I've found lots of talks about windows or seats but never both together. I also check the wire in the door boot and they were all good as well.:frown2::crying::headbang::rocket:
 

·
Registered
Joined
·
361 Posts
Before you go replacing a junction box, in the same area is a little power supply module. I think it's in between the 2 fuse boxes. Mine is taken apart so i can't verify, but the module is bolted to the side of one of the fuse boxes. The module specifically supplies power to all your interior electronics. I had issues with my electrical in the past, and it was pointed out to me yesterday that the interior wiring harness that connects to the underside of it had a broken clip so it could wiggle all it wanted. It was never removed when i had it until my swap, and i know i didnt break it when i did remove it. I'd check there first.
 
1 - 3 of 3 Posts
Top