Jeep Commander Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter #1
2008 jeep commander v8 Newer style 4.7 with dual plugs. This is my brothers jeep we bought it 2 years ago with a dropped valve seat at 110k ish miles so I replaced 1 head and did all valve stem seals on other. Now 2 years later 145k miles runs fine no engine light or anything It is losing oil somewhere no outside visual leaks. I dont really see any smoke even when up to temp/revving it. About 3 months ago I changed his oil because it was REALLY low would not read on dip stick got lucky kid never checks his oil. So here I am 5k miles later I go to change his oil and it was low I only got 3qt out of it... So I am kind of sumped on where the fk I am losing all this oil without noticeable symptoms. Also it has a vacuum leak somewhere on pass side intake towards front even tho I just changed the intake seals expecting a crack when I take it apart next time not sure if this would have anything to do with burning oil tho.
 

·
Registered
Joined
·
424 Posts
Do you smell burning oil after a drive? Valve covers leaking?
 

·
Registered
Joined
·
150 Posts
Curious if you figured this one out. If I don't change every 3k, my oil is magically burned off somewhere. No smells no rough idles none of that. I use straight full synthetic, beginning to wonder if thats my issue. Let me know if you found the culprit (knock on wood, I have no leaks and no shop has found any issues with her, they just told me to change it at 3k and stop going 5 and 7k where I'm lucky to get a couple of quarts back out when I change it).
 
1 - 3 of 3 Posts
Top