Jeep Commander Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Hey guys, my commander stalls once every few weeks. Engine just dies while driving. Almost exclusively happens at freeway speeds. Its sudden, no warning. Running, running, running, bam, engine cuts out. Throw it in N while coasting and stars again immediately. It has had warranty work to correct this issue probably 20 times and every time they have never correctly fixed the issue at the Dealership. Check engine light is not on and has no DTC's when scanned. Lets pretend that it hasn't had any work done to alleviate this issue, what would you recommend. I have lifetime powertrain warranty through Chrysler and they can not solve this issue and they then proceeded to offer me $500 to trade it in after i paid $3000 for lifetime warranty in 2010 so basically since they cannot solve this issue the truck is worthless to them on a trade in and will offer a insulting $500. Im upset and need some help. Thanks guys.
 

·
Super Moderator
Joined
·
5,763 Posts
Hey guys, my commander stalls once every few weeks. Engine just dies while driving. Almost exclusively happens at freeway speeds. Its sudden, no warning. Running, running, running, bam, engine cuts out. Throw it in N while coasting and stars again immediately. It has had warranty work to correct this issue probably 20 times and every time they have never correctly fixed the issue at the Dealership. Check engine light is not on and has no DTC's when scanned. Lets pretend that it hasn't had any work done to alleviate this issue, what would you recommend. I have lifetime powertrain warranty through Chrysler and they can not solve this issue and they then proceeded to offer me $500 to trade it in after i paid $3000 for lifetime warranty in 2010 so basically since they cannot solve this issue the truck is worthless to them on a trade in and will offer a insulting $500. Im upset and need some help. Thanks guys.
@Klaus Bartelt;

Welcome to the forum; So ideally you first post would have been a new member introduction in the new member section; You shouldn't have even been able to post anywhere but the new member section, until you reached 5 posts, so, I'll have to look into what's going on there.

Off the top of my head, I don't have answer for you, but hopefully someone else will chime in here; Give me a little time to try & search the forum and see what I can dig up that sounds like it might relate to your problem;

Thanks & again welcome aboard.
 

·
Registered
Joined
·
3 Posts
Sounds like a Throttle Position Sensor (TPS) intermittent failure. Had the same issue weeks ago but TPS replacement (cheap) fixed it.

Ther TPS input controls a lot of ECM functions and a glitch here or there will tell the computer to shut down.
 

·
Registered
Joined
·
1 Posts
I had the same problem and they couldn't find out the problem The dealer finally kept it for two months. . The problem they found was the coil pack was bad. They changed out the coil pack and spark plugs. I have had it back for a month and haven't had any stalling issues
 

·
Super Moderator
Joined
·
5,763 Posts
I had the same problem and they couldn't find out the problem The dealer finally kept it for two months. . The problem they found was the coil pack was bad. They changed out the coil pack and spark plugs. I have had it back for a month and haven't had any stalling issues
@JDC PENS;

Please complete your user profile as directed; This forum announcement is 2 years old.

https://www.jeepcommander.com/forums/5-general-commander-discussion/75441-attention-all-forum-members-mandatory-requirement.html
 

·
Registered
Joined
·
4 Posts
Discussion Starter #6
I had the same problem and they couldn't find out the problem The dealer finally kept it for two months. . The problem they found was the coil pack was bad. They changed out the coil pack and spark plugs. I have had it back for a month and haven't had any stalling issues
Hey thanks, did they change all eight coil packs or did they trace it down to just one?
The plugs were changed a while ago but I'm going to change them all again, it's probably about time.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #7 (Edited)
Sounds like a Throttle Position Sensor (TPS) intermittent failure. Had the same issue weeks ago but TPS replacement (cheap) fixed it.

Ther TPS input controls a lot of ECM functions and a glitch here or there will tell the computer to shut down.
Did you put a MOPAR TPS in, or did you go aftermarket?

And my commander is Gas/Ethanol and at the bottom of the picture attached you can see that the MOPAR TPS says Gas next to it so I am wondering is there a dedicated Gas/Ethanol TPS?
 

Attachments

·
Super Moderator
Joined
·
5,763 Posts
Did you put a MOPAR TPS in, or did you go aftermarket?

And my commander is Gas/Ethanol and at the bottom of the picture attached you can see that the MOPAR TPS says Gas next to it so I am wondering is there a dedicated Gas/Ethanol TPS?
The "gas" annotation is probably to differentiate between gas & diesel; I can't imagine that there's a special throttle position sensor for a Flex-Fuel vehicle.
 
1 - 8 of 8 Posts
Top